summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJacob Stiffler <j-stiffler@ti.com>2019-02-23 02:20:49 +0000
committerDenys Dmytriyenko <denys@ti.com>2019-02-26 21:30:32 +0000
commit72051b974fbeb3e6c714a379b0b3fcb6fefa71c8 (patch)
tree110b05de61a3934e44196c7ef634ffcd53592ce9
parent900177c2d1a0061c20d425d55220240c78b8c582 (diff)
downloadmeta-ti-72051b974fbeb3e6c714a379b0b3fcb6fefa71c8.tar.gz
gcc-arm-none-eabi: extend to nativesdk class
Signed-off-by: Jacob Stiffler <j-stiffler@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r--recipes-ti/devtools/gcc-arm-none-eabi_6-2017-q1-update.bb (renamed from recipes-ti/devtools/gcc-arm-none-eabi-native_6-2017-q1-update.bb)8
1 files changed, 6 insertions, 2 deletions
diff --git a/recipes-ti/devtools/gcc-arm-none-eabi-native_6-2017-q1-update.bb b/recipes-ti/devtools/gcc-arm-none-eabi_6-2017-q1-update.bb
index 1140f27a..ae3d1d72 100644
--- a/recipes-ti/devtools/gcc-arm-none-eabi-native_6-2017-q1-update.bb
+++ b/recipes-ti/devtools/gcc-arm-none-eabi_6-2017-q1-update.bb
@@ -3,7 +3,6 @@ LICENSE = "GPL-3.0-with-GCC-exception & GPLv3"
3 3
4LIC_FILES_CHKSUM = "file://share/doc/gcc-arm-none-eabi/license.txt;md5=c224e429f53a1a6ce70bf8986ea2990b" 4LIC_FILES_CHKSUM = "file://share/doc/gcc-arm-none-eabi/license.txt;md5=c224e429f53a1a6ce70bf8986ea2990b"
5 5
6inherit native
7require recipes-ti/includes/ti-paths.inc 6require recipes-ti/includes/ti-paths.inc
8 7
9SRC_URI = "https://developer.arm.com/-/media/Files/downloads/gnu-rm/6_1-2017q1/gcc-arm-none-eabi-6-2017-q1-update-linux.tar.bz2;name=gcc-arm-none" 8SRC_URI = "https://developer.arm.com/-/media/Files/downloads/gnu-rm/6_1-2017q1/gcc-arm-none-eabi-6-2017-q1-update-linux.tar.bz2;name=gcc-arm-none"
@@ -13,6 +12,9 @@ SRC_URI[gcc-arm-none.sha256sum] = "e7aad2579f02e3b095c6d7899ca5e6a70cfa9b8a8cbd6
13 12
14S = "${WORKDIR}/gcc-arm-none-eabi-6-2017-q1-update" 13S = "${WORKDIR}/gcc-arm-none-eabi-6-2017-q1-update"
15 14
15# only x86_64 is supported
16COMPATIBLE_HOST = "x86_64.*-linux"
17
16do_install() { 18do_install() {
17 install -d ${D}${GCC_ARM_NONE_TOOLCHAIN_RECIPE} 19 install -d ${D}${GCC_ARM_NONE_TOOLCHAIN_RECIPE}
18 cp -r ${S}/. ${D}${GCC_ARM_NONE_TOOLCHAIN_RECIPE} 20 cp -r ${S}/. ${D}${GCC_ARM_NONE_TOOLCHAIN_RECIPE}
@@ -20,4 +22,6 @@ do_install() {
20 22
21FILES_${PN} = "${GCC_ARM_NONE_TOOLCHAIN_RECIPE}/*" 23FILES_${PN} = "${GCC_ARM_NONE_TOOLCHAIN_RECIPE}/*"
22 24
23INSANE_SKIP_${PN} = "already-stripped" 25INSANE_SKIP_${PN} = "already-stripped libdir staticdev"
26
27BBCLASSEXTEND = "native nativesdk"