summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJianzhong Xu <xuj@ti.com>2018-09-24 20:59:34 +0000
committerDenys Dmytriyenko <denys@ti.com>2018-09-24 16:34:51 +0000
commit708863d503bdd4174ee412f1dd418b1650dad520 (patch)
treeabee13ea37bb8e896873956ea3bbddd199d17429
parent6a854e93404a9b190ed7b80fd18bb5e849da47f5 (diff)
downloadmeta-ti-708863d503bdd4174ee412f1dd418b1650dad520.tar.gz
mathlib: build MATHLIB C66x/C674x from source
Remove MATHLIB recipe that downloads pre-built MATHLIB from ti.com. Add new recipe to build MATHLIB for C66x or C674x from source code. Signed-off-by: Jianzhong Xu <xuj@ti.com> Signed-off-by: Jacob Stiffler <j-stiffler@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r--recipes-ti/includes/ti-paths.inc2
-rw-r--r--recipes-ti/mathlib/mathlib-c66x.inc29
-rw-r--r--recipes-ti/mathlib/mathlib-c66x_3.1.1.0.bb9
-rw-r--r--recipes-ti/mathlib/mathlib-c66x_git.bb5
-rw-r--r--recipes-ti/mathlib/mathlib-c674x_git.bb5
-rw-r--r--recipes-ti/mathlib/mathlib.inc72
6 files changed, 84 insertions, 38 deletions
diff --git a/recipes-ti/includes/ti-paths.inc b/recipes-ti/includes/ti-paths.inc
index f797a2d2..6c2b2001 100644
--- a/recipes-ti/includes/ti-paths.inc
+++ b/recipes-ti/includes/ti-paths.inc
@@ -51,6 +51,7 @@ export GCC_ARM_NONE_TOOLCHAIN_RECIPE = "${installdir}/gcc-arm-none-eabi"
51export TI_CGT_PRU_INSTALL_DIR_RECIPE = "${installdir}/cgt-pru" 51export TI_CGT_PRU_INSTALL_DIR_RECIPE = "${installdir}/cgt-pru"
52export DSPLIB_C66_INSTALL_DIR_RECIPE = "${installdir}/ti-dsplib-c66x-tree" 52export DSPLIB_C66_INSTALL_DIR_RECIPE = "${installdir}/ti-dsplib-c66x-tree"
53export MATHLIB_C66_INSTALL_DIR_RECIPE = "${installdir}/ti-mathlib-c66x-tree" 53export MATHLIB_C66_INSTALL_DIR_RECIPE = "${installdir}/ti-mathlib-c66x-tree"
54export MATHLIB_C674_INSTALL_DIR_RECIPE = "${installdir}/ti-mathlib-c674x-tree"
54export IMGLIB_C66_INSTALL_DIR_RECIPE = "${installdir}/ti-imglib-c66x-tree" 55export IMGLIB_C66_INSTALL_DIR_RECIPE = "${installdir}/ti-imglib-c66x-tree"
55export VLIB_C66_INSTALL_DIR_RECIPE = "${installdir}/ti-vlib-c66x-tree" 56export VLIB_C66_INSTALL_DIR_RECIPE = "${installdir}/ti-vlib-c66x-tree"
56export CG_XML_INSTALL_DIR_RECIPE = "${installdir}/ti-cg-xml-tree" 57export CG_XML_INSTALL_DIR_RECIPE = "${installdir}/ti-cg-xml-tree"
@@ -101,6 +102,7 @@ export TI_CGT_PRU_INSTALL_DIR = "${STAGING_DIR_NATIVE}${TI_CGT_PRU_INSTALL_
101export SWTOOLS_INSTALL_DIR = "${STAGING_DIR_TARGET}${SWTOOLS_INSTALL_DIR_RECIPE}" 102export SWTOOLS_INSTALL_DIR = "${STAGING_DIR_TARGET}${SWTOOLS_INSTALL_DIR_RECIPE}"
102export DSPLIB_C66_INSTALL_DIR = "${STAGING_DIR_TARGET}${DSPLIB_C66_INSTALL_DIR_RECIPE}" 103export DSPLIB_C66_INSTALL_DIR = "${STAGING_DIR_TARGET}${DSPLIB_C66_INSTALL_DIR_RECIPE}"
103export MATHLIB_C66_INSTALL_DIR = "${STAGING_DIR_TARGET}${MATHLIB_C66_INSTALL_DIR_RECIPE}" 104export MATHLIB_C66_INSTALL_DIR = "${STAGING_DIR_TARGET}${MATHLIB_C66_INSTALL_DIR_RECIPE}"
105export MATHLIB_C674_INSTALL_DIR = "${STAGING_DIR_TARGET}${MATHLIB_C674_INSTALL_DIR_RECIPE}"
104export IMGLIB_C66_INSTALL_DIR = "${STAGING_DIR_TARGET}${IMGLIB_C66_INSTALL_DIR_RECIPE}" 106export IMGLIB_C66_INSTALL_DIR = "${STAGING_DIR_TARGET}${IMGLIB_C66_INSTALL_DIR_RECIPE}"
105export VLIB_C66_INSTALL_DIR = "${STAGING_DIR_TARGET}${VLIB_C66_INSTALL_DIR_RECIPE}" 107export VLIB_C66_INSTALL_DIR = "${STAGING_DIR_TARGET}${VLIB_C66_INSTALL_DIR_RECIPE}"
106export CG_XML_INSTALL_DIR = "${STAGING_DIR_NATIVE}${CG_XML_INSTALL_DIR_RECIPE}" 108export CG_XML_INSTALL_DIR = "${STAGING_DIR_NATIVE}${CG_XML_INSTALL_DIR_RECIPE}"
diff --git a/recipes-ti/mathlib/mathlib-c66x.inc b/recipes-ti/mathlib/mathlib-c66x.inc
deleted file mode 100644
index 7951e6ca..00000000
--- a/recipes-ti/mathlib/mathlib-c66x.inc
+++ /dev/null
@@ -1,29 +0,0 @@
1DESCRIPTION = "MATHLIB contains optimized general-purpose signal-processing routines for TI DSPs"
2HOMEPAGE = "http://www.ti.com/tool/mathlib"
3SECTION = "devel"
4LICENSE = "BSD-3-Clause"
5
6require ../includes/ti-paths.inc
7require ../includes/ti-staging.inc
8require ../includes/ti-unpack.inc
9
10COMPATIBLE_MACHINE = "omap-a15|keystone"
11
12SRC_URI = "http://software-dl.ti.com/sdoemb/sdoemb_public_sw/mathlib/${PV}/exports/${BINFILE};name=mathlib"
13
14S = "${WORKDIR}/mathlib-c66x-${PV}"
15
16BINFILE = "mathlib_c66x_${PV}_Linux.bin"
17TI_BIN_UNPK_ARGS = "--mode silent --prefix ${S}"
18TI_BIN_UNPK_CMDS = ""
19
20do_install() {
21 CP_ARGS="-Prf --preserve=mode,timestamps --no-preserve=ownership"
22 install -d ${D}${MATHLIB_C66_INSTALL_DIR_RECIPE}
23 cp ${CP_ARGS} ${S}/* ${D}${MATHLIB_C66_INSTALL_DIR_RECIPE}
24}
25
26ALLOW_EMPTY_${PN} = "1"
27FILES_${PN}-dev += "${MATHLIB_C66_INSTALL_DIR_RECIPE}"
28
29INSANE_SKIP_${PN}-dev = "arch"
diff --git a/recipes-ti/mathlib/mathlib-c66x_3.1.1.0.bb b/recipes-ti/mathlib/mathlib-c66x_3.1.1.0.bb
deleted file mode 100644
index 50746fb9..00000000
--- a/recipes-ti/mathlib/mathlib-c66x_3.1.1.0.bb
+++ /dev/null
@@ -1,9 +0,0 @@
1require mathlib-c66x.inc
2
3PV = "3_1_1_0"
4PR = "r1"
5
6LIC_FILES_CHKSUM = "file://packages/ti/mathlib/mathlib.h;beginline=9;endline=35;md5=954ed7074e987be574989f985f1897db"
7
8SRC_URI[mathlib.md5sum] = "f3c9ad06dfcea780b5362c57a4bc48b8"
9SRC_URI[mathlib.sha256sum] = "85df897c94e8768e9a1f186c21702ed3887d39cda6dc67cb4580fa3f083e8925"
diff --git a/recipes-ti/mathlib/mathlib-c66x_git.bb b/recipes-ti/mathlib/mathlib-c66x_git.bb
new file mode 100644
index 00000000..22683855
--- /dev/null
+++ b/recipes-ti/mathlib/mathlib-c66x_git.bb
@@ -0,0 +1,5 @@
1include mathlib.inc
2
3MATHLIB_BUILD_TARGET = "c66x"
4MATHLIB_INSTALL_DIR_RECIPE = "${MATHLIB_C66_INSTALL_DIR_RECIPE}"
5MATHLIB_INSTALL_DIR = "${MATHLIB_C66_INSTALL_DIR}"
diff --git a/recipes-ti/mathlib/mathlib-c674x_git.bb b/recipes-ti/mathlib/mathlib-c674x_git.bb
new file mode 100644
index 00000000..1654baf2
--- /dev/null
+++ b/recipes-ti/mathlib/mathlib-c674x_git.bb
@@ -0,0 +1,5 @@
1include mathlib.inc
2
3MATHLIB_BUILD_TARGET = "c674x"
4MATHLIB_INSTALL_DIR_RECIPE = "${MATHLIB_C674_INSTALL_DIR_RECIPE}"
5MATHLIB_INSTALL_DIR = "${MATHLIB_C674_INSTALL_DIR}"
diff --git a/recipes-ti/mathlib/mathlib.inc b/recipes-ti/mathlib/mathlib.inc
new file mode 100644
index 00000000..3e981e4e
--- /dev/null
+++ b/recipes-ti/mathlib/mathlib.inc
@@ -0,0 +1,72 @@
1SUMMARY = "MATHLIB contains optimized floating-point math functions for TI DSPs"
2HOMEPAGE = "http://git.ti.com/ep-processor-libraries/mathlib"
3LICENSE = "BSD-3-Clause"
4
5require ../includes/ti-paths.inc
6
7PV = "3_1_2_2"
8PR = "r0"
9
10DEPENDS = "ti-cgt6x-native \
11 ti-xdctools-native \
12 ti-sysbios \
13 doxygen-native \
14 zip-native \
15 swtools"
16
17S = "${WORKDIR}/git"
18
19SRC_URI = "git://git.ti.com/ep-processor-libraries/mathlib.git;protocol=git;branch=master"
20SRCREV = "195355db20f53295cfeef0bcfba0a8d8fdb0a753"
21
22LIC_FILES_CHKSUM = "file://ti/mathlib/src/acosdp/acosdp.h;beginline=1;endline=35;md5=c133f7e139b46385906c861dd9552250"
23
24export MATHLIB_WORK_DIR="${S}"
25export CGTOOLS_INSTALL_DIR = "${STAGING_DIR_NATIVE}/usr/share/ti/cgt-c6x"
26export C64PCODEGENTOOL="${CGTOOLS_INSTALL_DIR}"
27export C674CODEGENTOOL="${CGTOOLS_INSTALL_DIR}"
28export C66CODEGENTOOL ="${CGTOOLS_INSTALL_DIR}"
29export SWTOOLS_PATH = "${SWTOOLS_INSTALL_DIR}/ti/mas/swtools"
30export XDCBUILDCFG="${SWTOOLS_PATH}/config.bld"
31
32PATH_append = ":${XDC_INSTALL_DIR}"
33
34XDCPATH.="${XDCCGROOT}/include;${XDC_INSTALL_DIR}/packages;${SYSBIOS_INSTALL_DIR}/packages;"
35XDCPATH.="${SWTOOLS_INSTALL_DIR};${MATHLIB_WORK_DIR};"
36
37export XDCPATH
38
39MATHLIB_PACKAGE_NAME = "mathlib_${MATHLIB_BUILD_TARGET}_${PV}"
40
41do_compile() {
42 cd ${MATHLIB_WORK_DIR}/ti/mathlib;
43 xdc XDCARGS="${MATHLIB_BUILD_TARGET} bundle" XDCOPTIONS="-v"
44}
45
46do_install() {
47 install -d ${D}${MATHLIB_INSTALL_DIR_RECIPE}
48
49 find -name "${MATHLIB_PACKAGE_NAME}.zip" -exec unzip -o {} -d ${D}${MATHLIB_INSTALL_DIR_RECIPE} \;
50 mv ${D}${MATHLIB_INSTALL_DIR_RECIPE}/mathlib/* ${D}${MATHLIB_INSTALL_DIR_RECIPE}
51 mv ${D}${MATHLIB_INSTALL_DIR_RECIPE}/mathlib/.metadata ${D}${MATHLIB_INSTALL_DIR_RECIPE}
52 rm -r ${D}${MATHLIB_INSTALL_DIR_RECIPE}/mathlib
53}
54
55inherit deploy
56addtask deploy before do_build after do_install
57
58do_deploy() {
59 install -d ${DEPLOYDIR}
60 # zip up files in ${D}${MATHLIB_INSTALL_DIR_RECIPE}
61 # and place the zip file in ${DEPLOYDIR}
62 mkdir ./${MATHLIB_PACKAGE_NAME}
63 cp -r ${D}${MATHLIB_INSTALL_DIR_RECIPE}/* ./${MATHLIB_PACKAGE_NAME}
64 cp -r ${D}${MATHLIB_INSTALL_DIR_RECIPE}/.metadata ./${MATHLIB_PACKAGE_NAME}
65 zip -9 -y -r -q ${DEPLOYDIR}/${MATHLIB_PACKAGE_NAME}.zip ./${MATHLIB_PACKAGE_NAME}
66 rm -r ./${MATHLIB_PACKAGE_NAME}
67}
68
69ALLOW_EMPTY_${PN} = "1"
70FILES_${PN}-dev += "${MATHLIB_INSTALL_DIR_RECIPE}"
71
72INSANE_SKIP_${PN}-dev = "arch"