summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMahesh Radhakrishnan <m-radhakrishnan2@ti.com>2018-09-28 22:26:29 +0000
committerDenys Dmytriyenko <denys@ti.com>2018-09-28 20:22:24 +0000
commitcae8b8d031f7a323e07ddbe41b7784836dfffd5c (patch)
tree5558fcc90cf1487499459d28fde35ba191a5d937
parent6ceb96d84caf00d2843dfad99e396b9abf704553 (diff)
downloadmeta-ti-cae8b8d031f7a323e07ddbe41b7784836dfffd5c.tar.gz
ti-ns: Adding support for TI network services
Signed-off-by: Mahesh Radhakrishnan <m-radhakrishnan2@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r--recipes-ti/includes/ti-paths.inc2
-rw-r--r--recipes-ti/ns/ti-ns.inc21
-rw-r--r--recipes-ti/ns/ti-ns_2.40.01.02.bb14
3 files changed, 37 insertions, 0 deletions
diff --git a/recipes-ti/includes/ti-paths.inc b/recipes-ti/includes/ti-paths.inc
index 93494f08..250074b4 100644
--- a/recipes-ti/includes/ti-paths.inc
+++ b/recipes-ti/includes/ti-paths.inc
@@ -34,6 +34,7 @@ export LINK_INSTALL_DIR_RECIPE = "${installdir}/ti-dsplink-tree"
34export LINUXUTILS_INSTALL_DIR_RECIPE = "${installdir}/ti-linuxutils-tree" 34export LINUXUTILS_INSTALL_DIR_RECIPE = "${installdir}/ti-linuxutils-tree"
35export LPM_INSTALL_DIR_RECIPE = "${installdir}/ti-local-power-manager-tree" 35export LPM_INSTALL_DIR_RECIPE = "${installdir}/ti-local-power-manager-tree"
36export NDK_INSTALL_DIR_RECIPE = "${installdir}/ti-ndk-tree" 36export NDK_INSTALL_DIR_RECIPE = "${installdir}/ti-ndk-tree"
37export NS_INSTALL_DIR_RECIPE = "${installdir}/ti-ns-tree"
37export OMX_INSTALL_DIR_RECIPE = "${installdir}/ti-omx-tree" 38export OMX_INSTALL_DIR_RECIPE = "${installdir}/ti-omx-tree"
38export OSAL_INSTALL_DIR_RECIPE = "${installdir}/ti-osal-tree" 39export OSAL_INSTALL_DIR_RECIPE = "${installdir}/ti-osal-tree"
39export RTFS_INSTALL_DIR_RECIPE = "${installdir}/ti-rtfs-tree" 40export RTFS_INSTALL_DIR_RECIPE = "${installdir}/ti-rtfs-tree"
@@ -86,6 +87,7 @@ export LINK_INSTALL_DIR = "${STAGING_DIR_TARGET}${LINK_INSTALL_DIR_RECIPE}
86export LINUXUTILS_INSTALL_DIR = "${STAGING_DIR_TARGET}${LINUXUTILS_INSTALL_DIR_RECIPE}" 87export LINUXUTILS_INSTALL_DIR = "${STAGING_DIR_TARGET}${LINUXUTILS_INSTALL_DIR_RECIPE}"
87export LPM_INSTALL_DIR = "${STAGING_DIR_TARGET}${LPM_INSTALL_DIR_RECIPE}" 88export LPM_INSTALL_DIR = "${STAGING_DIR_TARGET}${LPM_INSTALL_DIR_RECIPE}"
88export NDK_INSTALL_DIR = "${STAGING_DIR_TARGET}${NDK_INSTALL_DIR_RECIPE}" 89export NDK_INSTALL_DIR = "${STAGING_DIR_TARGET}${NDK_INSTALL_DIR_RECIPE}"
90export NS_INSTALL_DIR = "${STAGING_DIR_TARGET}${NS_INSTALL_DIR_RECIPE}"
89export OMX_INSTALL_DIR = "${STAGING_DIR_TARGET}${OMX_INSTALL_DIR_RECIPE}" 91export OMX_INSTALL_DIR = "${STAGING_DIR_TARGET}${OMX_INSTALL_DIR_RECIPE}"
90export SYSBIOS_INSTALL_DIR = "${STAGING_DIR_TARGET}${SYSBIOS_INSTALL_DIR_RECIPE}" 92export SYSBIOS_INSTALL_DIR = "${STAGING_DIR_TARGET}${SYSBIOS_INSTALL_DIR_RECIPE}"
91export SYSLINK_INSTALL_DIR = "${STAGING_DIR_TARGET}${SYSLINK_INSTALL_DIR_RECIPE}" 93export SYSLINK_INSTALL_DIR = "${STAGING_DIR_TARGET}${SYSLINK_INSTALL_DIR_RECIPE}"
diff --git a/recipes-ti/ns/ti-ns.inc b/recipes-ti/ns/ti-ns.inc
new file mode 100644
index 00000000..2a50c56c
--- /dev/null
+++ b/recipes-ti/ns/ti-ns.inc
@@ -0,0 +1,21 @@
1SUMMARY = "TI Network Services"
2HOMEPAGE = "http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/ns/index.html"
3SECTION = "devel"
4LICENSE = "BSD"
5
6require recipes-ti/includes/ti-paths.inc
7
8S = "${WORKDIR}/ns_${PV}"
9
10SRC_URI = "http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/ns/${PV}/exports/ns_${PV}.zip;name=nszip"
11
12do_install() {
13 CP_ARGS="-Prf --preserve=mode,timestamps --no-preserve=ownership"
14 install -d ${D}${NS_INSTALL_DIR_RECIPE}
15 cp ${CP_ARGS} ${S}/* ${D}${NS_INSTALL_DIR_RECIPE}
16}
17
18ALLOW_EMPTY_${PN} = "1"
19FILES_${PN}-dev += "${NS_INSTALL_DIR_RECIPE}"
20
21INSANE_SKIP_${PN}-dev = "arch ldflags staticdev file-rdeps"
diff --git a/recipes-ti/ns/ti-ns_2.40.01.02.bb b/recipes-ti/ns/ti-ns_2.40.01.02.bb
new file mode 100644
index 00000000..6de00209
--- /dev/null
+++ b/recipes-ti/ns/ti-ns_2.40.01.02.bb
@@ -0,0 +1,14 @@
1require ti-ns.inc
2
3PV = "2_40_01_02"
4PR = "r0"
5SRC_URI = "http://software-dl.ti.com/targetcontent/ns/${PV}/exports/ns_${PV}.zip;name=nszip"
6
7LIC_FILES_CHKSUM = "file://manifest_ns_${PV}.html;md5=29e319bb254ad52bdaebf8f6387c2f85"
8
9SRC_URI[nszip.md5sum] = "03146829fc7cf1e7b2acbeb6c1f772e9"
10SRC_URI[nszip.sha256sum] = "e41f254d9db341ad3efea7f6f59df46802769eba3e2f03b6d2a53d186de18687"
11
12INHIBIT_PACKAGE_STRIP = "1"
13INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
14INHIBIT_SYSROOT_STRIP = "1"