summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRam Prasad <x0038811@ti.com>2018-10-04 18:26:23 +0000
committerDenys Dmytriyenko <denys@ti.com>2018-10-08 19:36:01 +0000
commitdfb3ff546c68d00a8f5855d55a9c67d9d534bc91 (patch)
tree315a4d432c1534af10156d558e75b76f313b5851
parentb8d23a9f227b5bf8c1ee8b134896269c39c72ae6 (diff)
downloadmeta-ti-dfb3ff546c68d00a8f5855d55a9c67d9d534bc91.tar.gz
ipumm: Update SRCREV and cleanup patches
Cleanup the patch in meta-ti as the patch is merged to ipumm repo Signed-off-by: Ramprasad N <x0038811@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r--recipes-bsp/ipumm-fw/files/0001-Integration-with-IPC-3.50-BIOS-6.73-XDC-3.50.patch79
-rw-r--r--recipes-bsp/ipumm-fw/ipumm-fw_git.bb7
2 files changed, 2 insertions, 84 deletions
diff --git a/recipes-bsp/ipumm-fw/files/0001-Integration-with-IPC-3.50-BIOS-6.73-XDC-3.50.patch b/recipes-bsp/ipumm-fw/files/0001-Integration-with-IPC-3.50-BIOS-6.73-XDC-3.50.patch
deleted file mode 100644
index 22e1a435..00000000
--- a/recipes-bsp/ipumm-fw/files/0001-Integration-with-IPC-3.50-BIOS-6.73-XDC-3.50.patch
+++ /dev/null
@@ -1,79 +0,0 @@
1From 19b01da6f9cd02c4869229e46d5cfeefa9d5a5c6 Mon Sep 17 00:00:00 2001
2From: Ramprasad N <x0038811@ti.com>
3Date: Fri, 17 Aug 2018 17:12:14 +0530
4Subject: [ipumm PATCH] Integration with IPC 3.50, BIOS 6.73, XDC 3.50
5
6 Integrating IPUMM with
7 IPC: 3.50.01.00
8 BIOS: 6.73.00.12
9 XDC: 3.50.07.20
10
11Signed-off-by: Ramprasad N <x0038811@ti.com>
12---
13 Makefile | 6 +++---
14 build/common.bld | 2 +-
15 platform/ti/dce/baseimage/dce_ipu.cfg | 4 ++--
16 src/ti/framework/dce/dce.c | 2 +-
17 4 files changed, 7 insertions(+), 7 deletions(-)
18
19diff --git a/Makefile b/Makefile
20index 929a2a3..87e1b10 100644
21--- a/Makefile
22+++ b/Makefile
23@@ -36,9 +36,9 @@ REPO := $(BIOSTOOLSROOT)
24
25 # Different tool versions can easily be programmed by defining below variables
26 # in your environment.
27-XDCVERSION ?= xdctools_3_50_03_33_core
28-BIOSVERSION ?= bios_6_52_00_12
29-IPCVERSION ?= ipc_3_47_01_00
30+XDCVERSION ?= xdctools_3_50_07_20_core
31+BIOSVERSION ?= bios_6_73_00_12
32+IPCVERSION ?= ipc_3_50_01_00
33 CEVERSION ?= codec_engine_3_24_00_08
34 FCVERSION ?= framework_components_3_40_02_07
35 XDAISVERSION ?= xdais_7_24_00_04
36diff --git a/build/common.bld b/build/common.bld
37index eacc2b7..ecc7de1 100644
38--- a/build/common.bld
39+++ b/build/common.bld
40@@ -417,7 +417,7 @@ function GetVersionTag()
41 status = {};
42 var verInfo;
43 var git_cmd = "git ";
44- var ipc_ver = " IPC 3_47_01_00 ";
45+ var ipc_ver = " IPC 3_50_01_00 ";
46 var ipumm_ver = " MMIP 3_00_15_00 ";
47
48 var type_cmd = "type ";
49diff --git a/platform/ti/dce/baseimage/dce_ipu.cfg b/platform/ti/dce/baseimage/dce_ipu.cfg
50index 5bc1139..c81af98 100644
51--- a/platform/ti/dce/baseimage/dce_ipu.cfg
52+++ b/platform/ti/dce/baseimage/dce_ipu.cfg
53@@ -248,8 +248,8 @@ else
54 BIOS.smpEnabled = false;
55 }
56
57-var Settings = xdc.useModule('ti.sysbios.posix.Settings');
58-Settings.supportsMutexPriority = true;
59+var Settings = xdc.useModule('ti.posix.tirtos.Settings');
60+Settings.enableMutexPriority = true;
61
62 var Timer = xdc.useModule('ti.sysbios.timers.dmtimer.Timer');
63 if(Program.global.HwType == hw_OMAP5)
64diff --git a/src/ti/framework/dce/dce.c b/src/ti/framework/dce/dce.c
65index 62bea8c..01dbcce 100644
66--- a/src/ti/framework/dce/dce.c
67+++ b/src/ti/framework/dce/dce.c
68@@ -50,7 +50,7 @@
69 #include <ti/sysbios/hal/Cache.h>
70 #include <ti/sysbios/knl/Task.h>
71 #include <ti/sysbios/knl/Semaphore.h>
72-#include <ti/sysbios/posix/pthread.h>
73+#include <ti/posix/ccs/pthread.h>
74 #include <xdc/cfg/global.h>
75 #include <xdc/runtime/System.h>
76 #include <xdc/runtime/Diags.h>
77--
781.9.1
79
diff --git a/recipes-bsp/ipumm-fw/ipumm-fw_git.bb b/recipes-bsp/ipumm-fw/ipumm-fw_git.bb
index cee72a8c..f9677285 100644
--- a/recipes-bsp/ipumm-fw/ipumm-fw_git.bb
+++ b/recipes-bsp/ipumm-fw/ipumm-fw_git.bb
@@ -17,15 +17,12 @@ RDEPENDS_${PN} = " libdce"
17 17
18SRC_URI = "git://git.ti.com/ivimm/ipumm.git;protocol=git" 18SRC_URI = "git://git.ti.com/ivimm/ipumm.git;protocol=git"
19 19
20SRCREV = "035ba2571a273162fde75a31decadc6534d17eca" 20SRCREV = "e95e96e6d1e112a18d6935a8ede91fefeae70a8f"
21 21
22SRC_URI += " \
23 file://0001-Integration-with-IPC-3.50-BIOS-6.73-XDC-3.50.patch \
24"
25S = "${WORKDIR}/git" 22S = "${WORKDIR}/git"
26 23
27PV = "3.00.15.00" 24PV = "3.00.15.00"
28PR = "r2" 25PR = "r3"
29 26
30require recipes-ti/includes/ti-paths.inc 27require recipes-ti/includes/ti-paths.inc
31 28