diff options
author | Joel A Fernandes <joelagnel@ti.com> | 2011-08-23 15:05:19 -0500 |
---|---|---|
committer | Koen Kooi <koen@dominion.thruhere.net> | 2011-10-14 12:27:50 +0200 |
commit | 62393c718a0fd0ba83249c1a8ae296dcd1a04f80 (patch) | |
tree | b2add8bfc46ee7597bb999c4a468e7d6b814cd0c | |
parent | 52ee7074ef7669469294c1f5f83891390aa4e205 (diff) | |
download | meta-ti-62393c718a0fd0ba83249c1a8ae296dcd1a04f80.tar.gz |
beaglebone-tester: A component-based test framework for BeagleBone
Test scripts to be integrated into BeagleBone hardware testing images
and run automatically during boot time to determine if all hardware
components are working correctly.
Auto tests controllable from uEnv.txt which is auto deleted on a test success.
For future use, the individual scripts can be run from /var/lib/bone-tester/component
Signed-off-by: Joel A Fernandes <joelagnel@ti.com>
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
-rw-r--r-- | recipes-ti/beagleboard/beaglebone-tester.bb | 50 | ||||
-rw-r--r-- | recipes-ti/beagleboard/beaglebone-tester/0001-Initscript-check-for-run_hardware_tests-in-systemd-u.patch | 26 |
2 files changed, 76 insertions, 0 deletions
diff --git a/recipes-ti/beagleboard/beaglebone-tester.bb b/recipes-ti/beagleboard/beaglebone-tester.bb new file mode 100644 index 00000000..504096d4 --- /dev/null +++ b/recipes-ti/beagleboard/beaglebone-tester.bb | |||
@@ -0,0 +1,50 @@ | |||
1 | DESCRIPTION = "BeagleBone tester scripts" | ||
2 | HOMEPAGE = "http://beagleboard.org/support" | ||
3 | |||
4 | LICENSE = "GPLv2" | ||
5 | LIC_FILES_CHKSUM="file://gpl.txt;md5=5b122a36d0f6dc55279a0ebc69f3c60b" | ||
6 | |||
7 | # only scripts and data | ||
8 | inherit allarch | ||
9 | |||
10 | SRC_URI = "git://github.com/joelagnel/validation-scripts.git;protocol=git \ | ||
11 | file://0001-Initscript-check-for-run_hardware_tests-in-systemd-u.patch \ | ||
12 | " | ||
13 | SRCREV = "1b0b8d45cf0718a1768503e8f7616aff6fc3ca03" | ||
14 | |||
15 | S = "${WORKDIR}/git" | ||
16 | |||
17 | do_install() { | ||
18 | install -d ${D}${localstatedir}/lib/bone-tester/component/data/ | ||
19 | install -d ${D}${localstatedir}/lib/bone-tester/init-scripts/ | ||
20 | install -d ${D}${localstatedir}/lib/bone-tester/lib | ||
21 | install -d ${D}${base_libdir}/systemd/system/multi-user.target.wants/ | ||
22 | install -d ${D}/boot/ | ||
23 | install -m 0755 ${S}/bone-tester/init-scripts/uEnv.txt ${D}/boot/uEnv.txt | ||
24 | |||
25 | # systemd configuration | ||
26 | ln -s ../bone-tester.service ${D}${base_libdir}/systemd/system/multi-user.target.wants/bone-tester.service | ||
27 | install -m 0755 ${S}/bone-tester/init-scripts/bone-tester.service ${D}${base_libdir}/systemd/system/bone-tester.service | ||
28 | install -m 0755 ${S}/bone-tester/init-scripts/init.sh ${D}${localstatedir}/lib/bone-tester/init-scripts/init.sh | ||
29 | |||
30 | for i in $(find ${S}/bone-tester/component/ -maxdepth 1 -type f) ; do | ||
31 | install -m 0755 ${i} ${D}${localstatedir}/lib/bone-tester/component/ | ||
32 | done | ||
33 | for i in ${S}/bone-tester/component/data/* ; do | ||
34 | install -m 0755 ${i} ${D}${localstatedir}/lib/bone-tester/component/data/ | ||
35 | done | ||
36 | for i in ${S}/bone-tester/lib/* ; do | ||
37 | install -m 0755 ${i} ${D}${localstatedir}/lib/bone-tester/lib/ | ||
38 | done | ||
39 | } | ||
40 | |||
41 | |||
42 | FILES_${PN} += "${base_libdir}/systemd \ | ||
43 | /boot \ | ||
44 | " | ||
45 | |||
46 | RDEPENDS_${PN} = "iputils" | ||
47 | RRECOMMENDS_${PN} = "kernel-module-g-zero \ | ||
48 | kernel-module-g-file-storage \ | ||
49 | kernel-module-smsc95xx" | ||
50 | |||
diff --git a/recipes-ti/beagleboard/beaglebone-tester/0001-Initscript-check-for-run_hardware_tests-in-systemd-u.patch b/recipes-ti/beagleboard/beaglebone-tester/0001-Initscript-check-for-run_hardware_tests-in-systemd-u.patch new file mode 100644 index 00000000..c8df0e37 --- /dev/null +++ b/recipes-ti/beagleboard/beaglebone-tester/0001-Initscript-check-for-run_hardware_tests-in-systemd-u.patch | |||
@@ -0,0 +1,26 @@ | |||
1 | From 1a2bacad336c8d36c8b94c802510fe7eb23e7830 Mon Sep 17 00:00:00 2001 | ||
2 | From: Koen Kooi <koen@dominion.thruhere.net> | ||
3 | Date: Thu, 13 Oct 2011 12:54:47 +0300 | ||
4 | Subject: [PATCH] Initscript: check for 'run_hardware_tests' in systemd unit file | ||
5 | |||
6 | Signed-off-by: Koen Kooi <k-kooi@ti.com> | ||
7 | --- | ||
8 | bone-tester/init-scripts/bone-tester.service | 3 ++- | ||
9 | 1 files changed, 2 insertions(+), 1 deletions(-) | ||
10 | |||
11 | diff --git a/bone-tester/init-scripts/bone-tester.service b/bone-tester/init-scripts/bone-tester.service | ||
12 | index 78f8fa8..bf2b2d2 100644 | ||
13 | --- a/bone-tester/init-scripts/bone-tester.service | ||
14 | +++ b/bone-tester/init-scripts/bone-tester.service | ||
15 | @@ -1,6 +1,7 @@ | ||
16 | [Unit] | ||
17 | Description=BeagleBone Tester | ||
18 | -ConditionPathExists=|/var/lib/bone-tester | ||
19 | +ConditionPathExists=/var/lib/bone-tester | ||
20 | +ConditionKernelCommandLine=run_hardware_tests | ||
21 | |||
22 | [Service] | ||
23 | StandardOutput=syslog | ||
24 | -- | ||
25 | 1.6.6.1 | ||
26 | |||