summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authore-ruei1@ti.com <e-ruei1@ti.com>2018-07-14 02:54:09 +0000
committerDenys Dmytriyenko <denys@ti.com>2018-07-27 20:00:17 +0000
commit0f65c43f781d29c8bf5feca0a6a6a3a2ec5e2061 (patch)
tree7715fd449bfb1987aa7165374e1c380d37633243
parent94fd10877499352cdf3fbe0871bc6300e6436b93 (diff)
downloadmeta-ti-0f65c43f781d29c8bf5feca0a6a6a3a2ec5e2061.tar.gz
ti-sgx-ddk-km: add k3 (AM654x) support
- add K3 (AM654x) support based on SGX DDK 1.17 Signed-off-by: Eric Ruei <e-ruei1@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r--recipes-bsp/powervr-drivers/ti-sgx-ddk-km_1.17.4948957.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/recipes-bsp/powervr-drivers/ti-sgx-ddk-km_1.17.4948957.bb b/recipes-bsp/powervr-drivers/ti-sgx-ddk-km_1.17.4948957.bb
new file mode 100644
index 00000000..59310575
--- /dev/null
+++ b/recipes-bsp/powervr-drivers/ti-sgx-ddk-km_1.17.4948957.bb
@@ -0,0 +1,41 @@
1DESCRIPTION = "Kernel drivers for the PowerVR SGX chipset found in the TI SoCs"
2HOMEPAGE = "https://git.ti.com/graphics/omap5-sgx-ddk-linux"
3LICENSE = "MIT | GPLv2"
4LIC_FILES_CHKSUM = "file://eurasia_km/README;beginline=13;endline=22;md5=74506d9b8e5edbce66c2747c50fcef12"
5
6inherit module
7
8COMPATIBLE_MACHINE = "k3"
9
10MACHINE_KERNEL_PR_append = "o"
11PR = "${MACHINE_KERNEL_PR}"
12
13PACKAGE_ARCH = "${MACHINE_ARCH}"
14
15DEPENDS = "virtual/kernel"
16
17PROVIDES = "omapdrm-pvr"
18
19RPROVIDES_${PN} = "omapdrm-pvr"
20RREPLACES_${PN} = "omapdrm-pvr"
21RCONFLICTS_${PN} = "omapdrm-pvr"
22
23BRANCH = "ti-img-sgx/${PV}/k4.14"
24
25SRC_URI = "git://git.ti.com/graphics/omap5-sgx-ddk-linux.git;protocol=git;branch=${BRANCH}"
26
27S = "${WORKDIR}/git"
28
29SRCREV = "b630d462f5fbb86e5f98965ba1af35da1207822f"
30
31TARGET_PRODUCT_k3 = "ti654x"
32
33EXTRA_OEMAKE += 'KERNELDIR="${STAGING_KERNEL_DIR}" TARGET_PRODUCT=${TARGET_PRODUCT} WINDOW_SYSTEM=nulldrmws'
34
35do_compile_prepend() {
36 cd ${S}/eurasia_km/eurasiacon/build/linux2/omap_linux
37}
38
39do_install() {
40 make -C ${STAGING_KERNEL_DIR} SUBDIRS=${B}/eurasia_km/eurasiacon/binary_omap_linux_nulldrmws_release/target_aarch64/kbuild INSTALL_MOD_PATH=${D} PREFIX=${STAGING_DIR_HOST} modules_install
41}