summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMahesh Radhakrishnan <m-radhakrishnan2@ti.com>2018-09-28 22:26:19 +0000
committerDenys Dmytriyenko <denys@ti.com>2018-10-01 15:30:07 +0000
commitcd822352e1df34e5932fa44d9089951542dfcdac (patch)
tree887eb86ebb992eaa40ee1f5df62f766cae13636e
parentce29eadf7ec4c13449dd7100c42e48172acc00ff (diff)
downloadmeta-ti-cd822352e1df34e5932fa44d9089951542dfcdac.tar.gz
spi-lld-rtos: Update to version 01.00.00.12A and added k3 support
Signed-off-by: Mahesh Radhakrishnan <m-radhakrishnan2@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r--recipes-bsp/spi-lld/spi-lld-rtos_git.bb12
1 files changed, 8 insertions, 4 deletions
diff --git a/recipes-bsp/spi-lld/spi-lld-rtos_git.bb b/recipes-bsp/spi-lld/spi-lld-rtos_git.bb
index 2c174bf6..77564cc9 100644
--- a/recipes-bsp/spi-lld/spi-lld-rtos_git.bb
+++ b/recipes-bsp/spi-lld/spi-lld-rtos_git.bb
@@ -5,21 +5,21 @@ inherit ti-pdk
5LICENSE = "BSD-3-Clause" 5LICENSE = "BSD-3-Clause"
6LIC_FILES_CHKSUM = "file://SPI.h;beginline=1;endline=31;md5=8580f9c5c0de8d5d13518cf18a0122b8" 6LIC_FILES_CHKSUM = "file://SPI.h;beginline=1;endline=31;md5=8580f9c5c0de8d5d13518cf18a0122b8"
7 7
8COMPATIBLE_MACHINE = "ti33x|ti43x|omap-a15|keystone|c66x|omapl1" 8COMPATIBLE_MACHINE = "ti33x|ti43x|omap-a15|keystone|c66x|omapl1|k3"
9PACKAGE_ARCH = "${MACHINE_ARCH}" 9PACKAGE_ARCH = "${MACHINE_ARCH}"
10 10
11SPI_LLD_GIT_URI = "git://git.ti.com/keystone-rtos/spi-lld.git" 11SPI_LLD_GIT_URI = "git://git.ti.com/keystone-rtos/spi-lld.git"
12SPI_LLD_GIT_PROTOCOL = "git" 12SPI_LLD_GIT_PROTOCOL = "git"
13SPI_LLD_GIT_BRANCH = "master" 13SPI_LLD_GIT_BRANCH = "master"
14 14
15# Below commit ID corresponds to "DEV.SPI_LLD.01.00.00.11" 15# Below commit ID corresponds to "DEV.SPI_LLD.01.00.00.12A"
16SPI_LLD_SRCREV = "772286dc767de33f735b14fcc1c41e4b65f24bb8" 16SPI_LLD_SRCREV = "5f591af32a1ff92140cf7d2b40cd131bb308ab73"
17 17
18BRANCH = "${SPI_LLD_GIT_BRANCH}" 18BRANCH = "${SPI_LLD_GIT_BRANCH}"
19SRC_URI = "${SPI_LLD_GIT_URI};protocol=${SPI_LLD_GIT_PROTOCOL};branch=${BRANCH}" 19SRC_URI = "${SPI_LLD_GIT_URI};protocol=${SPI_LLD_GIT_PROTOCOL};branch=${BRANCH}"
20 20
21SRCREV = "${SPI_LLD_SRCREV}" 21SRCREV = "${SPI_LLD_SRCREV}"
22PV = "01.00.00.11" 22PV = "01.00.00.12A"
23PR = "r0" 23PR = "r0"
24 24
25DEPENDS_append = " osal-rtos \ 25DEPENDS_append = " osal-rtos \
@@ -28,6 +28,10 @@ DEPENDS_append = " osal-rtos \
28DEPENDS_append_ti33x = " starterware-rtos" 28DEPENDS_append_ti33x = " starterware-rtos"
29DEPENDS_append_ti43x = " starterware-rtos" 29DEPENDS_append_ti43x = " starterware-rtos"
30 30
31DEPENDS_remove_k3 = "edma3-lld-rtos "
32DEPENDS_append_k3 = " udma-lld-rtos"
33
34
31# Build with make instead of XDC 35# Build with make instead of XDC
32TI_PDK_XDCMAKE = "0" 36TI_PDK_XDCMAKE = "0"
33 37