summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMahesh Radhakrishnan <m-radhakrishnan2@ti.com>2018-09-28 22:26:06 +0000
committerDenys Dmytriyenko <denys@ti.com>2018-10-01 15:30:07 +0000
commit81dff26d3080390a6045dc8c4b0f2a6a3ac45216 (patch)
tree5b1e15afd09b33164acddc7047811e0dce891366
parentb1d5adc42405bdfc39bec686bfa9cd21537775e5 (diff)
downloadmeta-ti-81dff26d3080390a6045dc8c4b0f2a6a3ac45216.tar.gz
board-rtos: Update to version 01.00.10.02 and added support to k3
Signed-off-by: Mahesh Radhakrishnan <m-radhakrishnan2@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r--recipes-bsp/board-rtos/board-rtos_git.bb15
1 files changed, 10 insertions, 5 deletions
diff --git a/recipes-bsp/board-rtos/board-rtos_git.bb b/recipes-bsp/board-rtos/board-rtos_git.bb
index df3e9619..292d6265 100644
--- a/recipes-bsp/board-rtos/board-rtos_git.bb
+++ b/recipes-bsp/board-rtos/board-rtos_git.bb
@@ -5,22 +5,22 @@ inherit ti-pdk
5LICENSE = "BSD-3-Clause" 5LICENSE = "BSD-3-Clause"
6LIC_FILES_CHKSUM = "file://board.h;beginline=1;endline=32;md5=9bed8e4ac2fb37fc627cefe49eb1c919" 6LIC_FILES_CHKSUM = "file://board.h;beginline=1;endline=32;md5=9bed8e4ac2fb37fc627cefe49eb1c919"
7 7
8COMPATIBLE_MACHINE = "ti33x|ti43x|omap-a15|keystone|omapl1|c66x" 8COMPATIBLE_MACHINE = "ti33x|ti43x|omap-a15|keystone|omapl1|c66x|k3"
9PACKAGE_ARCH = "${MACHINE_ARCH}" 9PACKAGE_ARCH = "${MACHINE_ARCH}"
10 10
11BOARD_GIT_URI = "git://git.ti.com/keystone-rtos/board.git" 11BOARD_GIT_URI = "git://git.ti.com/keystone-rtos/board.git"
12BOARD_GIT_PROTOCOL = "git" 12BOARD_GIT_PROTOCOL = "git"
13BOARD_GIT_BRANCH = "master" 13BOARD_GIT_BRANCH = "master"
14 14
15# Below commit ID corresponds to "DEV.BOARD.01.00.10.01" 15# Below commit ID corresponds to "DEV.BOARD.01.00.10.02"
16BOARD_SRCREV = "983d89de8143645571e7893e95632a8be0fab67e" 16BOARD_SRCREV = "60bde3650d067e4064f93c292c8d9108aa1bf57b"
17 17
18BRANCH ="${BOARD_GIT_BRANCH}" 18BRANCH ="${BOARD_GIT_BRANCH}"
19SRC_URI = "${BOARD_GIT_URI};protocol=${BOARD_GIT_PROTOCOL};branch=${BRANCH}" 19SRC_URI = "${BOARD_GIT_URI};protocol=${BOARD_GIT_PROTOCOL};branch=${BRANCH}"
20 20
21SRCREV = "${BOARD_SRCREV}" 21SRCREV = "${BOARD_SRCREV}"
22PV = "01.00.10.01" 22PV = "01.00.10.02"
23PR = "r1" 23PR = "r0"
24 24
25DEPENDS_append = " i2c-lld-rtos \ 25DEPENDS_append = " i2c-lld-rtos \
26 spi-lld-rtos \ 26 spi-lld-rtos \
@@ -63,6 +63,11 @@ DEPENDS_append_dra7xx = " pm-lld-rtos \
63 mmcsd-lld-rtos \ 63 mmcsd-lld-rtos \
64" 64"
65 65
66DEPENDS_append_k3 = " sciclient-rtos \
67 pm-lld-rtos \
68"
69
70
66# Build with make instead of XDC 71# Build with make instead of XDC
67TI_PDK_XDCMAKE = "0" 72TI_PDK_XDCMAKE = "0"
68 73