diff options
author | Denys Dmytriyenko <denys@ti.com> | 2013-09-16 17:06:35 -0400 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2013-09-16 18:04:39 -0400 |
commit | 384f3c57d3263cece1c156ffc3be83598ef83a19 (patch) | |
tree | 0ddaca4c093164be28ee8a1198c306658ce11584 | |
parent | 499fba5e6c634c061d377971a73d1e0116676257 (diff) | |
download | meta-ti-384f3c57d3263cece1c156ffc3be83598ef83a19.tar.gz |
ligles-omap3, omap3-sgx-modules: correct checksum assignment
Checksums are handled as var attributes and require immediate expansion,
so use := operation as in the original patches, that got lost in the update.
Otherwise do_fetch will fail to validate the checksums.
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
4 files changed, 12 insertions, 12 deletions
diff --git a/recipes-bsp/powervr-drivers/omap3-sgx-modules-x11_4.09.00.01.bb b/recipes-bsp/powervr-drivers/omap3-sgx-modules-x11_4.09.00.01.bb index fd798189..14f18603 100644 --- a/recipes-bsp/powervr-drivers/omap3-sgx-modules-x11_4.09.00.01.bb +++ b/recipes-bsp/powervr-drivers/omap3-sgx-modules-x11_4.09.00.01.bb | |||
@@ -10,7 +10,7 @@ IMGPV = "1.9.2188537" | |||
10 | 10 | ||
11 | inherit module | 11 | inherit module |
12 | 12 | ||
13 | MACHINE_KERNEL_PR_append = "c" | 13 | MACHINE_KERNEL_PR_append = "d" |
14 | PR = "${MACHINE_KERNEL_PR}" | 14 | PR = "${MACHINE_KERNEL_PR}" |
15 | 15 | ||
16 | DEFAULT_PREFERENCE = "-1" | 16 | DEFAULT_PREFERENCE = "-1" |
@@ -28,8 +28,8 @@ BINFILE = "${@base_contains('TUNE_FEATURES', 'callconvention-hard', '${BINFILE_H | |||
28 | 28 | ||
29 | SRC_URI = "http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/gfxsdk/${SGXPV}/exports/${BINFILE}" | 29 | SRC_URI = "http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/gfxsdk/${SGXPV}/exports/${BINFILE}" |
30 | 30 | ||
31 | SRC_URI[md5sum] = "${@base_contains('TUNE_FEATURES', 'callconvention-hard', '${MD5SUM_HARDFP}', '${MD5SUM_SOFTFP}', d)}" | 31 | SRC_URI[md5sum] := "${@base_contains('TUNE_FEATURES', 'callconvention-hard', '${MD5SUM_HARDFP}', '${MD5SUM_SOFTFP}', d)}" |
32 | SRC_URI[sha256sum] = "${@base_contains('TUNE_FEATURES', 'callconvention-hard', '${SHA256SUM_HARDFP}', '${SHA256SUM_SOFTFP}', d)}" | 32 | SRC_URI[sha256sum] := "${@base_contains('TUNE_FEATURES', 'callconvention-hard', '${SHA256SUM_HARDFP}', '${SHA256SUM_SOFTFP}', d)}" |
33 | 33 | ||
34 | TI_BIN_UNPK_WDEXT="/Graphics_SDK_${SGXPV}" | 34 | TI_BIN_UNPK_WDEXT="/Graphics_SDK_${SGXPV}" |
35 | S = "${WORKDIR}${TI_BIN_UNPK_WDEXT}/GFX_Linux_KM" | 35 | S = "${WORKDIR}${TI_BIN_UNPK_WDEXT}/GFX_Linux_KM" |
diff --git a/recipes-bsp/powervr-drivers/omap3-sgx-modules_4.09.00.01.bb b/recipes-bsp/powervr-drivers/omap3-sgx-modules_4.09.00.01.bb index 1c8718c1..4b97bbc4 100644 --- a/recipes-bsp/powervr-drivers/omap3-sgx-modules_4.09.00.01.bb +++ b/recipes-bsp/powervr-drivers/omap3-sgx-modules_4.09.00.01.bb | |||
@@ -10,7 +10,7 @@ IMGPV = "1.9.2188537" | |||
10 | 10 | ||
11 | inherit module | 11 | inherit module |
12 | 12 | ||
13 | MACHINE_KERNEL_PR_append = "b" | 13 | MACHINE_KERNEL_PR_append = "c" |
14 | PR = "${MACHINE_KERNEL_PR}" | 14 | PR = "${MACHINE_KERNEL_PR}" |
15 | 15 | ||
16 | DEFAULT_PREFERENCE = "-1" | 16 | DEFAULT_PREFERENCE = "-1" |
@@ -28,8 +28,8 @@ BINFILE = "${@base_contains('TUNE_FEATURES', 'callconvention-hard', '${BINFILE_H | |||
28 | 28 | ||
29 | SRC_URI = "http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/gfxsdk/${SGXPV}/exports/${BINFILE}" | 29 | SRC_URI = "http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/gfxsdk/${SGXPV}/exports/${BINFILE}" |
30 | 30 | ||
31 | SRC_URI[md5sum] = "${@base_contains('TUNE_FEATURES', 'callconvention-hard', '${MD5SUM_HARDFP}', '${MD5SUM_SOFTFP}', d)}" | 31 | SRC_URI[md5sum] := "${@base_contains('TUNE_FEATURES', 'callconvention-hard', '${MD5SUM_HARDFP}', '${MD5SUM_SOFTFP}', d)}" |
32 | SRC_URI[sha256sum] = "${@base_contains('TUNE_FEATURES', 'callconvention-hard', '${SHA256SUM_HARDFP}', '${SHA256SUM_SOFTFP}', d)}" | 32 | SRC_URI[sha256sum] := "${@base_contains('TUNE_FEATURES', 'callconvention-hard', '${SHA256SUM_HARDFP}', '${SHA256SUM_SOFTFP}', d)}" |
33 | 33 | ||
34 | TI_BIN_UNPK_WDEXT="/Graphics_SDK_${SGXPV}" | 34 | TI_BIN_UNPK_WDEXT="/Graphics_SDK_${SGXPV}" |
35 | S = "${WORKDIR}${TI_BIN_UNPK_WDEXT}/GFX_Linux_KM" | 35 | S = "${WORKDIR}${TI_BIN_UNPK_WDEXT}/GFX_Linux_KM" |
diff --git a/recipes-graphics/libgles/libgles-omap3-x11_4.09.00.01.bb b/recipes-graphics/libgles/libgles-omap3-x11_4.09.00.01.bb index df84f9b3..f7b9d669 100644 --- a/recipes-graphics/libgles/libgles-omap3-x11_4.09.00.01.bb +++ b/recipes-graphics/libgles/libgles-omap3-x11_4.09.00.01.bb | |||
@@ -2,7 +2,7 @@ require libgles-omap3-x11.inc | |||
2 | 2 | ||
3 | LICENSE = "TSPA" | 3 | LICENSE = "TSPA" |
4 | 4 | ||
5 | PR = "${INC_PR}.1" | 5 | PR = "${INC_PR}.2" |
6 | 6 | ||
7 | DEFAULT_PREFERENCE = "-1" | 7 | DEFAULT_PREFERENCE = "-1" |
8 | 8 | ||
@@ -42,8 +42,8 @@ SRC_URI = "http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/gf | |||
42 | file://99-bufferclass.rules \ | 42 | file://99-bufferclass.rules \ |
43 | " | 43 | " |
44 | 44 | ||
45 | SRC_URI[md5sum] = "${@base_contains('TUNE_FEATURES', 'callconvention-hard', '${MD5SUM_HARDFP}', '${MD5SUM_SOFTFP}', d)}" | 45 | SRC_URI[md5sum] := "${@base_contains('TUNE_FEATURES', 'callconvention-hard', '${MD5SUM_HARDFP}', '${MD5SUM_SOFTFP}', d)}" |
46 | SRC_URI[sha256sum] = "${@base_contains('TUNE_FEATURES', 'callconvention-hard', '${SHA256SUM_HARDFP}', '${SHA256SUM_SOFTFP}', d)}" | 46 | SRC_URI[sha256sum] := "${@base_contains('TUNE_FEATURES', 'callconvention-hard', '${SHA256SUM_HARDFP}', '${SHA256SUM_SOFTFP}', d)}" |
47 | 47 | ||
48 | S = "${WORKDIR}/Graphics_SDK_${SGXPV}" | 48 | S = "${WORKDIR}/Graphics_SDK_${SGXPV}" |
49 | 49 | ||
diff --git a/recipes-graphics/libgles/libgles-omap3_4.09.00.01.bb b/recipes-graphics/libgles/libgles-omap3_4.09.00.01.bb index 6899cfc7..d094b5c9 100644 --- a/recipes-graphics/libgles/libgles-omap3_4.09.00.01.bb +++ b/recipes-graphics/libgles/libgles-omap3_4.09.00.01.bb | |||
@@ -2,7 +2,7 @@ require libgles-omap3-no-x.inc | |||
2 | 2 | ||
3 | LICENSE = "TSPA" | 3 | LICENSE = "TSPA" |
4 | 4 | ||
5 | PR = "${INC_PR}.1" | 5 | PR = "${INC_PR}.2" |
6 | 6 | ||
7 | DEFAULT_PREFERENCE = "-1" | 7 | DEFAULT_PREFERENCE = "-1" |
8 | 8 | ||
@@ -40,8 +40,8 @@ SRC_URI = "http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/gf | |||
40 | file://99-bufferclass.rules \ | 40 | file://99-bufferclass.rules \ |
41 | " | 41 | " |
42 | 42 | ||
43 | SRC_URI[md5sum] = "${@base_contains('TUNE_FEATURES', 'callconvention-hard', '${MD5SUM_HARDFP}', '${MD5SUM_SOFTFP}', d)}" | 43 | SRC_URI[md5sum] := "${@base_contains('TUNE_FEATURES', 'callconvention-hard', '${MD5SUM_HARDFP}', '${MD5SUM_SOFTFP}', d)}" |
44 | SRC_URI[sha256sum] = "${@base_contains('TUNE_FEATURES', 'callconvention-hard', '${SHA256SUM_HARDFP}', '${SHA256SUM_SOFTFP}', d)}" | 44 | SRC_URI[sha256sum] := "${@base_contains('TUNE_FEATURES', 'callconvention-hard', '${SHA256SUM_HARDFP}', '${SHA256SUM_SOFTFP}', d)}" |
45 | 45 | ||
46 | S = "${WORKDIR}/Graphics_SDK_${SGXPV}" | 46 | S = "${WORKDIR}/Graphics_SDK_${SGXPV}" |
47 | 47 | ||