summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMahesh Radhakrishnan <m-radhakrishnan2@ti.com>2018-09-28 22:26:20 +0000
committerDenys Dmytriyenko <denys@ti.com>2018-10-01 15:30:07 +0000
commit238f063889fcbb2afe8f7c56c7e511c2685d75c2 (patch)
treebd5768646b7cfeaec0380314c3199cf4d4bba188
parentcd822352e1df34e5932fa44d9089951542dfcdac (diff)
downloadmeta-ti-238f063889fcbb2afe8f7c56c7e511c2685d75c2.tar.gz
pcie-lld-rtos: Update to version 02.03.00.01 and added k3 support
The license checksum change is due to copyright year change Signed-off-by: Mahesh Radhakrishnan <m-radhakrishnan2@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r--recipes-bsp/pcie-lld/pcie-lld-rtos_git.bb13
1 files changed, 8 insertions, 5 deletions
diff --git a/recipes-bsp/pcie-lld/pcie-lld-rtos_git.bb b/recipes-bsp/pcie-lld/pcie-lld-rtos_git.bb
index 1b7218ad..35a0cbcf 100644
--- a/recipes-bsp/pcie-lld/pcie-lld-rtos_git.bb
+++ b/recipes-bsp/pcie-lld/pcie-lld-rtos_git.bb
@@ -3,9 +3,9 @@ SUMMARY = "TI RTOS low lever driver for Peripheral Interconnect Express (PCIE)"
3inherit ti-pdk 3inherit ti-pdk
4 4
5LICENSE = "BSD-3-Clause" 5LICENSE = "BSD-3-Clause"
6LIC_FILES_CHKSUM = "file://pcie.h;beginline=1;endline=34;md5=c094db055596498ba803933936611eb2" 6LIC_FILES_CHKSUM = "file://pcie.h;beginline=1;endline=34;md5=566a784d78790a716d641764d5d60b74"
7 7
8COMPATIBLE_MACHINE = "omap-a15|keystone|c66x" 8COMPATIBLE_MACHINE = "omap-a15|keystone|c66x|k3"
9PACKAGE_ARCH = "${MACHINE_ARCH}" 9PACKAGE_ARCH = "${MACHINE_ARCH}"
10 10
11PCIE_LLD_GIT_URI = "git://git.ti.com/keystone-rtos/pcie-lld.git" 11PCIE_LLD_GIT_URI = "git://git.ti.com/keystone-rtos/pcie-lld.git"
@@ -13,16 +13,19 @@ PCIE_LLD_GIT_PROTOCOL = "git"
13PCIE_LLD_GIT_BRANCH = "master" 13PCIE_LLD_GIT_BRANCH = "master"
14PCIE_LLD_GIT_DESTSUFFIX = "git/ti/drv/pcie" 14PCIE_LLD_GIT_DESTSUFFIX = "git/ti/drv/pcie"
15 15
16# Below commit ID corresponds to "DEV.PCIE_LLD.02.02.00.13" 16# Below commit ID corresponds to "DEV.PCIE_LLD.02.03.00.01"
17PCIE_LLD_SRCREV = "bf8d3a22c03a5f273321c284fa1737072eca3f77" 17PCIE_LLD_SRCREV = "61759fc238600e3d5506ce86db1f6b604334edf8"
18 18
19BRANCH = "${PCIE_LLD_GIT_BRANCH}" 19BRANCH = "${PCIE_LLD_GIT_BRANCH}"
20SRC_URI = "${PCIE_LLD_GIT_URI};destsuffix=${PCIE_LLD_GIT_DESTSUFFIX};protocol=${PCIE_LLD_GIT_PROTOCOL};branch=${BRANCH}" 20SRC_URI = "${PCIE_LLD_GIT_URI};destsuffix=${PCIE_LLD_GIT_DESTSUFFIX};protocol=${PCIE_LLD_GIT_PROTOCOL};branch=${BRANCH}"
21 21
22SRCREV = "${PCIE_LLD_SRCREV}" 22SRCREV = "${PCIE_LLD_SRCREV}"
23PV = "02.02.00.13" 23PV = "02.03.00.01"
24PR = "r0" 24PR = "r0"
25 25
26DEPENDS_append_k3 = " udma-lld-rtos \
27"
28
26S = "${WORKDIR}/${PCIE_LLD_GIT_DESTSUFFIX}" 29S = "${WORKDIR}/${PCIE_LLD_GIT_DESTSUFFIX}"
27 30
28export PDK_PCIE_ROOT_PATH ="${WORKDIR}/build" 31export PDK_PCIE_ROOT_PATH ="${WORKDIR}/build"