summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJacob Stiffler <j-stiffler@ti.com>2018-09-07 19:37:11 +0000
committerDenys Dmytriyenko <denys@ti.com>2018-09-10 20:19:03 +0000
commit0601c64082439c6b524a0faccb30a8c97182cda2 (patch)
tree440e9088a37bd4ed4b63b3279aa622b95f30aade
parent5a088050cd8227fa21d3f5abcb85ea78ebeb051c (diff)
downloadmeta-ti-0601c64082439c6b524a0faccb30a8c97182cda2.tar.gz
sa-lld: utilize oe_runmake
* This fixes a configure issue when the sources may get cleaned. Signed-off-by: Jacob Stiffler <j-stiffler@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r--recipes-bsp/sa-lld/sa-lld-test_git.bb9
-rw-r--r--recipes-bsp/sa-lld/sa-lld_git.bb9
2 files changed, 12 insertions, 6 deletions
diff --git a/recipes-bsp/sa-lld/sa-lld-test_git.bb b/recipes-bsp/sa-lld/sa-lld-test_git.bb
index 07d64676..f3fa4f3d 100644
--- a/recipes-bsp/sa-lld/sa-lld-test_git.bb
+++ b/recipes-bsp/sa-lld/sa-lld-test_git.bb
@@ -14,14 +14,17 @@ DEVICELIST_k2e = "k2e"
14 14
15CHOICELIST = "no yes" 15CHOICELIST = "no yes"
16 16
17PARALLEL_MAKE = ""
18EXTRA_OEMAKE = "-f makefile_armv7 PDK_INSTALL_PATH=${STAGING_INCDIR} SA_SRC_DIR=${S}"
19
17do_compile () { 20do_compile () {
18# Now build the lld in the updated directory 21# Now build the lld in the updated directory
19 for device in ${DEVICELIST} 22 for device in ${DEVICELIST}
20 do 23 do
21 make -f makefile_armv7 clean PDK_INSTALL_PATH=${STAGING_INCDIR} DEVICE="$device" SA_SRC_DIR=${S} 24 oe_runmake clean DEVICE="$device"
22 for choice in ${CHOICELIST} 25 for choice in ${CHOICELIST}
23 do 26 do
24 make -f makefile_armv7 examples utils PDK_INSTALL_PATH=${STAGING_INCDIR} DEVICE="$device" SA_SRC_DIR=${S} USEDYNAMIC_LIB="$choice" 27 oe_runmake examples utils DEVICE="$device" USEDYNAMIC_LIB="$choice"
25 done 28 done
26 done 29 done
27} 30}
@@ -34,7 +37,7 @@ do_install () {
34 37
35 for device in ${DEVICELIST} 38 for device in ${DEVICELIST}
36 do 39 do
37 make -f makefile_armv7 installbin PDK_INSTALL_PATH=${STAGING_INCDIR} DEVICE="$device" SA_SRC_DIR=${S} INSTALL_BIN_BASE_DIR=${D}${bindir} 40 oe_runmake installbin DEVICE="$device" INSTALL_BIN_BASE_DIR=${D}${bindir}
38 done 41 done
39} 42}
40 43
diff --git a/recipes-bsp/sa-lld/sa-lld_git.bb b/recipes-bsp/sa-lld/sa-lld_git.bb
index d92ad1cf..df41c653 100644
--- a/recipes-bsp/sa-lld/sa-lld_git.bb
+++ b/recipes-bsp/sa-lld/sa-lld_git.bb
@@ -4,15 +4,18 @@ DEPENDS = "common-csl-ip"
4 4
5include sa-lld.inc 5include sa-lld.inc
6 6
7PR = "${INC_PR}.0" 7PR = "${INC_PR}.1"
8
9PARALLEL_MAKE = ""
10EXTRA_OEMAKE = "-f makefile_armv7 PDK_INSTALL_PATH=${STAGING_INCDIR}"
8 11
9do_compile () { 12do_compile () {
10# Now build the lld in the updated directory 13# Now build the lld in the updated directory
11 make -f makefile_armv7 clean lib PDK_INSTALL_PATH=${STAGING_INCDIR} 14 oe_runmake clean lib
12} 15}
13 16
14do_install () { 17do_install () {
15 make -f makefile_armv7 install PDK_INSTALL_PATH=${STAGING_INCDIR} INSTALL_INC_BASE_DIR=${D}/${includedir} INSTALL_LIB_BASE_DIR=${D}${libdir} 18 oe_runmake install INSTALL_INC_BASE_DIR=${D}/${includedir} INSTALL_LIB_BASE_DIR=${D}${libdir}
16 chown -R root:root ${D} 19 chown -R root:root ${D}
17 20
18# Set the generic device library symbolic link 21# Set the generic device library symbolic link