summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2018-04-24 01:53:50 +0000
committerDenys Dmytriyenko <denys@ti.com>2018-04-23 16:37:25 -0400
commitec52d51eccf72ad5cad8d6784aa9f087ba368954 (patch)
tree7dd4d7483961bb80060de53a4d6ba70d788bb898
parent7a786b2e4bce62b483c76547d23c4bf05b78af0c (diff)
downloadmeta-ti-ec52d51eccf72ad5cad8d6784aa9f087ba368954.tar.gz
multiprocmgr: don't hardcode "uapi" kernel location
This way keystone_remoteproc.h can also be found in sysroots, when available. Otherwise it can fall back to using kernel sources directly. Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r--recipes-ti/multiprocmgr/multiprocmgr/0001-mpmdlif.c-don-t-hardcode-kernel-s-uapi-location-keys.patch27
-rw-r--r--recipes-ti/multiprocmgr/multiprocmgr_git.bb9
2 files changed, 33 insertions, 3 deletions
diff --git a/recipes-ti/multiprocmgr/multiprocmgr/0001-mpmdlif.c-don-t-hardcode-kernel-s-uapi-location-keys.patch b/recipes-ti/multiprocmgr/multiprocmgr/0001-mpmdlif.c-don-t-hardcode-kernel-s-uapi-location-keys.patch
new file mode 100644
index 00000000..25deedcc
--- /dev/null
+++ b/recipes-ti/multiprocmgr/multiprocmgr/0001-mpmdlif.c-don-t-hardcode-kernel-s-uapi-location-keys.patch
@@ -0,0 +1,27 @@
1From 17c307ff6e67af43f243366baa2ccc01f89cdddd Mon Sep 17 00:00:00 2001
2From: Denys Dmytriyenko <denys@ti.com>
3Date: Mon, 23 Apr 2018 15:35:44 -0400
4Subject: [PATCH] mpmdlif.c: don't hardcode kernel's "uapi" location
5 keystone_remoteproc.h
6
7Signed-off-by: Denys Dmytriyenko <denys@ti.com>
8---
9 src/daemon/mpmdlif.c | 2 +-
10 1 file changed, 1 insertion(+), 1 deletion(-)
11
12diff --git a/src/daemon/mpmdlif.c b/src/daemon/mpmdlif.c
13index 0c31604..d287bbc 100644
14--- a/src/daemon/mpmdlif.c
15+++ b/src/daemon/mpmdlif.c
16@@ -47,7 +47,7 @@
17 #include <stdint.h>
18
19 #define _LINUX_TYPES_H
20-#include "uapi/linux/keystone_remoteproc.h"
21+#include "linux/keystone_remoteproc.h"
22 #include "internal/rsc_types.h"
23 //#include <elf.h>
24 // #define LOADER_DEBUG
25--
262.7.4
27
diff --git a/recipes-ti/multiprocmgr/multiprocmgr_git.bb b/recipes-ti/multiprocmgr/multiprocmgr_git.bb
index 053a04e5..f37b97e3 100644
--- a/recipes-ti/multiprocmgr/multiprocmgr_git.bb
+++ b/recipes-ti/multiprocmgr/multiprocmgr_git.bb
@@ -3,15 +3,18 @@ SUMMARY = "Provides download, debug and other utilities for other cores in the S
3 3
4include multiprocmgr.inc 4include multiprocmgr.inc
5 5
6SRC_URI_append = " file://mpmsrv-daemon.service" 6SRC_URI += " \
7 file://mpmsrv-daemon.service \
8 file://0001-mpmdlif.c-don-t-hardcode-kernel-s-uapi-location-keys.patch \
9"
7 10
8PR = "${INC_PR}.1" 11PR = "${INC_PR}.2"
9 12
10DEPENDS = "mpm-transport libdaemon virtual/kernel cmem" 13DEPENDS = "mpm-transport libdaemon virtual/kernel cmem"
11 14
12PACKAGE_ARCH = "${MACHINE_ARCH}" 15PACKAGE_ARCH = "${MACHINE_ARCH}"
13 16
14CC += "-I${STAGING_KERNEL_DIR}/include" 17CC += "-I${STAGING_KERNEL_DIR}/include -I${STAGING_KERNEL_DIR}/include/uapi"
15 18
16INITSCRIPT_NAME = "mpmsrv-daemon.sh" 19INITSCRIPT_NAME = "mpmsrv-daemon.sh"
17INITSCRIPT_PARAMS = "defaults 10" 20INITSCRIPT_PARAMS = "defaults 10"