summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSam Nelson <sam.nelson@ti.com>2014-12-19 05:38:26 +0000
committerDenys Dmytriyenko <denys@ti.com>2014-12-18 18:33:37 -0500
commit091c19a8fbba21a5ca9efab77ed7047721428f25 (patch)
tree4ecc2b6b46b251074d97dad29d28d6e04abbefa4
parent838c9edd2e6afe778ce49e32dd9c23c5985eefb8 (diff)
downloadmeta-ti-091c19a8fbba21a5ca9efab77ed7047721428f25.tar.gz
sa-lld: Add recipes for SA module low level driver
- Provides library and test code for Security accelerator module - Supports k2h, k2k, k2l & k2e devices Signed-off-by: Sam Nelson <sam.nelson@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r--recipes-bsp/sa-lld/sa-lld-test_git.bb33
-rw-r--r--recipes-bsp/sa-lld/sa-lld.inc14
-rw-r--r--recipes-bsp/sa-lld/sa-lld_git.bb14
3 files changed, 61 insertions, 0 deletions
diff --git a/recipes-bsp/sa-lld/sa-lld-test_git.bb b/recipes-bsp/sa-lld/sa-lld-test_git.bb
new file mode 100644
index 00000000..2069d415
--- /dev/null
+++ b/recipes-bsp/sa-lld/sa-lld-test_git.bb
@@ -0,0 +1,33 @@
1DESCRIPTION = "TI Security Accelerator LLD (SA LLD) Examples"
2
3DEPENDS = "common-csl-ip cppi-lld qmss-lld pa-lld sa-lld"
4
5include sa-lld.inc
6
7DEVICELIST = "k2h k2k k2l k2e"
8
9CHOICELIST = "no yes"
10
11do_compile () {
12# Now build the lld in the updated directory
13 for device in ${DEVICELIST}
14 do
15 make -f makefile_armv7 clean PDK_INSTALL_PATH=${STAGING_INCDIR} DEVICE="$device" SA_SRC_DIR=${S}
16 for choice in ${CHOICELIST}
17 do
18 make -f makefile_armv7 examples PDK_INSTALL_PATH=${STAGING_INCDIR} DEVICE="$device" SA_SRC_DIR=${S} USEDYNAMIC_LIB="$choice"
19 done
20 done
21}
22
23do_install () {
24 install -d ${D}${bindir}/ti/drv/sa/example/SaBasicExample/vectors
25
26# copy all the test vectors
27 find example/SaBasicExample/vectors -name *.bin -type f | xargs -I {} cp --parents {} ${D}${bindir}/ti/drv/sa
28
29 for device in ${DEVICELIST}
30 do
31 make -f makefile_armv7 installbin PDK_INSTALL_PATH=${STAGING_INCDIR} DEVICE="$device" SA_SRC_DIR=${S} INSTALL_BIN_BASE_DIR=${D}${bindir}
32 done
33}
diff --git a/recipes-bsp/sa-lld/sa-lld.inc b/recipes-bsp/sa-lld/sa-lld.inc
new file mode 100644
index 00000000..d4bdc953
--- /dev/null
+++ b/recipes-bsp/sa-lld/sa-lld.inc
@@ -0,0 +1,14 @@
1LICENSE = "BSD-3-Clause"
2COMPATIBLE_MACHINE = "keystone"
3
4LIC_FILES_CHKSUM = "file://${WORKDIR}/git/ti/drv/sa/COPYING.txt;md5=4709d353574a9569e129ebdf20e732dd"
5
6BRANCH = "master"
7SRC_URI = "git://git.ti.com/keystone-rtos/sa-lld.git;destsuffix=git/ti/drv/sa;protocol=git;branch=${BRANCH}"
8# Following commit DEV.SA_LLD.03.00.00.08
9SRCREV = "4da032c600ded79ab226a2a0100c1d8178a9da39"
10PV = "03.00.00.08"
11PR = "r0"
12
13BASEDIR = "${WORKDIR}/git"
14S = "${BASEDIR}/ti/drv/sa"
diff --git a/recipes-bsp/sa-lld/sa-lld_git.bb b/recipes-bsp/sa-lld/sa-lld_git.bb
new file mode 100644
index 00000000..f3458950
--- /dev/null
+++ b/recipes-bsp/sa-lld/sa-lld_git.bb
@@ -0,0 +1,14 @@
1DESCRIPTION = "TI Security Accelerator LLD (SA LLD) Library"
2
3DEPENDS = "common-csl-ip"
4
5include sa-lld.inc
6
7do_compile () {
8# Now build the lld in the updated directory
9 make -f makefile_armv7 clean lib PDK_INSTALL_PATH=${STAGING_INCDIR}
10}
11
12do_install () {
13 make -f makefile_armv7 install PDK_INSTALL_PATH=${STAGING_INCDIR} INSTALL_INC_BASE_DIR=${D}/${includedir} INSTALL_LIB_BASE_DIR=${D}${libdir}
14}