summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHongmei Gou <a0271529@ti.com>2018-07-20 01:11:38 +0000
committerDenys Dmytriyenko <denys@ti.com>2018-07-24 18:23:14 +0000
commit5c914c8aeafca7a60d127c46e70afc9b3b32b067 (patch)
tree3392aa553b93a298cfde7e3382e9d919069eadc1
parent7ddc6a384800612909ab299fe545c27ad77bdf10 (diff)
downloadmeta-ti-5c914c8aeafca7a60d127c46e70afc9b3b32b067.tar.gz
pruss-lld-apps: build example applications of pruss-lld
* The current example application is Simple Open Real-Time Ethernet (SORTE). It is ported to Linux user space utilizing UIO. Signed-off-by: Hongmei Gou <a0271529@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r--recipes-bsp/pruss-lld/pruss-lld-apps_git.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/recipes-bsp/pruss-lld/pruss-lld-apps_git.bb b/recipes-bsp/pruss-lld/pruss-lld-apps_git.bb
new file mode 100644
index 00000000..5867984b
--- /dev/null
+++ b/recipes-bsp/pruss-lld/pruss-lld-apps_git.bb
@@ -0,0 +1,33 @@
1DESCRIPTION = "TI PRUSS low level driver example applications"
2
3DEPENDS="common-csl-ip pruss-lld osal ti-pdk-build-rtos pruss-lld-rtos"
4
5DEPENDS_append_ti33x = " starterware"
6DEPENDS_append_ti43x = " starterware"
7
8include pruss-lld.inc
9
10PR = "${INC_PR}.0"
11
12S = "${WORKDIR}/${PRUSS_LLD_GIT_DESTSUFFIX}"
13
14EXTRA_OEMAKE += "-f makefile_armv7 PDK_INSTALL_PATH=${STAGING_INCDIR} PDK_PKG_PATH=${STAGING_DATADIR}/ti/ti-pdk-tree/packages PRUSS_SRC_DIR=${S}"
15
16
17DEVICE_LIST ?= "${TI_PDK_LIMIT_SOCS}"
18
19do_compile () {
20# Build the apps
21 for device in ${DEVICE_LIST}
22 do
23 oe_runmake apps DEVICE="$device"
24 done
25}
26
27do_install () {
28# Install the app binary
29 for device in ${DEVICE_LIST}
30 do
31 oe_runmake installapp INSTALL_BIN_BASE_DIR=${D}${bindir} DEVICE="$device"
32 done
33}