diff options
author | Denys Dmytriyenko <denys@ti.com> | 2015-12-01 11:25:56 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2015-12-01 15:44:15 -0500 |
commit | 8195b22cb136a91d32151ef932de0958a931361c (patch) | |
tree | 2a7f3de9c17aca7844ddfb9f0ecc4185bdf86483 | |
parent | 77c46bc3170892cc55d5f92e0ab00c2920ef9097 (diff) | |
download | meta-ti-8195b22cb136a91d32151ef932de0958a931361c.tar.gz |
pa-lld: set sane defaults when platform is not defined
Also fix this build error:
| makefile_armv7:27: *** missing separator. Stop.
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r-- | recipes-bsp/pa-lld/files/0001-makefile_armv7-fix-missing-separator-error.patch | 30 | ||||
-rw-r--r-- | recipes-bsp/pa-lld/pa-lld.inc | 7 | ||||
-rw-r--r-- | recipes-bsp/pa-lld/pa-lld_git.bb | 2 |
3 files changed, 36 insertions, 3 deletions
diff --git a/recipes-bsp/pa-lld/files/0001-makefile_armv7-fix-missing-separator-error.patch b/recipes-bsp/pa-lld/files/0001-makefile_armv7-fix-missing-separator-error.patch new file mode 100644 index 00000000..2ff41d3d --- /dev/null +++ b/recipes-bsp/pa-lld/files/0001-makefile_armv7-fix-missing-separator-error.patch | |||
@@ -0,0 +1,30 @@ | |||
1 | From 60a938e6902c7cb8bec34abbc5a3723c8094d728 Mon Sep 17 00:00:00 2001 | ||
2 | From: Denys Dmytriyenko <denys@ti.com> | ||
3 | Date: Tue, 1 Dec 2015 00:00:00 -0500 | ||
4 | Subject: [PATCH] makefile_armv7: fix missing separator error | ||
5 | |||
6 | Doesn't seem to work in all versions of Make, fails like this: | ||
7 | makefile_armv7:27: *** missing separator. Stop. | ||
8 | |||
9 | Signed-off-by: Denys Dmytriyenko <denys@ti.com> | ||
10 | --- | ||
11 | makefile_armv7 | 3 --- | ||
12 | 1 file changed, 3 deletions(-) | ||
13 | |||
14 | diff --git a/makefile_armv7 b/makefile_armv7 | ||
15 | index a2bc4f6..1ae6e0a 100644 | ||
16 | --- a/makefile_armv7 | ||
17 | +++ b/makefile_armv7 | ||
18 | @@ -24,9 +24,6 @@ else | ||
19 | export LLD_NAME=pa | ||
20 | endif | ||
21 | |||
22 | -echo DEVICE=$(DEVICE) | ||
23 | -echo LLD_NAME=$(LLD_NAME) | ||
24 | - | ||
25 | # Output for prebuilt generated libraries | ||
26 | export ARMV7LIBDIR ?= ./lib | ||
27 | export ARMV7OBJDIR ?= ./obj/$(DEVICE) | ||
28 | -- | ||
29 | 2.2.0 | ||
30 | |||
diff --git a/recipes-bsp/pa-lld/pa-lld.inc b/recipes-bsp/pa-lld/pa-lld.inc index 082d59d0..396278d4 100644 --- a/recipes-bsp/pa-lld/pa-lld.inc +++ b/recipes-bsp/pa-lld/pa-lld.inc | |||
@@ -13,18 +13,21 @@ PA_LLD_GIT_DESTSUFFIX = "git/ti/drv/pa" | |||
13 | PA_LLD_SRCREV = "ae3aa3e80ecf64fe5a16515d134a6bc217220e2e" | 13 | PA_LLD_SRCREV = "ae3aa3e80ecf64fe5a16515d134a6bc217220e2e" |
14 | 14 | ||
15 | BRANCH = "${PA_LLD_GIT_BRANCH}" | 15 | BRANCH = "${PA_LLD_GIT_BRANCH}" |
16 | SRC_URI = "${PA_LLD_GIT_URI};destsuffix=${PA_LLD_GIT_DESTSUFFIX};protocol=${PA_LLD_GIT_PROTOCOL};branch=${BRANCH}" | 16 | SRC_URI = "${PA_LLD_GIT_URI};destsuffix=${PA_LLD_GIT_DESTSUFFIX};protocol=${PA_LLD_GIT_PROTOCOL};branch=${BRANCH} \ |
17 | file://0001-makefile_armv7-fix-missing-separator-error.patch" | ||
17 | SRCREV = "${PA_LLD_SRCREV}" | 18 | SRCREV = "${PA_LLD_SRCREV}" |
18 | 19 | ||
19 | PV = "03.00.01.05" | 20 | PV = "03.00.01.05" |
20 | INC_PR = "r2" | 21 | INC_PR = "r3" |
21 | 22 | ||
22 | S = "${WORKDIR}/${PA_LLD_GIT_DESTSUFFIX}" | 23 | S = "${WORKDIR}/${PA_LLD_GIT_DESTSUFFIX}" |
23 | 24 | ||
25 | DEVICELIST = "k2h k2k k2l k2e" | ||
24 | DEVICELIST_k2hk-evm = "k2h k2k" | 26 | DEVICELIST_k2hk-evm = "k2h k2k" |
25 | DEVICELIST_k2l-evm = "k2l" | 27 | DEVICELIST_k2l-evm = "k2l" |
26 | DEVICELIST_k2e-evm = "k2e" | 28 | DEVICELIST_k2e-evm = "k2e" |
27 | 29 | ||
30 | LIBPA = "libpa" | ||
28 | LIBPA_k2hk-evm = "libpa" | 31 | LIBPA_k2hk-evm = "libpa" |
29 | LIBPA_k2e-evm = "libpa2" | 32 | LIBPA_k2e-evm = "libpa2" |
30 | LIBPA_k2l-evm = "libpa2" | 33 | LIBPA_k2l-evm = "libpa2" |
diff --git a/recipes-bsp/pa-lld/pa-lld_git.bb b/recipes-bsp/pa-lld/pa-lld_git.bb index 501ee2d9..f6de5b15 100644 --- a/recipes-bsp/pa-lld/pa-lld_git.bb +++ b/recipes-bsp/pa-lld/pa-lld_git.bb | |||
@@ -10,7 +10,7 @@ do_compile () { | |||
10 | # Now build the lld in the updated directory | 10 | # Now build the lld in the updated directory |
11 | for device in ${DEVICELIST} | 11 | for device in ${DEVICELIST} |
12 | do | 12 | do |
13 | make -f makefile_armv7 DEVICE=$device lib PDK_INSTALL_PATH=${STAGING_INCDIR} | 13 | make -f makefile_armv7 lib PDK_INSTALL_PATH=${STAGING_INCDIR} DEVICE="$device" |
14 | done | 14 | done |
15 | } | 15 | } |
16 | 16 | ||