summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMahesh Radhakrishnan <m-radhakrishnan2@ti.com>2017-09-19 02:22:39 +0000
committerDenys Dmytriyenko <denys@ti.com>2017-09-26 14:21:15 -0400
commitda84b67552ecda5ff3f1b257ead08c2b0d248d0b (patch)
treed4590a2848ec2ae60d327d822b584e5b0533415e
parentadce45c8dd2ccfff48e247359a48db63ed948ac6 (diff)
downloadmeta-ti-da84b67552ecda5ff3f1b257ead08c2b0d248d0b.tar.gz
pruss-lld: Add rtos recipe & update the version to 1.0.0.7
RTOS low level driver for the PRUSS module Signed-off-by: Mahesh Radhakrishnan <m-radhakrishnan2@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r--recipes-bsp/pruss-lld/pruss-lld-rtos_git.bb23
-rw-r--r--recipes-bsp/pruss-lld/pruss-lld.inc8
2 files changed, 27 insertions, 4 deletions
diff --git a/recipes-bsp/pruss-lld/pruss-lld-rtos_git.bb b/recipes-bsp/pruss-lld/pruss-lld-rtos_git.bb
new file mode 100644
index 00000000..50682867
--- /dev/null
+++ b/recipes-bsp/pruss-lld/pruss-lld-rtos_git.bb
@@ -0,0 +1,23 @@
1SUMMARY = "TI RTOS low level driver library for PRUSS"
2
3inherit ti-pdk
4require recipes-bsp/pruss-lld/pruss-lld.inc
5
6PR = "${INC_PR}.0"
7
8S = "${WORKDIR}/${PRUSS_LLD_GIT_DESTSUFFIX}"
9
10DEPENDS_append = " osal-rtos"
11DEPENDS_append_ti33x = " starterware-rtos"
12DEPENDS_append_ti43x = " starterware-rtos"
13
14# Build with make instead of XDC
15TI_PDK_XDCMAKE = "0"
16
17export PDK_PRUSS_ROOT_PATH ="${WORKDIR}/build"
18export DEST_ROOT="${WORKDIR}/build"
19
20# HTML doc link params
21PDK_COMP_LINK_TEXT = "PRUSS LLD"
22
23INSANE_SKIP_${PN} = "arch"
diff --git a/recipes-bsp/pruss-lld/pruss-lld.inc b/recipes-bsp/pruss-lld/pruss-lld.inc
index 86201080..44d84b83 100644
--- a/recipes-bsp/pruss-lld/pruss-lld.inc
+++ b/recipes-bsp/pruss-lld/pruss-lld.inc
@@ -1,7 +1,7 @@
1LICENSE = "BSD-3-Clause" 1LICENSE = "BSD-3-Clause"
2LIC_FILES_CHKSUM = "file://pruicss.h;beginline=1;endline=31;md5=315177aa03d58bcd124a6e799e2bd458" 2LIC_FILES_CHKSUM = "file://pruicss.h;beginline=1;endline=31;md5=315177aa03d58bcd124a6e799e2bd458"
3 3
4COMPATIBLE_MACHINE = "ti33x|ti43x|am57xx-evm|k2g-evm" 4COMPATIBLE_MACHINE = "ti33x|ti43x|am57xx-evm|k2g"
5PACKAGE_ARCH = "${MACHINE_ARCH}" 5PACKAGE_ARCH = "${MACHINE_ARCH}"
6 6
7PRUSS_LLD_GIT_URI = "git://git.ti.com/keystone-rtos/pruss-lld.git" 7PRUSS_LLD_GIT_URI = "git://git.ti.com/keystone-rtos/pruss-lld.git"
@@ -9,12 +9,12 @@ PRUSS_LLD_GIT_PROTOCOL = "git"
9PRUSS_LLD_GIT_BRANCH = "master" 9PRUSS_LLD_GIT_BRANCH = "master"
10PRUSS_LLD_GIT_DESTSUFFIX = "git/ti/drv/pruss" 10PRUSS_LLD_GIT_DESTSUFFIX = "git/ti/drv/pruss"
11 11
12# Below commit ID corresponds to "DEV.PRUSS_LLD.01.00.00.06A" 12# Below commit ID corresponds to "DEV.PRUSS_LLD.01.00.00.07"
13PRUSS_LLD_SRCREV = "b98729cc1fc26c9ac32846146892646a23c28adb" 13PRUSS_LLD_SRCREV = "636bb5645014723c54c08245cf8c2ee401eceb4f"
14 14
15BRANCH = "${PRUSS_LLD_GIT_BRANCH}" 15BRANCH = "${PRUSS_LLD_GIT_BRANCH}"
16SRC_URI = "${PRUSS_LLD_GIT_URI};destsuffix=${PRUSS_LLD_GIT_DESTSUFFIX};protocol=${PRUSS_LLD_GIT_PROTOCOL};branch=${BRANCH}" 16SRC_URI = "${PRUSS_LLD_GIT_URI};destsuffix=${PRUSS_LLD_GIT_DESTSUFFIX};protocol=${PRUSS_LLD_GIT_PROTOCOL};branch=${BRANCH}"
17 17
18SRCREV = "${PRUSS_LLD_SRCREV}" 18SRCREV = "${PRUSS_LLD_SRCREV}"
19PV = "01.00.00.06A" 19PV = "01.00.00.07"
20INC_PR = "r0" 20INC_PR = "r0"