summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMahesh Radhakrishnan <m-radhakrishnan2@ti.com>2017-07-19 05:03:35 +0000
committerDenys Dmytriyenko <denys@ti.com>2017-08-24 15:41:43 -0400
commit88ef434d3dff9710e26ee7a46bc3b60b0f10e88f (patch)
tree85baba4c4d93f494ac5cdb543bf238ec4bf418df
parent5f81b55394cd27079df103a7a9b18927028163b8 (diff)
downloadmeta-ti-88ef434d3dff9710e26ee7a46bc3b60b0f10e88f.tar.gz
usb-lld-rtos: Added rtos recipe for usb-lld
Upstreaming RTOS low level driver for USB interface Signed-off-by: Mahesh Radhakrishnan <m-radhakrishnan2@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r--recipes-bsp/usb-lld/usb-lld-rtos_git.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/recipes-bsp/usb-lld/usb-lld-rtos_git.bb b/recipes-bsp/usb-lld/usb-lld-rtos_git.bb
new file mode 100644
index 00000000..a227981d
--- /dev/null
+++ b/recipes-bsp/usb-lld/usb-lld-rtos_git.bb
@@ -0,0 +1,36 @@
1SUMMARY = "TI RTOS USB low level driver"
2
3inherit ti-pdk
4
5LICENSE = "BSD-3-Clause"
6LIC_FILES_CHKSUM = "file://USBver.h;beginline=16;endline=46;md5=5394fa32763383d2c8e2aca5a1c67805"
7
8COMPATIBLE_MACHINE = "ti33x|ti43x|omap-a15|k2g"
9PACKAGE_ARCH = "${MACHINE_ARCH}"
10
11USB_LLD_GIT_URI = "git://git.ti.com/keystone-rtos/usb.git"
12USB_LLD_GIT_PROTOCOL = "git"
13USB_LLD_GIT_BRANCH = "master"
14
15# Below commit ID corresponds to "DEV.USB_LLD.01.00.00.09"
16USB_LLD_SRCREV = "6c2b21e5f6f8b34313f8d30a1de9b3e2fc301a73"
17
18BRANCH = "${USB_LLD_GIT_BRANCH}"
19SRC_URI = "${USB_LLD_GIT_URI};protocol=${USB_LLD_GIT_PROTOCOL};branch=${BRANCH}"
20
21SRCREV = "${USB_LLD_SRCREV}"
22PV = "01.00.00.09"
23PR = "r0"
24
25DEPENDS_append = " osal-rtos"
26DEPENDS_append_ti33x = " starterware-rtos"
27DEPENDS_append_ti43x = " starterware-rtos"
28
29# Build with make instead of XDC
30TI_PDK_XDCMAKE = "0"
31
32export PDK_USB_ROOT_PATH ="${WORKDIR}/build"
33export DEST_ROOT="${S}"
34
35# HTML doc link params
36PDK_COMP_LINK_TEXT = "USB LLD"