summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMahesh Radhakrishnan <m-radhakrishnan2@ti.com>2017-07-19 05:03:19 +0000
committerDenys Dmytriyenko <denys@ti.com>2017-08-16 13:49:00 -0400
commit967145d88639ec84986da6dfd0bea1550efc89cf (patch)
treeadfb3ad5426c1147bd946971ffa637e752e0c671
parentbc7cb9470a86c814a60f78056afb9de16a06479a (diff)
downloadmeta-ti-967145d88639ec84986da6dfd0bea1550efc89cf.tar.gz
gpmc-lld-rtos: Added rtos recipe for gpmc-lld
Upstreaming RTOS low level driver for General purpose memory controller (GPMC) Signed-off-by: Mahesh Radhakrishnan <m-radhakrishnan2@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r--recipes-bsp/gpmc-lld/gpmc-lld-rtos_git.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/recipes-bsp/gpmc-lld/gpmc-lld-rtos_git.bb b/recipes-bsp/gpmc-lld/gpmc-lld-rtos_git.bb
new file mode 100644
index 00000000..01ea5010
--- /dev/null
+++ b/recipes-bsp/gpmc-lld/gpmc-lld-rtos_git.bb
@@ -0,0 +1,39 @@
1SUMMARY = "TI RTOS low level driver for General Purpose Memory Controller (GPMC)"
2
3inherit ti-pdk
4
5LICENSE = "BSD-3-Clause"
6LIC_FILES_CHKSUM = "file://GPMC.h;beginline=1;endline=31;md5=485ec97c36f809bf92323fde3e988c72"
7
8COMPATIBLE_MACHINE = "ti33x|ti43x"
9PACKAGE_ARCH = "${MACHINE_ARCH}"
10
11GPMC_LLD_GIT_URI = "git://git.ti.com/keystone-rtos/gpmc-lld.git"
12GPMC_LLD_GIT_PROTOCOL = "git"
13GPMC_LLD_GIT_BRANCH = "master"
14
15# Below commit ID corresponds to "DEV.GPMC_LLD.01.00.00.01"
16GPMC_LLD_SRCREV = "86df4c099ad9c84f4b92d515ba64c343c75cf44d"
17
18BRANCH = "${GPMC_LLD_GIT_BRANCH}"
19SRC_URI = "${GPMC_LLD_GIT_URI};protocol=${GPMC_LLD_GIT_PROTOCOL};branch=${BRANCH}"
20
21SRCREV = "${GPMC_LLD_SRCREV}"
22PV = "01.00.00.01"
23PR = "r0"
24
25DEPENDS_append = " osal-rtos \
26"
27DEPENDS_append_ti33x = " starterware-rtos \
28"
29DEPENDS_append_ti43x = " starterware-rtos \
30"
31
32# Build with make instead of XDC
33TI_PDK_XDCMAKE = "0"
34
35# HTML doc link params
36PDK_COMP_LINK_TEXT = "GPMC LLD"
37
38export PDK_GPMC_ROOT_PATH ="${WORKDIR}/build"
39export DEST_ROOT="${S}"