summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMahesh Radhakrishnan <m-radhakrishnan2@ti.com>2017-07-19 05:03:12 +0000
committerDenys Dmytriyenko <denys@ti.com>2017-08-16 13:49:00 -0400
commit6ae83c332dfe62f02f15a8deb2c7a22efa23663f (patch)
tree3dfedd5d7837d8c3a70e422d06a56f7703f0e0e9
parenta18d57af8384ced25996739bb66d197c69efb77b (diff)
downloadmeta-ti-6ae83c332dfe62f02f15a8deb2c7a22efa23663f.tar.gz
bcp-lld-rtos: Added RTOS recipe for bcp-lld
Upstreaming the RTOS recipe for Bit Coprocessor LLD drvier Signed-off-by: Mahesh Radhakrishnan <m-radhakrishnan2@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r--recipes-bsp/bcp-lld/bcp-lld-rtos_git.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/recipes-bsp/bcp-lld/bcp-lld-rtos_git.bb b/recipes-bsp/bcp-lld/bcp-lld-rtos_git.bb
new file mode 100644
index 00000000..c6b52581
--- /dev/null
+++ b/recipes-bsp/bcp-lld/bcp-lld-rtos_git.bb
@@ -0,0 +1,33 @@
1SUMMARY = "TI Bit Coprocessor (BCP) low level driver"
2
3inherit ti-pdk
4
5LICENSE = "BSD-3-Clause"
6LIC_FILES_CHKSUM = "file://bcp.h;beginline=1;endline=40;md5=4f6e6128dd075a89548c0287a39b8896"
7
8COMPATIBLE_MACHINE = "k2hk-evm|k2l-evm|c667x-evm"
9PACKAGE_ARCH = "${MACHINE_ARCH}"
10
11BCP_LLD_GIT_URI = "git://git.ti.com/keystone-rtos/bcp-lld.git"
12BCP_LLD_GIT_PROTOCOL = "git"
13BCP_LLD_GIT_BRANCH = "master"
14BCP_LLD_GIT_DESTSUFFIX = "git/ti/drv/bcp"
15
16# Below commit ID corresponds to "DEV.BCP_LLD.02.01.00.06"
17BCP_LLD_SRCREV = "44e2ffcb6fd236c41f7ea8f9a1684833f5361daa"
18
19BRANCH = "${BCP_LLD_GIT_BRANCH}"
20SRC_URI = "${BCP_LLD_GIT_URI};destsuffix=${BCP_LLD_GIT_DESTSUFFIX};protocol=${BCP_LLD_GIT_PROTOCOL};branch=${BRANCH}"
21
22SRCREV = "${BCP_LLD_SRCREV}"
23PV = "02.01.00.06"
24PR = "r0"
25
26S = "${WORKDIR}/${BCP_LLD_GIT_DESTSUFFIX}"
27
28DEPENDS_append = " qmss-lld-rtos \
29 cppi-lld-rtos \
30"
31
32# HTML doc link params
33PDK_COMP_LINK_TEXT = "BCP LLD"