summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSam Nelson <sam.nelson@ti.com>2017-08-02 17:45:49 +0000
committerDenys Dmytriyenko <denys@ti.com>2017-08-04 18:08:17 -0400
commitc3dac59a54440a3b6514e046bef9a3d3cd4452cd (patch)
tree6d39664a87959c0d001700e05b7bf6cf85a8c87f
parent29f68fc20e903b75d888598ef8d2becb1aa04031 (diff)
downloadmeta-ti-c3dac59a54440a3b6514e046bef9a3d3cd4452cd.tar.gz
ti-ipc: Update to GA version 3.46.02.04
- Update ipcdev branch to 3.46 ( commit id remains same) - Adds support for c66x platforms - Update to avoid stripping for IPC rtos example binaries Signed-off-by: Sam Nelson <sam.nelson@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r--recipes-ti/ipc/ti-ipc-common.inc4
-rw-r--r--recipes-ti/ipc/ti-ipc-examples_git.bb7
-rw-r--r--recipes-ti/ipc/ti-ipc-rtos.inc14
-rw-r--r--recipes-ti/ipc/ti-ipc.inc4
4 files changed, 19 insertions, 10 deletions
diff --git a/recipes-ti/ipc/ti-ipc-common.inc b/recipes-ti/ipc/ti-ipc-common.inc
index d9956fc1..f2df6785 100644
--- a/recipes-ti/ipc/ti-ipc-common.inc
+++ b/recipes-ti/ipc/ti-ipc-common.inc
@@ -1,5 +1,5 @@
1PV = "3.46.02.04" 1PV = "3.46.02.04"
2INC_PR = "r0" 2INC_PR = "r1"
3 3
4PACKAGE_ARCH = "${MACHINE_ARCH}" 4PACKAGE_ARCH = "${MACHINE_ARCH}"
5 5
@@ -11,5 +11,7 @@ PLATFORM_k2l-evm = "TCI6630"
11PLATFORM_k2e = "66AK2E" 11PLATFORM_k2e = "66AK2E"
12PLATFORM_k2g = "66AK2G" 12PLATFORM_k2g = "66AK2G"
13PLATFORM_omapl138 = "OMAPL138" 13PLATFORM_omapl138 = "OMAPL138"
14PLATFORM_c667x-evm = "C6678"
15PLATFORM_c665x-evm = "C6678"
14 16
15ALT_PLATFORM_k2hk = "TCI6636" 17ALT_PLATFORM_k2hk = "TCI6636"
diff --git a/recipes-ti/ipc/ti-ipc-examples_git.bb b/recipes-ti/ipc/ti-ipc-examples_git.bb
index 40c3bc3b..23ce2bfc 100644
--- a/recipes-ti/ipc/ti-ipc-examples_git.bb
+++ b/recipes-ti/ipc/ti-ipc-examples_git.bb
@@ -1,5 +1,5 @@
1DESCRIPTION = "TI Inter Process Communication (IPC) examples" 1DESCRIPTION = "TI Inter Process Communication (IPC) examples"
2HOMEPAGE="http://processors.wiki.ti.com/index.php/Category:IPC" 2HOMEPAGE = "http://processors.wiki.ti.com/index.php/Category:IPC"
3require ti-ipc-common.inc 3require ti-ipc-common.inc
4require ti-ipc-rtos.inc 4require ti-ipc-rtos.inc
5 5
@@ -15,9 +15,9 @@ ALLOW_EMPTY_${PN} = "1"
15PACKAGES =+ "${PN}-linux" 15PACKAGES =+ "${PN}-linux"
16 16
17INSANE_SKIP_${PN}-linux += "arch" 17INSANE_SKIP_${PN}-linux += "arch"
18ALLOW_EMPTY_${PN}-linux = "1" 18ALLOW_EMPTY_${PN}-linux = "1"
19 19
20IPC_INSTALL_DIR="${STAGING_DIR_TARGET}/usr/share/ti/ti-ipc-tree" 20IPC_INSTALL_DIR = "${STAGING_DIR_TARGET}/usr/share/ti/ti-ipc-tree"
21 21
22do_compile() { 22do_compile() {
23 23
@@ -93,3 +93,4 @@ do_install() {
93 93
94FILES_${PN} += "ipc_*" 94FILES_${PN} += "ipc_*"
95FILES_${PN}-linux += "${bindir}/*" 95FILES_${PN}-linux += "${bindir}/*"
96INHIBIT_PACKAGE_STRIP = "1"
diff --git a/recipes-ti/ipc/ti-ipc-rtos.inc b/recipes-ti/ipc/ti-ipc-rtos.inc
index 7dc96029..5a34d4ba 100644
--- a/recipes-ti/ipc/ti-ipc-rtos.inc
+++ b/recipes-ti/ipc/ti-ipc-rtos.inc
@@ -24,11 +24,11 @@ protocol=${TI_IPC_METADATA_GIT_PROTOCOL};\
24branch=${TI_IPC_METADATA_GIT_BRANCH};\ 24branch=${TI_IPC_METADATA_GIT_BRANCH};\
25name=${TI_IPC_METADATA_NAME}" 25name=${TI_IPC_METADATA_NAME}"
26 26
27# Corresponds to tag: 3.46.02.04_eng 27# Corresponds to tag: 3.46.02.04
28SRCREV_ipc-examples = "b833c759d620b4218ece6d64fae91e4777ef823a" 28SRCREV_ipc-examples = "b833c759d620b4218ece6d64fae91e4777ef823a"
29 29
30# Corresponds to tag: 3.46.02.04_eng 30# Corresponds to tag: 3.46.02.04
31SRCREV_ipc-metadata = "bb07d3e00dcaf1074589e805be0a4ed2ada2d17c" 31SRCREV_ipc-metadata = "afdcf6855f05c97d2bb77867f4f150aed29c1b12"
32 32
33S_ipc-examples = "${WORKDIR}/git/ipc-examples" 33S_ipc-examples = "${WORKDIR}/git/ipc-examples"
34S_ipc-metadata = "${WORKDIR}/git/ipc-metadata" 34S_ipc-metadata = "${WORKDIR}/git/ipc-metadata"
@@ -36,7 +36,7 @@ S_ipc-metadata = "${WORKDIR}/git/ipc-metadata"
36RELEASE_TYPE = "ENG" 36RELEASE_TYPE = "ENG"
37RELEASE_SUFFIX = "_eng" 37RELEASE_SUFFIX = "_eng"
38 38
39PR = "${INC_PR}.r0" 39PR = "${INC_PR}.r1"
40 40
41DEPENDS_append_keystone = " ti-cgt6x-native \ 41DEPENDS_append_keystone = " ti-cgt6x-native \
42 gcc-arm-none-eabi-native \ 42 gcc-arm-none-eabi-native \
@@ -47,6 +47,8 @@ DEPENDS_append_omap-a15 = " ti-cgt6x-native \
47" 47"
48DEPENDS_append_omapl138 = " ti-cgt6x-native \ 48DEPENDS_append_omapl138 = " ti-cgt6x-native \
49" 49"
50DEPENDS_append_c66x = " ti-cgt6x-native \
51"
50 52
51IPC_TARGETS = "" 53IPC_TARGETS = ""
52 54
@@ -66,6 +68,10 @@ IPC_TARGETS_keystone = " \
66 ti.targets.elf.C66="${STAGING_DIR_NATIVE}/usr/share/ti/cgt-c6x" \ 68 ti.targets.elf.C66="${STAGING_DIR_NATIVE}/usr/share/ti/cgt-c6x" \
67 ti.targets.elf.C66_big_endian="${STAGING_DIR_NATIVE}/usr/share/ti/cgt-c6x" \ 69 ti.targets.elf.C66_big_endian="${STAGING_DIR_NATIVE}/usr/share/ti/cgt-c6x" \
68" 70"
71IPC_TARGETS_c66x = " \
72 ti.targets.elf.C66="${STAGING_DIR_NATIVE}/usr/share/ti/cgt-c6x" \
73 ti.targets.elf.C66_big_endian="${STAGING_DIR_NATIVE}/usr/share/ti/cgt-c6x" \
74"
69 75
70EXTRA_OEMAKE = "\ 76EXTRA_OEMAKE = "\
71 PLATFORM=${PLATFORM} \ 77 PLATFORM=${PLATFORM} \
diff --git a/recipes-ti/ipc/ti-ipc.inc b/recipes-ti/ipc/ti-ipc.inc
index 06c087a4..c3742c1b 100644
--- a/recipes-ti/ipc/ti-ipc.inc
+++ b/recipes-ti/ipc/ti-ipc.inc
@@ -6,9 +6,9 @@ LIC_FILES_CHKSUM = "file://${S}/ipc-linux.mak;beginline=1;endline=30;md5=7b327f9
6 6
7TI_IPC_GIT_URI = "git://git.ti.com/ipc/ipcdev.git" 7TI_IPC_GIT_URI = "git://git.ti.com/ipc/ipcdev.git"
8TI_IPC_GIT_PROTOCOL = "git" 8TI_IPC_GIT_PROTOCOL = "git"
9TI_IPC_GIT_BRANCH = "ipc-next" 9TI_IPC_GIT_BRANCH = "3.46"
10 10
11#Corresponds to 3.46.02.04_eng 11#Corresponds to 3.46.02.04
12TI_IPC_SRCREV = "bf355e7d0f5c3993f56a6ea778743b656ef6b536" 12TI_IPC_SRCREV = "bf355e7d0f5c3993f56a6ea778743b656ef6b536"
13 13
14BRANCH = "${TI_IPC_GIT_BRANCH}" 14BRANCH = "${TI_IPC_GIT_BRANCH}"