summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSam Nelson <sam.nelson@ti.com>2017-03-25 01:05:25 +0000
committerDenys Dmytriyenko <denys@ti.com>2017-03-27 10:56:25 -0400
commite65502c42ead0d9a831ed485222d3323d089705c (patch)
treef55b4e52b6e57404bdc41563532c4f7b27d87463
parentae9edd5f1ed133032dad1e2683f045a8b7d8aab5 (diff)
downloadmeta-ti-e65502c42ead0d9a831ed485222d3323d089705c.tar.gz
ti-ipc-examples: Update with change of directory structure
Separated Linux host examples into separate package ti-ipc-examples- linux and installed into /usr/bin directory. Signed-off-by: Sam Nelson <sam.nelson@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r--recipes-ti/ipc/ti-ipc-common.inc2
-rw-r--r--recipes-ti/ipc/ti-ipc-examples_git.bb25
2 files changed, 18 insertions, 9 deletions
diff --git a/recipes-ti/ipc/ti-ipc-common.inc b/recipes-ti/ipc/ti-ipc-common.inc
index 6aa08c53..c5f28e7c 100644
--- a/recipes-ti/ipc/ti-ipc-common.inc
+++ b/recipes-ti/ipc/ti-ipc-common.inc
@@ -1,5 +1,5 @@
1PV = "3.45.00.00" 1PV = "3.45.00.00"
2INC_PR = "r0" 2INC_PR = "r1"
3 3
4PACKAGE_ARCH = "${MACHINE_ARCH}" 4PACKAGE_ARCH = "${MACHINE_ARCH}"
5 5
diff --git a/recipes-ti/ipc/ti-ipc-examples_git.bb b/recipes-ti/ipc/ti-ipc-examples_git.bb
index 019bffac..40c3bc3b 100644
--- a/recipes-ti/ipc/ti-ipc-examples_git.bb
+++ b/recipes-ti/ipc/ti-ipc-examples_git.bb
@@ -12,6 +12,11 @@ INSANE_SKIP_${PN} += "arch"
12 12
13ALLOW_EMPTY_${PN} = "1" 13ALLOW_EMPTY_${PN} = "1"
14 14
15PACKAGES =+ "${PN}-linux"
16
17INSANE_SKIP_${PN}-linux += "arch"
18ALLOW_EMPTY_${PN}-linux = "1"
19
15IPC_INSTALL_DIR="${STAGING_DIR_TARGET}/usr/share/ti/ti-ipc-tree" 20IPC_INSTALL_DIR="${STAGING_DIR_TARGET}/usr/share/ti/ti-ipc-tree"
16 21
17do_compile() { 22do_compile() {
@@ -56,31 +61,35 @@ do_install() {
56 cd ${S_ipc-examples}/src 61 cd ${S_ipc-examples}/src
57 IPC_VERSION=`echo ${PV}${RELEASE_SUFFIX} | sed -e 's|\.|_|g'` 62 IPC_VERSION=`echo ${PV}${RELEASE_SUFFIX} | sed -e 's|\.|_|g'`
58 63
59 install -d ${D}/ipc_${IPC_VERSION}/examples
60 if [ "${PLATFORM}" != "UNKNOWN" ]; then 64 if [ "${PLATFORM}" != "UNKNOWN" ]; then
65 # Install directory for bios examples
66 install -d ${D}/ipc_${IPC_VERSION}/examples/bios
67 # Install directory for linux examples
68 install -d ${D}${bindir}/ipc/examples
61 oe_runmake -C examples install IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \ 69 oe_runmake -C examples install IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \
62 HOSTOS="bios" EXEC_DIR="${D}/ipc_${IPC_VERSION}/examples" 70 HOSTOS="bios" EXEC_DIR="${D}/ipc_${IPC_VERSION}/examples/bios"
63 oe_runmake -C examples install_rov IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \ 71 oe_runmake -C examples install_rov IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \
64 HOSTOS="bios" EXEC_DIR="${D}/ipc_${IPC_VERSION}/examples" 72 HOSTOS="bios" EXEC_DIR="${D}/ipc_${IPC_VERSION}/examples/bios"
65 73
66 oe_runmake -C examples install IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \ 74 oe_runmake -C examples install IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \
67 LINUX_SYSROOT_DIR="${STAGING_INCDIR}" \ 75 LINUX_SYSROOT_DIR="${STAGING_INCDIR}" \
68 HOSTOS="linux" EXEC_DIR="${D}/ipc_${IPC_VERSION}/examples" 76 HOSTOS="linux" EXEC_DIR="${D}/${bindir}/ipc/examples"
69 77
70 if [ ! -z ${ALT_PLATFORM} ]; then 78 if [ ! -z ${ALT_PLATFORM} ]; then
71 oe_runmake -C examples install IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \ 79 oe_runmake -C examples install IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \
72 HOSTOS="bios" EXEC_DIR="${D}/ipc_${IPC_VERSION}/examples" \ 80 HOSTOS="bios" EXEC_DIR="${D}/ipc_${IPC_VERSION}/examples/bios" \
73 PLATFORM="${ALT_PLATFORM}" 81 PLATFORM="${ALT_PLATFORM}"
74 oe_runmake -C examples install_rov IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \ 82 oe_runmake -C examples install_rov IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \
75 HOSTOS="bios" EXEC_DIR="${D}/ipc_${IPC_VERSION}/examples" \ 83 HOSTOS="bios" EXEC_DIR="${D}/ipc_${IPC_VERSION}/examples/bios" \
76 PLATFORM="${ALT_PLATFORM}" 84 PLATFORM="${ALT_PLATFORM}"
77 85
78 oe_runmake -C examples install IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \ 86 oe_runmake -C examples install IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \
79 LINUX_SYSROOT_DIR="${STAGING_INCDIR}" \ 87 LINUX_SYSROOT_DIR="${STAGING_INCDIR}" \
80 HOSTOS="linux" EXEC_DIR="${D}/ipc_${IPC_VERSION}/examples" \ 88 HOSTOS="linux" EXEC_DIR="${D}/${bindir}/ipc/examples" \
81 PLATFORM="${ALT_PLATFORM}" 89 PLATFORM="${ALT_PLATFORM}"
82 fi 90 fi
83 fi 91 fi
84} 92}
85 93
86FILES_${PN} += "ipc_*" 94FILES_${PN} += "ipc_*"
95FILES_${PN}-linux += "${bindir}/*"