summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJustin Sobota <jsobota@ti.com>2017-04-28 04:10:34 +0000
committerDenys Dmytriyenko <denys@ti.com>2017-04-28 14:07:41 -0400
commit79b145858addb68d37e22d08051b054b3a9280af (patch)
tree2fedd7a8ed3e28165083aec657f2177b453f4435
parent3648eba56c49393f7fc587d92f42a6e144b2f87d (diff)
downloadmeta-ti-79b145858addb68d37e22d08051b054b3a9280af.tar.gz
Resolve host contamination warnings
Signed-off-by: Justin Sobota <jsobota@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r--classes/ti-pdk.bbclass2
-rw-r--r--recipes-bsp/edma3-lld/edma3-lld-rtos_git.bb5
-rw-r--r--recipes-ti/bios/ti-sysbios.inc3
-rw-r--r--recipes-ti/devtools/ti-cg-xml_2.41.00.bb3
-rw-r--r--recipes-ti/dsplib/dsplib-c66x.inc3
-rw-r--r--recipes-ti/framework-components/ti-framework-components.inc3
-rw-r--r--recipes-ti/imglib/imglib-c66x.inc3
-rw-r--r--recipes-ti/mathlib/mathlib-c66x.inc3
-rw-r--r--recipes-ti/xdais/ti-xdais.inc3
9 files changed, 18 insertions, 10 deletions
diff --git a/classes/ti-pdk.bbclass b/classes/ti-pdk.bbclass
index eca3652c..981ec12e 100644
--- a/classes/ti-pdk.bbclass
+++ b/classes/ti-pdk.bbclass
@@ -89,7 +89,7 @@ do_compile() {
89 89
90do_install () { 90do_install () {
91 install -d ${D}${PDK_INSTALL_DIR_RECIPE}/packages 91 install -d ${D}${PDK_INSTALL_DIR_RECIPE}/packages
92 find -name "*.tar" -exec tar xf {} -C ${D}${PDK_INSTALL_DIR_RECIPE}/packages \; 92 find -name "*.tar" -exec tar xf {} --no-same-owner -C ${D}${PDK_INSTALL_DIR_RECIPE}/packages \;
93 93
94 if [ "${PDK_COMP_LINK_TEXT}" != "" ] 94 if [ "${PDK_COMP_LINK_TEXT}" != "" ]
95 then 95 then
diff --git a/recipes-bsp/edma3-lld/edma3-lld-rtos_git.bb b/recipes-bsp/edma3-lld/edma3-lld-rtos_git.bb
index ce9ef855..7fd778a4 100644
--- a/recipes-bsp/edma3-lld/edma3-lld-rtos_git.bb
+++ b/recipes-bsp/edma3-lld/edma3-lld-rtos_git.bb
@@ -2,7 +2,7 @@ require edma3-lld.inc
2require recipes-ti/includes/ti-paths.inc 2require recipes-ti/includes/ti-paths.inc
3require recipes-ti/includes/ti-staging.inc 3require recipes-ti/includes/ti-staging.inc
4 4
5PR = "${INC_PR}.0" 5PR = "${INC_PR}.1"
6 6
7DEPENDS = "ti-sysbios ti-xdctools gcc-arm-none-eabi-native ti-cgt-arm-native ti-cgt6x-native" 7DEPENDS = "ti-sysbios ti-xdctools gcc-arm-none-eabi-native ti-cgt-arm-native ti-cgt6x-native"
8 8
@@ -106,8 +106,9 @@ do_compile () {
106} 106}
107 107
108do_install () { 108do_install () {
109 CP_ARGS="-Prf --preserve=mode,timestamps --no-preserve=ownership"
109 install -d ${D}${EDMA3_LLD_INSTALL_DIR_RECIPE} 110 install -d ${D}${EDMA3_LLD_INSTALL_DIR_RECIPE}
110 cp -pPrf ${S}/* ${D}${EDMA3_LLD_INSTALL_DIR_RECIPE} 111 cp ${CP_ARGS} ${S}/* ${D}${EDMA3_LLD_INSTALL_DIR_RECIPE}
111} 112}
112 113
113INSANE_SKIP_${PN}-dev = "arch ldflags" 114INSANE_SKIP_${PN}-dev = "arch ldflags"
diff --git a/recipes-ti/bios/ti-sysbios.inc b/recipes-ti/bios/ti-sysbios.inc
index 408be783..53b55a52 100644
--- a/recipes-ti/bios/ti-sysbios.inc
+++ b/recipes-ti/bios/ti-sysbios.inc
@@ -15,8 +15,9 @@ BINFILE="bios_setuplinux_${PV}.bin"
15TI_BIN_UNPK_CMDS="Y: q:workdir:Y" 15TI_BIN_UNPK_CMDS="Y: q:workdir:Y"
16 16
17do_install() { 17do_install() {
18 CP_ARGS="-Prf --preserve=mode,timestamps --no-preserve=ownership"
18 install -d ${D}${SYSBIOS_INSTALL_DIR_RECIPE} 19 install -d ${D}${SYSBIOS_INSTALL_DIR_RECIPE}
19 cp -pPrf ${S}/* ${D}${SYSBIOS_INSTALL_DIR_RECIPE} 20 cp ${CP_ARGS} ${S}/* ${D}${SYSBIOS_INSTALL_DIR_RECIPE}
20} 21}
21 22
22ALLOW_EMPTY_${PN} = "1" 23ALLOW_EMPTY_${PN} = "1"
diff --git a/recipes-ti/devtools/ti-cg-xml_2.41.00.bb b/recipes-ti/devtools/ti-cg-xml_2.41.00.bb
index 115254eb..a0387b7b 100644
--- a/recipes-ti/devtools/ti-cg-xml_2.41.00.bb
+++ b/recipes-ti/devtools/ti-cg-xml_2.41.00.bb
@@ -25,8 +25,9 @@ TI_BIN_UNPK_CMDS=""
25TI_BIN_UNPK_ARGS="--prefix ${S} --mode silent" 25TI_BIN_UNPK_ARGS="--prefix ${S} --mode silent"
26 26
27do_install() { 27do_install() {
28 CP_ARGS="-Prf --preserve=mode,timestamps --no-preserve=ownership"
28 install -d ${D}${CG_XML_INSTALL_DIR_RECIPE} 29 install -d ${D}${CG_XML_INSTALL_DIR_RECIPE}
29 cp -pPrf ${S}/* ${D}${CG_XML_INSTALL_DIR_RECIPE} 30 cp ${CP_ARGS} ${S}/* ${D}${CG_XML_INSTALL_DIR_RECIPE}
30} 31}
31 32
32FILES_${PN} += "${CG_XML_INSTALL_DIR_RECIPE}" 33FILES_${PN} += "${CG_XML_INSTALL_DIR_RECIPE}"
diff --git a/recipes-ti/dsplib/dsplib-c66x.inc b/recipes-ti/dsplib/dsplib-c66x.inc
index 31acc1e8..ce978dbd 100644
--- a/recipes-ti/dsplib/dsplib-c66x.inc
+++ b/recipes-ti/dsplib/dsplib-c66x.inc
@@ -16,8 +16,9 @@ TI_BIN_UNPK_ARGS = "--mode silent --prefix ${S}"
16TI_BIN_UNPK_CMDS = "" 16TI_BIN_UNPK_CMDS = ""
17 17
18do_install() { 18do_install() {
19 CP_ARGS="-Prf --preserve=mode,timestamps --no-preserve=ownership"
19 install -d ${D}${DSPLIB_C66_INSTALL_DIR_RECIPE} 20 install -d ${D}${DSPLIB_C66_INSTALL_DIR_RECIPE}
20 cp -pPrf ${S}/* ${D}${DSPLIB_C66_INSTALL_DIR_RECIPE} 21 cp ${CP_ARGS} ${S}/* ${D}${DSPLIB_C66_INSTALL_DIR_RECIPE}
21} 22}
22 23
23ALLOW_EMPTY_${PN} = "1" 24ALLOW_EMPTY_${PN} = "1"
diff --git a/recipes-ti/framework-components/ti-framework-components.inc b/recipes-ti/framework-components/ti-framework-components.inc
index e111ec45..d3a1d758 100644
--- a/recipes-ti/framework-components/ti-framework-components.inc
+++ b/recipes-ti/framework-components/ti-framework-components.inc
@@ -11,8 +11,9 @@ S = "${WORKDIR}/framework_components_${PV}"
11SRC_URI = "http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/fc/${PV}/exports/framework_components_${PV},lite.tar.gz;name=fctarball" 11SRC_URI = "http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/fc/${PV}/exports/framework_components_${PV},lite.tar.gz;name=fctarball"
12 12
13do_install() { 13do_install() {
14 CP_ARGS="-Prf --preserve=mode,timestamps --no-preserve=ownership"
14 install -d ${D}${FC_INSTALL_DIR_RECIPE} 15 install -d ${D}${FC_INSTALL_DIR_RECIPE}
15 cp -pPrf ${S}/* ${D}${FC_INSTALL_DIR_RECIPE} 16 cp ${CP_ARGS} ${S}/* ${D}${FC_INSTALL_DIR_RECIPE}
16} 17}
17 18
18INSANE_SKIP_${PN} = "ldflags" 19INSANE_SKIP_${PN} = "ldflags"
diff --git a/recipes-ti/imglib/imglib-c66x.inc b/recipes-ti/imglib/imglib-c66x.inc
index 3c76ad5e..eb575985 100644
--- a/recipes-ti/imglib/imglib-c66x.inc
+++ b/recipes-ti/imglib/imglib-c66x.inc
@@ -18,8 +18,9 @@ TI_BIN_UNPK_ARGS = "--mode silent --prefix ${S}"
18TI_BIN_UNPK_CMDS = "" 18TI_BIN_UNPK_CMDS = ""
19 19
20do_install() { 20do_install() {
21 CP_ARGS="-Prf --preserve=mode,timestamps --no-preserve=ownership"
21 install -d ${D}${IMGLIB_C66_INSTALL_DIR_RECIPE} 22 install -d ${D}${IMGLIB_C66_INSTALL_DIR_RECIPE}
22 cp -pPrf ${S}/* ${D}${IMGLIB_C66_INSTALL_DIR_RECIPE} 23 cp ${CP_ARGS} ${S}/* ${D}${IMGLIB_C66_INSTALL_DIR_RECIPE}
23} 24}
24 25
25ALLOW_EMPTY_${PN} = "1" 26ALLOW_EMPTY_${PN} = "1"
diff --git a/recipes-ti/mathlib/mathlib-c66x.inc b/recipes-ti/mathlib/mathlib-c66x.inc
index 1511337e..7951e6ca 100644
--- a/recipes-ti/mathlib/mathlib-c66x.inc
+++ b/recipes-ti/mathlib/mathlib-c66x.inc
@@ -18,8 +18,9 @@ TI_BIN_UNPK_ARGS = "--mode silent --prefix ${S}"
18TI_BIN_UNPK_CMDS = "" 18TI_BIN_UNPK_CMDS = ""
19 19
20do_install() { 20do_install() {
21 CP_ARGS="-Prf --preserve=mode,timestamps --no-preserve=ownership"
21 install -d ${D}${MATHLIB_C66_INSTALL_DIR_RECIPE} 22 install -d ${D}${MATHLIB_C66_INSTALL_DIR_RECIPE}
22 cp -pPrf ${S}/* ${D}${MATHLIB_C66_INSTALL_DIR_RECIPE} 23 cp ${CP_ARGS} ${S}/* ${D}${MATHLIB_C66_INSTALL_DIR_RECIPE}
23} 24}
24 25
25ALLOW_EMPTY_${PN} = "1" 26ALLOW_EMPTY_${PN} = "1"
diff --git a/recipes-ti/xdais/ti-xdais.inc b/recipes-ti/xdais/ti-xdais.inc
index a12ad640..24268b3a 100644
--- a/recipes-ti/xdais/ti-xdais.inc
+++ b/recipes-ti/xdais/ti-xdais.inc
@@ -11,8 +11,9 @@ S = "${WORKDIR}/xdais_${PV}"
11SRC_URI = "http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/xdais/${PV}/exports/xdais_${PV}.tar.gz;name=xdaistarball" 11SRC_URI = "http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/xdais/${PV}/exports/xdais_${PV}.tar.gz;name=xdaistarball"
12 12
13do_install() { 13do_install() {
14 CP_ARGS="-Prf --preserve=mode,timestamps --no-preserve=ownership"
14 install -d ${D}${XDAIS_INSTALL_DIR_RECIPE} 15 install -d ${D}${XDAIS_INSTALL_DIR_RECIPE}
15 cp -pPrf ${S}/* ${D}${XDAIS_INSTALL_DIR_RECIPE} 16 cp ${CP_ARGS} ${S}/* ${D}${XDAIS_INSTALL_DIR_RECIPE}
16} 17}
17 18
18INHIBIT_PACKAGE_STRIP = "1" 19INHIBIT_PACKAGE_STRIP = "1"