summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-10-12 11:01:16 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2011-10-12 11:01:16 +0200
commitcaae2e5a8fe057de9c48bb1da783a72dc6ddabaf (patch)
tree12114bc1bb11af6537f42c96073346969e3a319b
parent79f827a9669e6849b294712b4e727d419b24df8c (diff)
downloadmeta-ti-caae2e5a8fe057de9c48bb1da783a72dc6ddabaf.tar.gz
u-boot 2011.10rc: update to latest Joel, rebase Jasons patches
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
-rw-r--r--recipes-bsp/u-boot/u-boot/0001-am335x-evm-hack-in-ethernet-rmii-clock.patch26
-rw-r--r--recipes-bsp/u-boot/u-boot/0002-am335x_evm-reduced-bootdelay-to-0.patch35
-rw-r--r--recipes-bsp/u-boot/u-boot/0005-am335x_evm-remove-redundant-attempt-to-load-uImage.patch27
-rw-r--r--recipes-bsp/u-boot/u-boot/2011.09git/0001-am335x_evm-reduced-bootdelay-to-1.patch26
-rw-r--r--recipes-bsp/u-boot/u-boot/2011.09git/0002-am335x_evm-read-uEnv.txt-instead-of-boot.scr.patch (renamed from recipes-bsp/u-boot/u-boot/0004-am335x_evm-read-uEnv.txt-instead-of-boot.scr.patch)33
-rw-r--r--recipes-bsp/u-boot/u-boot/2011.09git/0003-am335x_evm-boot-kernel-from-ext2-filesystem.patch (renamed from recipes-bsp/u-boot/u-boot/0003-am335x_evm-boot-kernel-from-ext2-filesystem.patch)0
-rw-r--r--recipes-bsp/u-boot/u-boot_2011.10rc.bb12
7 files changed, 44 insertions, 115 deletions
diff --git a/recipes-bsp/u-boot/u-boot/0001-am335x-evm-hack-in-ethernet-rmii-clock.patch b/recipes-bsp/u-boot/u-boot/0001-am335x-evm-hack-in-ethernet-rmii-clock.patch
deleted file mode 100644
index 3f030565..00000000
--- a/recipes-bsp/u-boot/u-boot/0001-am335x-evm-hack-in-ethernet-rmii-clock.patch
+++ /dev/null
@@ -1,26 +0,0 @@
1From 8bf8cbead1115e2a47b74f53b96272bbacad0df2 Mon Sep 17 00:00:00 2001
2From: Koen Kooi <koen@dominion.thruhere.net>
3Date: Fri, 7 Oct 2011 18:17:50 +0200
4Subject: [PATCH 1/5] am335x-evm: hack in ethernet rmii clock
5
6Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
7---
8 include/configs/am335x_evm.h | 2 +-
9 1 files changed, 1 insertions(+), 1 deletions(-)
10
11diff --git a/include/configs/am335x_evm.h b/include/configs/am335x_evm.h
12index 543c604..0f806aa 100755
13--- a/include/configs/am335x_evm.h
14+++ b/include/configs/am335x_evm.h
15@@ -163,7 +163,7 @@
16 "bootm ${loadaddr}\0" \
17
18 #define CONFIG_BOOTCOMMAND \
19- "if mmc rescan; then " \
20+ "mw.l 0x44e10650 0x05 ; if mmc rescan; then " \
21 "if run loadbootscript; then " \
22 "run bootscript; " \
23 "else " \
24--
251.6.6.1
26
diff --git a/recipes-bsp/u-boot/u-boot/0002-am335x_evm-reduced-bootdelay-to-0.patch b/recipes-bsp/u-boot/u-boot/0002-am335x_evm-reduced-bootdelay-to-0.patch
deleted file mode 100644
index b93d7046..00000000
--- a/recipes-bsp/u-boot/u-boot/0002-am335x_evm-reduced-bootdelay-to-0.patch
+++ /dev/null
@@ -1,35 +0,0 @@
1From 8c7d293dcbf1bb53c4e8f26fc2553e99880978d1 Mon Sep 17 00:00:00 2001
2From: Jason Kridner <jdk@ti.com>
3Date: Sat, 8 Oct 2011 15:48:57 -0400
4Subject: [PATCH 2/5] am335x_evm: reduced bootdelay to 0
5
6---
7 include/configs/am335x_evm.h | 5 +----
8 1 files changed, 1 insertions(+), 4 deletions(-)
9
10diff --git a/include/configs/am335x_evm.h b/include/configs/am335x_evm.h
11index 0f806aa..c5e608c 100755
12--- a/include/configs/am335x_evm.h
13+++ b/include/configs/am335x_evm.h
14@@ -24,7 +24,7 @@
15 #define CONFIG_AM335X_HSMMC_INSTANCE 0 /* 0 - MMC0, 1 - MMC1 */
16
17 /* set to negative value for no autoboot */
18-#define CONFIG_BOOTDELAY 3
19+#define CONFIG_BOOTDELAY 0
20
21 # if defined(CONFIG_SPI_BOOT)
22 # define CONFIG_SPI 1
23@@ -73,9 +73,6 @@
24 #define CONFIG_SETUP_MEMORY_TAGS 1
25 #define CONFIG_INITRD_TAG 1 /* Required for ramdisk support */
26
27-/* set to negative value for no autoboot */
28-#define CONFIG_BOOTDELAY 3
29-
30 #define CONFIG_MMC 1
31
32 #ifndef CONFIG_NOR_BOOT
33--
341.6.6.1
35
diff --git a/recipes-bsp/u-boot/u-boot/0005-am335x_evm-remove-redundant-attempt-to-load-uImage.patch b/recipes-bsp/u-boot/u-boot/0005-am335x_evm-remove-redundant-attempt-to-load-uImage.patch
deleted file mode 100644
index 6d484489..00000000
--- a/recipes-bsp/u-boot/u-boot/0005-am335x_evm-remove-redundant-attempt-to-load-uImage.patch
+++ /dev/null
@@ -1,27 +0,0 @@
1From 2f05cac97c5aba4d2dbd3e9ec6c53c8cbf27ee77 Mon Sep 17 00:00:00 2001
2From: Jason Kridner <jdk@ti.com>
3Date: Sat, 8 Oct 2011 16:57:08 -0400
4Subject: [PATCH 5/5] am335x_evm: remove redundant attempt to load uImage
5
6---
7 include/configs/am335x_evm.h | 4 +---
8 1 files changed, 1 insertions(+), 3 deletions(-)
9
10diff --git a/include/configs/am335x_evm.h b/include/configs/am335x_evm.h
11index e157fd7..cb69176 100755
12--- a/include/configs/am335x_evm.h
13+++ b/include/configs/am335x_evm.h
14@@ -175,9 +175,7 @@
15 "echo Running uenvcmd ...;" \
16 "run uenvcmd;" \
17 "fi;" \
18- "if run mmc_load_uimage; then " \
19- "run mmc_boot; " \
20- "fi; " \
21+ "run mmc_boot; " \
22 "fi; " \
23 "run nand_boot; " \
24
25--
261.6.6.1
27
diff --git a/recipes-bsp/u-boot/u-boot/2011.09git/0001-am335x_evm-reduced-bootdelay-to-1.patch b/recipes-bsp/u-boot/u-boot/2011.09git/0001-am335x_evm-reduced-bootdelay-to-1.patch
new file mode 100644
index 00000000..126806de
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot/2011.09git/0001-am335x_evm-reduced-bootdelay-to-1.patch
@@ -0,0 +1,26 @@
1From 722fc7ad06a0353c1c1d168804747c5c56614ae3 Mon Sep 17 00:00:00 2001
2From: Koen Kooi <koen@dominion.thruhere.net>
3Date: Wed, 12 Oct 2011 10:45:17 +0200
4Subject: [PATCH 1/2] am335x_evm: reduced bootdelay to 1
5
6Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
7---
8 include/configs/am335x_evm.h | 2 +-
9 1 files changed, 1 insertions(+), 1 deletions(-)
10
11diff --git a/include/configs/am335x_evm.h b/include/configs/am335x_evm.h
12index ddadc3e..dbb412a 100755
13--- a/include/configs/am335x_evm.h
14+++ b/include/configs/am335x_evm.h
15@@ -24,7 +24,7 @@
16 #define CONFIG_AM335X_HSMMC_INSTANCE 0 /* 0 - MMC0, 1 - MMC1 */
17
18 /* set to negative value for no autoboot */
19-#define CONFIG_BOOTDELAY 3
20+#define CONFIG_BOOTDELAY 1
21
22 # if defined(CONFIG_SPI_BOOT)
23 # define CONFIG_SPI 1
24--
251.6.6.1
26
diff --git a/recipes-bsp/u-boot/u-boot/0004-am335x_evm-read-uEnv.txt-instead-of-boot.scr.patch b/recipes-bsp/u-boot/u-boot/2011.09git/0002-am335x_evm-read-uEnv.txt-instead-of-boot.scr.patch
index c8a05396..a2e0f6d1 100644
--- a/recipes-bsp/u-boot/u-boot/0004-am335x_evm-read-uEnv.txt-instead-of-boot.scr.patch
+++ b/recipes-bsp/u-boot/u-boot/2011.09git/0002-am335x_evm-read-uEnv.txt-instead-of-boot.scr.patch
@@ -1,35 +1,32 @@
1From abf7185e16b2b96db7aa06af56bd84836eff92f6 Mon Sep 17 00:00:00 2001 1From 527309ca11da0a258479da8443f00de0003c4bf9 Mon Sep 17 00:00:00 2001
2From: Jason Kridner <jdk@ti.com> 2From: Koen Kooi <koen@dominion.thruhere.net>
3Date: Sat, 8 Oct 2011 16:20:50 -0400 3Date: Wed, 12 Oct 2011 10:50:51 +0200
4Subject: [PATCH 4/5] am335x_evm: read uEnv.txt instead of boot.scr 4Subject: [PATCH 2/2] am335x_evm: read uEnv.txt instead of boot.scr
5 5
6Also restructured the BOOTCMD flow a bit to avoid pointless if/then depth. 6Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
7
8I'm considering to respect both boot.scr and uEnv.txt.
9--- 7---
10 include/configs/am335x_evm.h | 30 ++++++++++++++++++------------ 8 include/configs/am335x_evm.h | 25 ++++++++++++++-----------
11 1 files changed, 18 insertions(+), 12 deletions(-) 9 1 files changed, 14 insertions(+), 11 deletions(-)
12 10
13diff --git a/include/configs/am335x_evm.h b/include/configs/am335x_evm.h 11diff --git a/include/configs/am335x_evm.h b/include/configs/am335x_evm.h
14index a2e4564..e157fd7 100755 12index dbb412a..5a28724 100755
15--- a/include/configs/am335x_evm.h 13--- a/include/configs/am335x_evm.h
16+++ b/include/configs/am335x_evm.h 14+++ b/include/configs/am335x_evm.h
17@@ -112,6 +112,10 @@ 15@@ -116,6 +116,10 @@
18 "loadbootscript=fatload mmc 0 ${script_addr} boot.scr\0" \ 16 "loadbootscript=fatload mmc 0 ${script_addr} boot.scr\0" \
19 "bootscript= echo Running bootscript from MMC/SD to set the ENV...; " \ 17 "bootscript= echo Running bootscript from MMC/SD to set the ENV...; " \
20 "source ${script_addr}\0" \ 18 "source ${script_addr}\0" \
21+ "bootenv=uEnv.txt\0" \ 19+ "bootenv=uEnv.txt\0" \
22+ "loadbootenv=fatload mmc 0 ${loadaddr} ${bootenv}\0" \ 20+ "loadbootenv=fatload mmc 0 ${loadaddr} ${bootenv}\0" \
23+ "importbootenv=echo Importing environment from mmc ...; " \ 21+ "importbootenv=echo Importing environment from mmc ...; " \
24+ "env import -t $loadaddr $filesize\0" \ 22+ "env import -t $loadaddr $filesize\0" \
25 "mmc_load_uimage_fat=fatload mmc 0 ${loadaddr} ${bootfile}\0" \ 23 "mmc_load_uimage_fat=fatload mmc 0 ${loadaddr} ${bootfile}\0" \
26 "mmc_load_uimage=ext2load mmc 0:2 ${loadaddr} /boot/${bootfile}\0" \ 24 "mmc_load_uimage=ext2load mmc 0:2 ${loadaddr} /boot/${bootfile}\0" \
27 "bootargs_defaults=setenv bootargs " \ 25 "bootargs_defaults=setenv bootargs " \
28@@ -161,19 +165,21 @@ 26@@ -167,18 +171,17 @@
29 "bootm ${loadaddr}\0" \
30 27
31 #define CONFIG_BOOTCOMMAND \ 28 #define CONFIG_BOOTCOMMAND \
32- "mw.l 0x44e10650 0x05 ; if mmc rescan; then " \ 29 "if mmc rescan; then " \
33- "if run loadbootscript; then " \ 30- "if run loadbootscript; then " \
34- "run bootscript; " \ 31- "run bootscript; " \
35- "else " \ 32- "else " \
@@ -38,8 +35,6 @@ index a2e4564..e157fd7 100755
38- "else " \ 35- "else " \
39- "run nand_boot; " \ 36- "run nand_boot; " \
40- "fi; " \ 37- "fi; " \
41+ "mw.l 0x44e10650 0x05 ; " \
42+ "if mmc rescan; then " \
43+ "if run loadbootenv; then " \ 38+ "if run loadbootenv; then " \
44+ "echo Loaded environment from ${bootenv};" \ 39+ "echo Loaded environment from ${bootenv};" \
45+ "run importbootenv; " \ 40+ "run importbootenv; " \
@@ -51,9 +46,7 @@ index a2e4564..e157fd7 100755
51+ "echo Running uenvcmd ...;" \ 46+ "echo Running uenvcmd ...;" \
52+ "run uenvcmd;" \ 47+ "run uenvcmd;" \
53+ "fi;" \ 48+ "fi;" \
54+ "if run mmc_load_uimage; then " \ 49+ "run mmc_boot; " \
55+ "run mmc_boot; " \
56+ "fi; " \
57+ "fi; " \ 50+ "fi; " \
58+ "run nand_boot; " \ 51+ "run nand_boot; " \
59 52
diff --git a/recipes-bsp/u-boot/u-boot/0003-am335x_evm-boot-kernel-from-ext2-filesystem.patch b/recipes-bsp/u-boot/u-boot/2011.09git/0003-am335x_evm-boot-kernel-from-ext2-filesystem.patch
index 47fa7aa1..47fa7aa1 100644
--- a/recipes-bsp/u-boot/u-boot/0003-am335x_evm-boot-kernel-from-ext2-filesystem.patch
+++ b/recipes-bsp/u-boot/u-boot/2011.09git/0003-am335x_evm-boot-kernel-from-ext2-filesystem.patch
diff --git a/recipes-bsp/u-boot/u-boot_2011.10rc.bb b/recipes-bsp/u-boot/u-boot_2011.10rc.bb
index 5607bd67..8c3384e6 100644
--- a/recipes-bsp/u-boot/u-boot_2011.10rc.bb
+++ b/recipes-bsp/u-boot/u-boot_2011.10rc.bb
@@ -4,7 +4,7 @@ require u-boot.inc
4COMPATIBLE_MACHINE = "beaglebone" 4COMPATIBLE_MACHINE = "beaglebone"
5DEFAULT_PREFERENCE_beaglebone = "99" 5DEFAULT_PREFERENCE_beaglebone = "99"
6PV = "2011.09+git" 6PV = "2011.09+git"
7PR = "r3" 7PR = "r4"
8 8
9# SPL build 9# SPL build
10UBOOT_BINARY = "u-boot.img" 10UBOOT_BINARY = "u-boot.img"
@@ -12,13 +12,11 @@ UBOOT_IMAGE = "u-boot-${MACHINE}-${PV}-${PR}.img"
12UBOOT_SYMLINK = "u-boot-${MACHINE}.img" 12UBOOT_SYMLINK = "u-boot-${MACHINE}.img"
13 13
14SRC_URI = "git://github.com/joelagnel/u-boot.git;protocol=git;branch=bone-bringup \ 14SRC_URI = "git://github.com/joelagnel/u-boot.git;protocol=git;branch=bone-bringup \
15 file://0001-am335x-evm-hack-in-ethernet-rmii-clock.patch \ 15 file://2011.09git/0003-am335x_evm-boot-kernel-from-ext2-filesystem.patch \
16 file://0002-am335x_evm-reduced-bootdelay-to-0.patch \ 16 file://2011.09git/0001-am335x_evm-reduced-bootdelay-to-1.patch \
17 file://0003-am335x_evm-boot-kernel-from-ext2-filesystem.patch \ 17 file://2011.09git/0002-am335x_evm-read-uEnv.txt-instead-of-boot.scr.patch \
18 file://0004-am335x_evm-read-uEnv.txt-instead-of-boot.scr.patch \
19 file://0005-am335x_evm-remove-redundant-attempt-to-load-uImage.patch \
20 " 18 "
21SRCREV = "d643e691ab2055ef64f73dd70300a73e0443d1ef" 19SRCREV = "fb3043c07bc05df83d38bfd2b303f2c9a96779c6"
22 20
23LIC_FILES_CHKSUM = "file://COPYING;md5=1707d6db1d42237583f50183a5651ecb" 21LIC_FILES_CHKSUM = "file://COPYING;md5=1707d6db1d42237583f50183a5651ecb"
24 22