summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-11-01 09:01:28 +0100
committerKoen Kooi <koen@dominion.thruhere.net>2011-11-01 09:01:28 +0100
commitbba583b39be777852060cde2a24b8156cacb943b (patch)
treeddae7c4d2fbb40df51c45fd16a1ea5dfa638e1f6
parent20226232cbaa715f24719cbd0aa1a93a29f047b7 (diff)
downloadmeta-ti-bba583b39be777852060cde2a24b8156cacb943b.tar.gz
xserver-xf86-config: add configs for all SOC_FAMILIES
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
-rw-r--r--recipes-graphics/xorg-xserver/xserver-xf86-config/omap4/xorg.conf29
-rw-r--r--recipes-graphics/xorg-xserver/xserver-xf86-config/omapl138/xorg.conf29
-rw-r--r--recipes-graphics/xorg-xserver/xserver-xf86-config/ti33x/xorg.conf29
-rw-r--r--recipes-graphics/xorg-xserver/xserver-xf86-config/ti814x/xorg.conf29
-rw-r--r--recipes-graphics/xorg-xserver/xserver-xf86-config/ti816x/xorg.conf29
-rw-r--r--recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend2
6 files changed, 146 insertions, 1 deletions
diff --git a/recipes-graphics/xorg-xserver/xserver-xf86-config/omap4/xorg.conf b/recipes-graphics/xorg-xserver/xserver-xf86-config/omap4/xorg.conf
new file mode 100644
index 00000000..0d6ab435
--- /dev/null
+++ b/recipes-graphics/xorg-xserver/xserver-xf86-config/omap4/xorg.conf
@@ -0,0 +1,29 @@
1Section "Module"
2 Load "extmod"
3 Load "dbe"
4 Load "glx"
5 Load "freetype"
6 Load "type1"
7 Load "record"
8 Load "dri"
9EndSection
10
11Section "Monitor"
12 Identifier "Builtin Default Monitor"
13EndSection
14
15Section "Device"
16 Identifier "Builtin Default fbdev Device 0"
17 Driver "fbdev"
18EndSection
19
20Section "Screen"
21 Identifier "Builtin Default fbdev Screen 0"
22 Device "Builtin Default fbdev Device 0"
23 Monitor "Builtin Default Monitor"
24EndSection
25
26Section "ServerLayout"
27 Identifier "Builtin Default Layout"
28 Screen "Builtin Default fbdev Screen 0"
29EndSection
diff --git a/recipes-graphics/xorg-xserver/xserver-xf86-config/omapl138/xorg.conf b/recipes-graphics/xorg-xserver/xserver-xf86-config/omapl138/xorg.conf
new file mode 100644
index 00000000..0d6ab435
--- /dev/null
+++ b/recipes-graphics/xorg-xserver/xserver-xf86-config/omapl138/xorg.conf
@@ -0,0 +1,29 @@
1Section "Module"
2 Load "extmod"
3 Load "dbe"
4 Load "glx"
5 Load "freetype"
6 Load "type1"
7 Load "record"
8 Load "dri"
9EndSection
10
11Section "Monitor"
12 Identifier "Builtin Default Monitor"
13EndSection
14
15Section "Device"
16 Identifier "Builtin Default fbdev Device 0"
17 Driver "fbdev"
18EndSection
19
20Section "Screen"
21 Identifier "Builtin Default fbdev Screen 0"
22 Device "Builtin Default fbdev Device 0"
23 Monitor "Builtin Default Monitor"
24EndSection
25
26Section "ServerLayout"
27 Identifier "Builtin Default Layout"
28 Screen "Builtin Default fbdev Screen 0"
29EndSection
diff --git a/recipes-graphics/xorg-xserver/xserver-xf86-config/ti33x/xorg.conf b/recipes-graphics/xorg-xserver/xserver-xf86-config/ti33x/xorg.conf
new file mode 100644
index 00000000..0d6ab435
--- /dev/null
+++ b/recipes-graphics/xorg-xserver/xserver-xf86-config/ti33x/xorg.conf
@@ -0,0 +1,29 @@
1Section "Module"
2 Load "extmod"
3 Load "dbe"
4 Load "glx"
5 Load "freetype"
6 Load "type1"
7 Load "record"
8 Load "dri"
9EndSection
10
11Section "Monitor"
12 Identifier "Builtin Default Monitor"
13EndSection
14
15Section "Device"
16 Identifier "Builtin Default fbdev Device 0"
17 Driver "fbdev"
18EndSection
19
20Section "Screen"
21 Identifier "Builtin Default fbdev Screen 0"
22 Device "Builtin Default fbdev Device 0"
23 Monitor "Builtin Default Monitor"
24EndSection
25
26Section "ServerLayout"
27 Identifier "Builtin Default Layout"
28 Screen "Builtin Default fbdev Screen 0"
29EndSection
diff --git a/recipes-graphics/xorg-xserver/xserver-xf86-config/ti814x/xorg.conf b/recipes-graphics/xorg-xserver/xserver-xf86-config/ti814x/xorg.conf
new file mode 100644
index 00000000..0d6ab435
--- /dev/null
+++ b/recipes-graphics/xorg-xserver/xserver-xf86-config/ti814x/xorg.conf
@@ -0,0 +1,29 @@
1Section "Module"
2 Load "extmod"
3 Load "dbe"
4 Load "glx"
5 Load "freetype"
6 Load "type1"
7 Load "record"
8 Load "dri"
9EndSection
10
11Section "Monitor"
12 Identifier "Builtin Default Monitor"
13EndSection
14
15Section "Device"
16 Identifier "Builtin Default fbdev Device 0"
17 Driver "fbdev"
18EndSection
19
20Section "Screen"
21 Identifier "Builtin Default fbdev Screen 0"
22 Device "Builtin Default fbdev Device 0"
23 Monitor "Builtin Default Monitor"
24EndSection
25
26Section "ServerLayout"
27 Identifier "Builtin Default Layout"
28 Screen "Builtin Default fbdev Screen 0"
29EndSection
diff --git a/recipes-graphics/xorg-xserver/xserver-xf86-config/ti816x/xorg.conf b/recipes-graphics/xorg-xserver/xserver-xf86-config/ti816x/xorg.conf
new file mode 100644
index 00000000..0d6ab435
--- /dev/null
+++ b/recipes-graphics/xorg-xserver/xserver-xf86-config/ti816x/xorg.conf
@@ -0,0 +1,29 @@
1Section "Module"
2 Load "extmod"
3 Load "dbe"
4 Load "glx"
5 Load "freetype"
6 Load "type1"
7 Load "record"
8 Load "dri"
9EndSection
10
11Section "Monitor"
12 Identifier "Builtin Default Monitor"
13EndSection
14
15Section "Device"
16 Identifier "Builtin Default fbdev Device 0"
17 Driver "fbdev"
18EndSection
19
20Section "Screen"
21 Identifier "Builtin Default fbdev Screen 0"
22 Device "Builtin Default fbdev Device 0"
23 Monitor "Builtin Default Monitor"
24EndSection
25
26Section "ServerLayout"
27 Identifier "Builtin Default Layout"
28 Screen "Builtin Default fbdev Screen 0"
29EndSection
diff --git a/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend b/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend
index 73c440e8..1615df38 100644
--- a/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend
+++ b/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend
@@ -1,4 +1,4 @@
1PRINC = "1" 1PRINC = "2"
2 2
3THISDIR := "${@os.path.dirname(bb.data.getVar('FILE', d, True))}" 3THISDIR := "${@os.path.dirname(bb.data.getVar('FILE', d, True))}"
4FILESPATH =. "${@base_set_filespath(["${THISDIR}/${PN}"], d)}:" 4FILESPATH =. "${@base_set_filespath(["${THISDIR}/${PN}"], d)}:"