summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2016-01-20 05:49:37 +0000
committerDenys Dmytriyenko <denys@ti.com>2016-01-22 00:51:49 -0500
commit085f3d58e4293806683a49c084ce49181eb97f1d (patch)
tree9a098bca910a043fd08e20f26ae218903c7f0dd6
parent63b3736c18c418ef2cc5dd7b1533b49f6d65b8fb (diff)
downloadmeta-ti-085f3d58e4293806683a49c084ce49181eb97f1d.tar.gz
linux-ti-staging: split out systest defconfig into own recipe
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r--recipes-kernel/linux/linux-ti-staging-systest-4.1/defconfig (renamed from recipes-kernel/linux/linux-ti-staging-4.1/configs/systest)0
-rw-r--r--recipes-kernel/linux/linux-ti-staging-systest-4.1/keystone/defconfig (renamed from recipes-kernel/linux/linux-ti-staging-4.1/keystone/configs/systest)0
-rw-r--r--recipes-kernel/linux/linux-ti-staging-systest_4.1.bb5
-rw-r--r--recipes-kernel/linux/linux-ti-staging_4.1.bb1
-rw-r--r--recipes-kernel/linux/setup-defconfig.inc10
5 files changed, 14 insertions, 2 deletions
diff --git a/recipes-kernel/linux/linux-ti-staging-4.1/configs/systest b/recipes-kernel/linux/linux-ti-staging-systest-4.1/defconfig
index cfe4f991..cfe4f991 100644
--- a/recipes-kernel/linux/linux-ti-staging-4.1/configs/systest
+++ b/recipes-kernel/linux/linux-ti-staging-systest-4.1/defconfig
diff --git a/recipes-kernel/linux/linux-ti-staging-4.1/keystone/configs/systest b/recipes-kernel/linux/linux-ti-staging-systest-4.1/keystone/defconfig
index 68cfc252..68cfc252 100644
--- a/recipes-kernel/linux/linux-ti-staging-4.1/keystone/configs/systest
+++ b/recipes-kernel/linux/linux-ti-staging-systest-4.1/keystone/defconfig
diff --git a/recipes-kernel/linux/linux-ti-staging-systest_4.1.bb b/recipes-kernel/linux/linux-ti-staging-systest_4.1.bb
new file mode 100644
index 00000000..30962e69
--- /dev/null
+++ b/recipes-kernel/linux/linux-ti-staging-systest_4.1.bb
@@ -0,0 +1,5 @@
1require linux-ti-staging_4.1.bb
2
3# Look in the generic major.minor directory for files
4# This will have priority over generic non-rt path
5FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}-4.1:"
diff --git a/recipes-kernel/linux/linux-ti-staging_4.1.bb b/recipes-kernel/linux/linux-ti-staging_4.1.bb
index a6615aaa..e02e5cd0 100644
--- a/recipes-kernel/linux/linux-ti-staging_4.1.bb
+++ b/recipes-kernel/linux/linux-ti-staging_4.1.bb
@@ -7,7 +7,6 @@ inherit kernel
7 7
8require recipes-kernel/linux/linux-dtb.inc 8require recipes-kernel/linux/linux-dtb.inc
9require recipes-kernel/linux/setup-defconfig.inc 9require recipes-kernel/linux/setup-defconfig.inc
10require recipes-kernel/linux/multi-kernel.inc
11require recipes-kernel/linux/cmem.inc 10require recipes-kernel/linux/cmem.inc
12 11
13# Look in the generic major.minor directory for files 12# Look in the generic major.minor directory for files
diff --git a/recipes-kernel/linux/setup-defconfig.inc b/recipes-kernel/linux/setup-defconfig.inc
index 2b67bfc8..cfad14b2 100644
--- a/recipes-kernel/linux/setup-defconfig.inc
+++ b/recipes-kernel/linux/setup-defconfig.inc
@@ -1,6 +1,14 @@
1# KERNEL_LOCALVERSION can be set to add a tag to the end of the 1# KERNEL_LOCALVERSION can be set to add a tag to the end of the
2# kernel version string. such as the commit id 2# kernel version string. such as the commit id
3KERNEL_LOCALVERSION ?= "" 3def get_git_revision(p):
4 import subprocess
5
6 try:
7 return subprocess.Popen("git rev-parse HEAD 2>/dev/null ", cwd=p, shell=True, stdout=subprocess.PIPE).communicate()[0].rstrip()
8 except OSError:
9 return None
10
11KERNEL_LOCALVERSION = "-g${@get_git_revision('${S}').__str__()[:10]}"
4 12
5# Check the defconfig file and see if it points to an in kernel 13# Check the defconfig file and see if it points to an in kernel
6# defconfig that should be used, or if it is a complete config file 14# defconfig that should be used, or if it is a complete config file