diff options
author | Sam Nelson <sam.nelson@ti.com> | 2016-11-29 20:28:10 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2016-12-06 19:39:26 -0500 |
commit | 16bf3379a3428b93e7bf4282b9175f40c4509f21 (patch) | |
tree | 68a9d8a84dca3cc3e945611d9979fab7929b8461 | |
parent | f7719a0e1dbb0c3f6ad226338ecd3ccbc876cdd9 (diff) | |
download | meta-ti-16bf3379a3428b93e7bf4282b9175f40c4509f21.tar.gz |
ti-ipc: Reorganised recipes to help in adding ipc examples recipes
Created ti-ipc-common.inc & ti-ipc-rtos.inc to gather common definitions
Updated commmit ids for ipc-examples
Update ti-ipc-rtos to add ALT_PLATFORM examples
Signed-off-by: Sam Nelson <sam.nelson@ti.com>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r-- | recipes-ti/ipc/ti-ipc-common.inc | 14 | ||||
-rw-r--r-- | recipes-ti/ipc/ti-ipc-rtos.inc | 65 | ||||
-rw-r--r-- | recipes-ti/ipc/ti-ipc-rtos_git.bb | 72 | ||||
-rw-r--r-- | recipes-ti/ipc/ti-ipc.inc | 16 | ||||
-rw-r--r-- | recipes-ti/ipc/ti-ipc_git.bb | 1 |
5 files changed, 88 insertions, 80 deletions
diff --git a/recipes-ti/ipc/ti-ipc-common.inc b/recipes-ti/ipc/ti-ipc-common.inc new file mode 100644 index 00000000..ddb48bc1 --- /dev/null +++ b/recipes-ti/ipc/ti-ipc-common.inc | |||
@@ -0,0 +1,14 @@ | |||
1 | PV = "3.44.00.00" | ||
2 | INC_PR = "r2" | ||
3 | |||
4 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||
5 | |||
6 | PLATFORM = "UNKNOWN" | ||
7 | PLATFORM_omap5-evm = "OMAP54XX" | ||
8 | PLATFORM_dra7xx = "DRA7XX" | ||
9 | PLATFORM_k2hk-evm = "TCI6638" | ||
10 | PLATFORM_k2l-evm = "TCI6630" | ||
11 | PLATFORM_k2e = "66AK2E" | ||
12 | PLATFORM_k2g = "66AK2G" | ||
13 | |||
14 | ALT_PLATFORM_k2hk-evm = "TCI6636" | ||
diff --git a/recipes-ti/ipc/ti-ipc-rtos.inc b/recipes-ti/ipc/ti-ipc-rtos.inc new file mode 100644 index 00000000..e1abf368 --- /dev/null +++ b/recipes-ti/ipc/ti-ipc-rtos.inc | |||
@@ -0,0 +1,65 @@ | |||
1 | require recipes-ti/includes/ti-paths.inc | ||
2 | require recipes-ti/includes/ti-staging.inc | ||
3 | |||
4 | TI_IPC_EXAMPLES_GIT_URI = "git://git.ti.com/ipc/ipc-examples.git" | ||
5 | TI_IPC_EXAMPLES_DEST_SUFFIX = "git/ipc-examples" | ||
6 | TI_IPC_EXAMPLES_GIT_PROTOCOL = "git" | ||
7 | TI_IPC_EXAMPLES_GIT_BRANCH = "master" | ||
8 | TI_IPC_EXAMPLES_NAME = "ipc-examples" | ||
9 | |||
10 | SRC_URI += "${TI_IPC_EXAMPLES_GIT_URI};\ | ||
11 | destsuffix=${TI_IPC_EXAMPLES_DEST_SUFFIX};\ | ||
12 | protocol=${TI_IPC_EXAMPLES_GIT_PROTOCOL};\ | ||
13 | branch=${TI_IPC_EXAMPLES_GIT_BRANCH};\ | ||
14 | name=${TI_IPC_EXAMPLES_NAME}" | ||
15 | |||
16 | TI_IPC_METADATA_GIT_URI = "git://git.ti.com/ipc/ipc-metadata.git" | ||
17 | TI_IPC_METADATA_DEST_SUFFIX = "git/ipc-metadata" | ||
18 | TI_IPC_METADATA_GIT_PROTOCOL = "git" | ||
19 | TI_IPC_METADATA_GIT_BRANCH = "master" | ||
20 | TI_IPC_METADATA_NAME = "ipc-metadata" | ||
21 | |||
22 | SRC_URI += "${TI_IPC_METADATA_GIT_URI};\ | ||
23 | destsuffix=${TI_IPC_METADATA_DEST_SUFFIX};\ | ||
24 | protocol=${TI_IPC_METADATA_GIT_PROTOCOL};\ | ||
25 | branch=${TI_IPC_METADATA_GIT_BRANCH};\ | ||
26 | name=${TI_IPC_METADATA_NAME}" | ||
27 | |||
28 | # Corresponds to tag: 3.44.00.00C | ||
29 | SRCREV_ipc-examples = "1b73bc32c5bdd869b5121f86859afb122d286acc" | ||
30 | |||
31 | # Corresponds to tag: 3.44.00.00 | ||
32 | SRCREV_ipc-metadata = "07a745d47ecd7b4b64860e7c5d0fbe4e89524f2e" | ||
33 | |||
34 | S_ipc-examples = "${WORKDIR}/git/ipc-examples" | ||
35 | S_ipc-metadata = "${WORKDIR}/git/ipc-metadata" | ||
36 | |||
37 | PR = "${INC_PR}.4" | ||
38 | |||
39 | DEPENDS_append_keystone = " ti-cgt6x-native \ | ||
40 | gcc-arm-none-eabi-native \ | ||
41 | " | ||
42 | DEPENDS_append_omap-a15 = " ti-cgt6x-native \ | ||
43 | ti-ccsv6-native \ | ||
44 | gcc-arm-none-eabi-native \ | ||
45 | " | ||
46 | IPC_TARGETS = "" | ||
47 | IPC_TARGETS_omap-a15 = "\ | ||
48 | gnu.targets.arm.A15F="${GCC_ARM_NONE_TOOLCHAIN}" \ | ||
49 | ti.targets.elf.C66="${STAGING_DIR_NATIVE}/usr/share/ti/cgt-c6x" \ | ||
50 | ti.targets.elf.C66_big_endian="${STAGING_DIR_NATIVE}/usr/share/ti/cgt-c6x" \ | ||
51 | ti.targets.arm.elf.M4="${M4_TOOLCHAIN_INSTALL_DIR}" \ | ||
52 | " | ||
53 | |||
54 | IPC_TARGETS_keystone = " \ | ||
55 | gnu.targets.arm.A15F="${GCC_ARM_NONE_TOOLCHAIN}" \ | ||
56 | ti.targets.elf.C66="${STAGING_DIR_NATIVE}/usr/share/ti/cgt-c6x" \ | ||
57 | ti.targets.elf.C66_big_endian="${STAGING_DIR_NATIVE}/usr/share/ti/cgt-c6x" \ | ||
58 | " | ||
59 | |||
60 | EXTRA_OEMAKE = "\ | ||
61 | PLATFORM=${PLATFORM} \ | ||
62 | XDC_INSTALL_DIR="${XDC_INSTALL_DIR}" \ | ||
63 | BIOS_INSTALL_DIR="${SYSBIOS_INSTALL_DIR}" \ | ||
64 | ${IPC_TARGETS} \ | ||
65 | " | ||
diff --git a/recipes-ti/ipc/ti-ipc-rtos_git.bb b/recipes-ti/ipc/ti-ipc-rtos_git.bb index 5b0bed59..693a4e9c 100644 --- a/recipes-ti/ipc/ti-ipc-rtos_git.bb +++ b/recipes-ti/ipc/ti-ipc-rtos_git.bb | |||
@@ -1,50 +1,8 @@ | |||
1 | require recipes-ti/includes/ti-paths.inc | ||
2 | require recipes-ti/includes/ti-staging.inc | ||
3 | require ti-ipc.inc | 1 | require ti-ipc.inc |
4 | 2 | require ti-ipc-common.inc | |
5 | TI_IPC_EXAMPLES_GIT_URI = "git://git.ti.com/ipc/ipc-examples.git" | 3 | require ti-ipc-rtos.inc |
6 | TI_IPC_EXAMPLES_DEST_SUFFIX = "git/ipc-examples" | ||
7 | TI_IPC_EXAMPLES_GIT_PROTOCOL = "git" | ||
8 | TI_IPC_EXAMPLES_GIT_BRANCH = "master" | ||
9 | TI_IPC_EXAMPLES_NAME = "ipc-examples" | ||
10 | |||
11 | SRC_URI += "${TI_IPC_EXAMPLES_GIT_URI};\ | ||
12 | destsuffix=${TI_IPC_EXAMPLES_DEST_SUFFIX};\ | ||
13 | protocol=${TI_IPC_EXAMPLES_GIT_PROTOCOL};\ | ||
14 | branch=${TI_IPC_EXAMPLES_GIT_BRANCH};\ | ||
15 | name=${TI_IPC_EXAMPLES_NAME}" | ||
16 | |||
17 | TI_IPC_METADATA_GIT_URI = "git://git.ti.com/ipc/ipc-metadata.git" | ||
18 | TI_IPC_METADATA_DEST_SUFFIX = "git/ipc-metadata" | ||
19 | TI_IPC_METADATA_GIT_PROTOCOL = "git" | ||
20 | TI_IPC_METADATA_GIT_BRANCH = "master" | ||
21 | TI_IPC_METADATA_NAME = "ipc-metadata" | ||
22 | |||
23 | SRC_URI += "${TI_IPC_METADATA_GIT_URI};\ | ||
24 | destsuffix=${TI_IPC_METADATA_DEST_SUFFIX};\ | ||
25 | protocol=${TI_IPC_METADATA_GIT_PROTOCOL};\ | ||
26 | branch=${TI_IPC_METADATA_GIT_BRANCH};\ | ||
27 | name=${TI_IPC_METADATA_NAME}" | ||
28 | |||
29 | # Corresponds to tag: 3.44.00.00 | ||
30 | SRCREV_ipc-examples = "a934d057647af00401e4bfd1c6a4a0f6144441b7" | ||
31 | |||
32 | # Corresponds to tag: 3.44.00.00 | ||
33 | SRCREV_ipc-metadata = "07a745d47ecd7b4b64860e7c5d0fbe4e89524f2e" | ||
34 | |||
35 | S_ipc-examples = "${WORKDIR}/git/ipc-examples" | ||
36 | S_ipc-metadata = "${WORKDIR}/git/ipc-metadata" | ||
37 | |||
38 | PR = "${INC_PR}.3" | ||
39 | 4 | ||
40 | DEPENDS = "ti-xdctools ti-sysbios doxygen-native zip-native" | 5 | DEPENDS = "ti-xdctools ti-sysbios doxygen-native zip-native" |
41 | DEPENDS_append_keystone = " ti-cgt6x-native \ | ||
42 | gcc-arm-none-eabi-native \ | ||
43 | " | ||
44 | DEPENDS_append_omap-a15 = " ti-cgt6x-native \ | ||
45 | ti-ccsv6-native \ | ||
46 | gcc-arm-none-eabi-native \ | ||
47 | " | ||
48 | 6 | ||
49 | PACKAGES =+ "${PN}-fw" | 7 | PACKAGES =+ "${PN}-fw" |
50 | FILES_${PN}-fw = "${base_libdir}/firmware/*" | 8 | FILES_${PN}-fw = "${base_libdir}/firmware/*" |
@@ -55,27 +13,6 @@ INSANE_SKIP_${PN}-dev += "arch" | |||
55 | 13 | ||
56 | ALLOW_EMPTY_${PN} = "1" | 14 | ALLOW_EMPTY_${PN} = "1" |
57 | 15 | ||
58 | IPC_TARGETS = "" | ||
59 | IPC_TARGETS_omap-a15 = "\ | ||
60 | gnu.targets.arm.A15F="${GCC_ARM_NONE_TOOLCHAIN}" \ | ||
61 | ti.targets.elf.C66="${STAGING_DIR_NATIVE}/usr/share/ti/cgt-c6x" \ | ||
62 | ti.targets.elf.C66_big_endian="${STAGING_DIR_NATIVE}/usr/share/ti/cgt-c6x" \ | ||
63 | ti.targets.arm.elf.M4="${M4_TOOLCHAIN_INSTALL_DIR}" \ | ||
64 | " | ||
65 | |||
66 | IPC_TARGETS_keystone = " \ | ||
67 | gnu.targets.arm.A15F="${GCC_ARM_NONE_TOOLCHAIN}" \ | ||
68 | ti.targets.elf.C66="${STAGING_DIR_NATIVE}/usr/share/ti/cgt-c6x" \ | ||
69 | ti.targets.elf.C66_big_endian="${STAGING_DIR_NATIVE}/usr/share/ti/cgt-c6x" \ | ||
70 | " | ||
71 | |||
72 | EXTRA_OEMAKE = "\ | ||
73 | PLATFORM=${PLATFORM} \ | ||
74 | XDC_INSTALL_DIR="${XDC_INSTALL_DIR}" \ | ||
75 | BIOS_INSTALL_DIR="${SYSBIOS_INSTALL_DIR}" \ | ||
76 | ${IPC_TARGETS} \ | ||
77 | " | ||
78 | |||
79 | RELEASE_TYPE = "GA" | 16 | RELEASE_TYPE = "GA" |
80 | RELEASE_SUFFIX = "" | 17 | RELEASE_SUFFIX = "" |
81 | 18 | ||
@@ -93,6 +30,11 @@ do_compile() { | |||
93 | cd ${S_ipc-examples}/src | 30 | cd ${S_ipc-examples}/src |
94 | oe_runmake .examples \ | 31 | oe_runmake .examples \ |
95 | IPCTOOLS="${S_ipc-metadata}/src/etc" | 32 | IPCTOOLS="${S_ipc-metadata}/src/etc" |
33 | if [ ! -z ${ALT_PLATFORM} ]; then | ||
34 | oe_runmake .examples \ | ||
35 | IPCTOOLS="${S_ipc-metadata}/src/etc" \ | ||
36 | PLATFORM=${ALT_PLATFORM} | ||
37 | fi | ||
96 | 38 | ||
97 | if [ "${PLATFORM}" != "UNKNOWN" ]; then | 39 | if [ "${PLATFORM}" != "UNKNOWN" ]; then |
98 | oe_runmake extract HOSTOS="bios" IPC_INSTALL_DIR="${S}" | 40 | oe_runmake extract HOSTOS="bios" IPC_INSTALL_DIR="${S}" |
diff --git a/recipes-ti/ipc/ti-ipc.inc b/recipes-ti/ipc/ti-ipc.inc index 488e0fca..2d383674 100644 --- a/recipes-ti/ipc/ti-ipc.inc +++ b/recipes-ti/ipc/ti-ipc.inc | |||
@@ -6,7 +6,7 @@ LIC_FILES_CHKSUM = "file://${S}/ipc-linux.mak;beginline=1;endline=30;md5=7b327f9 | |||
6 | 6 | ||
7 | TI_IPC_GIT_URI = "git://git.ti.com/ipc/ipcdev.git" | 7 | TI_IPC_GIT_URI = "git://git.ti.com/ipc/ipcdev.git" |
8 | TI_IPC_GIT_PROTOCOL = "git" | 8 | TI_IPC_GIT_PROTOCOL = "git" |
9 | TI_IPC_GIT_BRANCH = "ipc-next" | 9 | TI_IPC_GIT_BRANCH = "3.44" |
10 | 10 | ||
11 | #Corresponds to 3.44.00.00 | 11 | #Corresponds to 3.44.00.00 |
12 | TI_IPC_SRCREV = "a1852fc8b254ed207bd1c1c88f5b362c9b6cc454" | 12 | TI_IPC_SRCREV = "a1852fc8b254ed207bd1c1c88f5b362c9b6cc454" |
@@ -16,17 +16,3 @@ SRC_URI = "${TI_IPC_GIT_URI};protocol=${TI_IPC_GIT_PROTOCOL};branch=${BRANCH};na | |||
16 | SRCREV = "${TI_IPC_SRCREV}" | 16 | SRCREV = "${TI_IPC_SRCREV}" |
17 | 17 | ||
18 | S = "${WORKDIR}/git" | 18 | S = "${WORKDIR}/git" |
19 | PV = "3.44.00.00" | ||
20 | INC_PR = "r1" | ||
21 | |||
22 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||
23 | |||
24 | PLATFORM = "UNKNOWN" | ||
25 | PLATFORM_omap5-evm = "OMAP54XX" | ||
26 | PLATFORM_dra7xx = "DRA7XX" | ||
27 | PLATFORM_k2hk-evm = "TCI6638" | ||
28 | PLATFORM_k2l-evm = "TCI6630" | ||
29 | PLATFORM_k2e = "66AK2E" | ||
30 | PLATFORM_k2g = "66AK2G" | ||
31 | |||
32 | ALT_PLATFORM_k2hk-evm = "TCI6636" | ||
diff --git a/recipes-ti/ipc/ti-ipc_git.bb b/recipes-ti/ipc/ti-ipc_git.bb index cd844b43..6ccd2c48 100644 --- a/recipes-ti/ipc/ti-ipc_git.bb +++ b/recipes-ti/ipc/ti-ipc_git.bb | |||
@@ -2,6 +2,7 @@ DESCRIPTION = "TI Inter Process Communication (IPC) Mechanisms (for Uni- and Mul | |||
2 | HOMEPAGE="http://processors.wiki.ti.com/index.php/Category:IPC" | 2 | HOMEPAGE="http://processors.wiki.ti.com/index.php/Category:IPC" |
3 | 3 | ||
4 | require ti-ipc.inc | 4 | require ti-ipc.inc |
5 | require ti-ipc-common.inc | ||
5 | 6 | ||
6 | PR = "${INC_PR}.0" | 7 | PR = "${INC_PR}.0" |
7 | 8 | ||