summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJacob Stiffler <j-stiffler@ti.com>2016-12-21 02:39:14 +0000
committerDenys Dmytriyenko <denys@ti.com>2016-12-20 16:32:00 -0500
commit10c1d75c9d5b5b448e312e2b4bae632b97ba6e52 (patch)
tree5c21277e9fd1783d4643593733f0c2c3705d7e14
parent6bea060cdd5d7b6c0dc4857bb22064b841e8a696 (diff)
downloadmeta-ti-10c1d75c9d5b5b448e312e2b4bae632b97ba6e52.tar.gz
pruss-lld: utilize oe_runmake
* Use the oe_runmake wrapper to invoke make * Supply common make arguments to EXTRA_OEMAKE such as which makefile to invoke. * This resolves build issues when pruss-lld needs to be reconfigured as do_configure would make the clean target of the incorrect makefile. Signed-off-by: Jacob Stiffler <j-stiffler@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r--recipes-bsp/pruss-lld/pruss-lld-test_git.bb8
-rw-r--r--recipes-bsp/pruss-lld/pruss-lld_git.bb10
2 files changed, 11 insertions, 7 deletions
diff --git a/recipes-bsp/pruss-lld/pruss-lld-test_git.bb b/recipes-bsp/pruss-lld/pruss-lld-test_git.bb
index d994ec8f..7fdbfb6f 100644
--- a/recipes-bsp/pruss-lld/pruss-lld-test_git.bb
+++ b/recipes-bsp/pruss-lld/pruss-lld-test_git.bb
@@ -4,16 +4,18 @@ DEPENDS="common-csl-ip pruss-lld osal"
4 4
5include pruss-lld.inc 5include pruss-lld.inc
6 6
7PR = "${INC_PR}.0" 7PR = "${INC_PR}.1"
8 8
9S = "${WORKDIR}/${PRUSS_LLD_GIT_DESTSUFFIX}" 9S = "${WORKDIR}/${PRUSS_LLD_GIT_DESTSUFFIX}"
10 10
11EXTRA_OEMAKE += "-f makefile_armv7 PDK_INSTALL_PATH=${STAGING_INCDIR} PRUSS_SRC_DIR=${S}"
12
11do_compile () { 13do_compile () {
12# Build the tests 14# Build the tests
13 make -f makefile_armv7 tests PDK_INSTALL_PATH=${STAGING_INCDIR} PRUSS_SRC_DIR=${S} 15 oe_runmake tests
14} 16}
15 17
16do_install () { 18do_install () {
17# Install the binary 19# Install the binary
18 make -f makefile_armv7 installbin PDK_INSTALL_PATH=${STAGING_INCDIR} INSTALL_BIN_BASE_DIR=${D}${bindir} PRUSS_SRC_DIR=${S} 20 oe_runmake installbin INSTALL_BIN_BASE_DIR=${D}${bindir}
19} 21}
diff --git a/recipes-bsp/pruss-lld/pruss-lld_git.bb b/recipes-bsp/pruss-lld/pruss-lld_git.bb
index 72670f44..2eca4ffa 100644
--- a/recipes-bsp/pruss-lld/pruss-lld_git.bb
+++ b/recipes-bsp/pruss-lld/pruss-lld_git.bb
@@ -4,17 +4,19 @@ DEPENDS="common-csl-ip osal"
4 4
5include pruss-lld.inc 5include pruss-lld.inc
6 6
7PR = "${INC_PR}.1" 7PR = "${INC_PR}.2"
8 8
9S = "${WORKDIR}/${PRUSS_LLD_GIT_DESTSUFFIX}" 9S = "${WORKDIR}/${PRUSS_LLD_GIT_DESTSUFFIX}"
10 10
11EXTRA_OEMAKE += "-f makefile_armv7 PDK_INSTALL_PATH=${STAGING_INCDIR}"
12
11do_compile () { 13do_compile () {
12# Build the lib 14# Build the lib
13 make -f makefile_armv7 clean PDK_INSTALL_PATH=${STAGING_INCDIR} 15 oe_runmake clean
14 make -f makefile_armv7 lib PDK_INSTALL_PATH=${STAGING_INCDIR} 16 oe_runmake lib
15} 17}
16 18
17do_install () { 19do_install () {
18# Install the lib 20# Install the lib
19 make -f makefile_armv7 install PDK_INSTALL_PATH=${STAGING_INCDIR} INSTALL_INC_BASE_DIR=${D}${includedir} INSTALL_LIB_BASE_DIR=${D}${libdir} 21 oe_runmake install INSTALL_INC_BASE_DIR=${D}${includedir} INSTALL_LIB_BASE_DIR=${D}${libdir}
20} 22}