summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2016-09-19 22:59:29 +0000
committerDenys Dmytriyenko <denys@ti.com>2016-09-19 18:59:10 -0400
commite54d33089ade90354424f0c2f923ea040a656a94 (patch)
treea27bfb87c0ad896eb6b9d170b5b85bac3cd80889
parent3a20d0540c72ea92a151f3ab6edb816fb42ec578 (diff)
downloadmeta-ti-e54d33089ade90354424f0c2f923ea040a656a94.tar.gz
conf/machine, u-boot-ti-staging: add am335x-hs-evm platform
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r--conf/machine/am335x-hs-evm.conf14
-rw-r--r--recipes-bsp/u-boot/u-boot-ti-staging_2016.05.bb7
2 files changed, 21 insertions, 0 deletions
diff --git a/conf/machine/am335x-hs-evm.conf b/conf/machine/am335x-hs-evm.conf
new file mode 100644
index 00000000..674a764c
--- /dev/null
+++ b/conf/machine/am335x-hs-evm.conf
@@ -0,0 +1,14 @@
1#@TYPE: Machine
2#@NAME: AM335x HS EVM
3#@DESCRIPTION: Machine configuration for the TI AM435x HS EVM
4
5require conf/machine/am335x-evm.conf
6
7UBOOT_MACHINE = "am335x_hs_evm_mmc_config"
8
9UBOOT_ENTRYPOINT = "0x82000000"
10UBOOT_LOADADDRESS = "0x82000000"
11UBOOT_RD_LOADADDRESS = "0x84000000"
12UBOOT_RD_ENTRYPOINT = "0x84000000"
13
14TI_SECURE_DEV_PKG = "${TI_SECURE_DEV_PKG_CAT}/am3x"
diff --git a/recipes-bsp/u-boot/u-boot-ti-staging_2016.05.bb b/recipes-bsp/u-boot/u-boot-ti-staging_2016.05.bb
index 868109b6..c3b55ac6 100644
--- a/recipes-bsp/u-boot/u-boot-ti-staging_2016.05.bb
+++ b/recipes-bsp/u-boot/u-boot-ti-staging_2016.05.bb
@@ -53,6 +53,13 @@ do_compile_append_am437x-hs-evm () {
53 fi 53 fi
54} 54}
55 55
56do_compile_append_am335x-hs-evm () {
57 if [ -f ${S}/u-boot-spl_HS_ISSW ]; then
58 rm -rf ${S}/MLO
59 cp ${S}/u-boot-spl_HS_ISSW ${S}/MLO
60 fi
61}
62
56do_install_append () { 63do_install_append () {
57 if [ -f ${S}/${UBOOT_HS_XLD_BINARY} ]; then 64 if [ -f ${S}/${UBOOT_HS_XLD_BINARY} ]; then
58 install ${S}/${UBOOT_HS_XLD_BINARY} ${D}/boot/${UBOOT_HS_XLD_IMAGE} 65 install ${S}/${UBOOT_HS_XLD_BINARY} ${D}/boot/${UBOOT_HS_XLD_IMAGE}