summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2016-09-19 22:59:25 +0000
committerDenys Dmytriyenko <denys@ti.com>2016-09-19 18:58:56 -0400
commitb41d8550d4dcdcbe51be9d343981cba8ef06445a (patch)
treec0ef11eb4a0fe8de0aeff25dc469af75ff645a6e
parentd1578d2766e62f65949c0f0c4ba9b2f5b3b95b2c (diff)
downloadmeta-ti-b41d8550d4dcdcbe51be9d343981cba8ef06445a.tar.gz
u-boot-ti-staging: remove old versions
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r--recipes-bsp/u-boot/u-boot-ti-staging_2014.07.bb20
-rw-r--r--recipes-bsp/u-boot/u-boot-ti-staging_2015.07.bb78
2 files changed, 0 insertions, 98 deletions
diff --git a/recipes-bsp/u-boot/u-boot-ti-staging_2014.07.bb b/recipes-bsp/u-boot/u-boot-ti-staging_2014.07.bb
deleted file mode 100644
index 9d7dd068..00000000
--- a/recipes-bsp/u-boot/u-boot-ti-staging_2014.07.bb
+++ /dev/null
@@ -1,20 +0,0 @@
1require u-boot-ti.inc
2
3# u-boot needs devtree compiler to parse dts files
4DEPENDS += "dtc-native"
5
6DESCRIPTION = "u-boot bootloader for TI devices"
7
8LIC_FILES_CHKSUM = "file://Licenses/README;md5=025bf9f768cbcb1a165dbe1a110babfb"
9
10PR = "r14"
11PV_append = "+git${SRCPV}"
12
13SRC_URI = "git://git.ti.com/ti-u-boot/ti-u-boot.git;protocol=git;branch=${BRANCH}"
14
15BRANCH ?= "ti-u-boot-2014.07"
16
17SRCREV = "fb6ab76dad21e12b12d0f824fcfa2609a26ec695"
18
19SPL_BINARY = "MLO"
20SPL_UART_BINARY = "u-boot-spl.bin"
diff --git a/recipes-bsp/u-boot/u-boot-ti-staging_2015.07.bb b/recipes-bsp/u-boot/u-boot-ti-staging_2015.07.bb
deleted file mode 100644
index 0634a16f..00000000
--- a/recipes-bsp/u-boot/u-boot-ti-staging_2015.07.bb
+++ /dev/null
@@ -1,78 +0,0 @@
1require u-boot-ti.inc
2
3# u-boot needs devtree compiler to parse dts files
4DEPENDS += "dtc-native"
5
6DESCRIPTION = "u-boot bootloader for TI devices"
7
8LIC_FILES_CHKSUM = "file://Licenses/README;md5=0507cd7da8e7ad6d6701926ec9b84c95"
9
10PR = "r25"
11PV_append = "+git${SRCPV}"
12
13SRC_URI = "git://git.ti.com/ti-u-boot/ti-u-boot.git;protocol=git;branch=${BRANCH}"
14
15BRANCH ?= "ti-u-boot-2015.07"
16
17SRCREV = "46c915c96358c426bb1f4dd1e25a9a805d93a24e"
18
19# Support for secure devices - detailed info is in doc/README.ti-secure
20TI_SECURE_DEV_PKG ?= ""
21TI_SECURE_DEV_PKG_dra7xx-hs-evm = "${TI_SECURE_DEV_PKG_DRA7}"
22TI_SECURE_DEV_PKG_am437x-hs-evm = "${TI_SECURE_DEV_PKG_AM4}"
23export TI_SECURE_DEV_PKG
24
25SPL_BINARY = "MLO"
26SPL_UART_BINARY = "u-boot-spl.bin"
27
28# Keystone specifics
29UBOOT_SUFFIX_keystone = "bin"
30SPL_UART_BINARY_keystone = ""
31
32# SPI NOR Flash binaries
33UBOOT_SPI_SPL_BINARY = "u-boot-spl.bin"
34UBOOT_SPI_BINARY = "u-boot.img"
35UBOOT_SPI_GPH_BINARY = "u-boot-spi.gph"
36
37# SPI NOR Flash deployed images
38UBOOT_SPI_SPL_IMAGE = "u-boot-spl-${MACHINE}-${PV}-${PR}.bin"
39UBOOT_SPI_SPL_SYMLINK = "u-boot-spl-${MACHINE}.bin"
40UBOOT_SPI_IMAGE = "u-boot-${MACHINE}-${PV}-${PR}.img"
41UBOOT_SPI_SYMLINK = "u-boot-${MACHINE}.img"
42UBOOT_SPI_GPH_IMAGE = "u-boot-spi-${MACHINE}-${PV}-${PR}.gph"
43UBOOT_SPI_GPH_SYMLINK = "u-boot-spi-${MACHINE}.gph"
44
45do_compile_append_am437x-hs-evm () {
46 if [ -f ${S}/u-boot-spl_HS_ISSW ]; then
47 rm -rf ${S}/MLO
48 cp ${S}/u-boot-spl_HS_ISSW ${S}/MLO
49 fi
50}
51
52do_install_append_keystone () {
53 install ${S}/spl/${UBOOT_SPI_SPL_BINARY} ${D}/boot/${UBOOT_SPI_SPL_IMAGE}
54 ln -sf ${UBOOT_SPI_SPL_IMAGE} ${D}/boot/${UBOOT_SPI_SPL_BINARY}
55
56 install ${S}/${UBOOT_SPI_BINARY} ${D}/boot/${UBOOT_SPI_IMAGE}
57 ln -sf ${UBOOT_SPI_IMAGE} ${D}/boot/${UBOOT_SPI_BINARY}
58
59 install ${S}/${UBOOT_SPI_GPH_BINARY} ${D}/boot/${UBOOT_SPI_GPH_IMAGE}
60 ln -sf ${UBOOT_SPI_GPH_IMAGE} ${D}/boot/${UBOOT_SPI_GPH_BINARY}
61}
62
63do_deploy_append_keystone () {
64 install ${S}/spl/${UBOOT_SPI_SPL_BINARY} ${DEPLOYDIR}/${UBOOT_SPI_SPL_IMAGE}
65 rm -f ${UBOOT_SPI_SPL_BINARY} ${UBOOT_SPI_SPL_SYMLINK}
66 ln -sf ${UBOOT_SPI_SPL_IMAGE} ${UBOOT_SPI_SPL_SYMLINK}
67 ln -sf ${UBOOT_SPI_SPL_IMAGE} ${UBOOT_SPI_SPL_BINARY}
68
69 install ${S}/${UBOOT_SPI_BINARY} ${DEPLOYDIR}/${UBOOT_SPI_IMAGE}
70 rm -f ${UBOOT_SPI_BINARY} ${UBOOT_SPI_SYMLINK}
71 ln -sf ${UBOOT_SPI_IMAGE} ${UBOOT_SPI_SYMLINK}
72 ln -sf ${UBOOT_SPI_IMAGE} ${UBOOT_SPI_BINARY}
73
74 install ${S}/${UBOOT_SPI_GPH_BINARY} ${DEPLOYDIR}/${UBOOT_SPI_GPH_IMAGE}
75 rm -f ${UBOOT_SPI_GPH_BINARY} ${UBOOT_SPI_GPH_SYMLINK}
76 ln -sf ${UBOOT_SPI_GPH_IMAGE} ${UBOOT_SPI_GPH_SYMLINK}
77 ln -sf ${UBOOT_SPI_GPH_IMAGE} ${UBOOT_SPI_GPH_BINARY}
78}