summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2016-08-16 08:05:13 +0000
committerDenys Dmytriyenko <denys@ti.com>2016-08-16 16:25:43 -0400
commit6ec5e0dab202accc4b313bbf7923c220ff62b43e (patch)
treeaae99d594ceeeb56c7c31ed92d834befe2305687
parent3c9ebcb91ee476c82c0fedc0f21f97620f937e4e (diff)
downloadmeta-ti-6ec5e0dab202accc4b313bbf7923c220ff62b43e.tar.gz
machines: move TI_SECURE_DEV_PKG and add UBOOT_* vars for fitimage support
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r--conf/machine/am437x-hs-evm.conf7
-rw-r--r--conf/machine/am57xx-hs-evm.conf7
-rw-r--r--conf/machine/dra7xx-hs-evm.conf7
-rw-r--r--recipes-bsp/u-boot/u-boot-ti-staging_2016.05.bb3
4 files changed, 21 insertions, 3 deletions
diff --git a/conf/machine/am437x-hs-evm.conf b/conf/machine/am437x-hs-evm.conf
index e8d88a41..4fb277df 100644
--- a/conf/machine/am437x-hs-evm.conf
+++ b/conf/machine/am437x-hs-evm.conf
@@ -5,3 +5,10 @@
5require conf/machine/am437x-evm.conf 5require conf/machine/am437x-evm.conf
6 6
7UBOOT_MACHINE = "am43xx_hs_evm_config" 7UBOOT_MACHINE = "am43xx_hs_evm_config"
8
9UBOOT_ENTRYPOINT = "0x82000000"
10UBOOT_LOADADDRESS = "0x82000000"
11UBOOT_RD_LOADADDRESS = "0x84000000"
12UBOOT_RD_ENTRYPOINT = "0x84000000"
13
14TI_SECURE_DEV_PKG = "${TI_SECURE_DEV_PKG_AM4}"
diff --git a/conf/machine/am57xx-hs-evm.conf b/conf/machine/am57xx-hs-evm.conf
index a3750176..bd5a1450 100644
--- a/conf/machine/am57xx-hs-evm.conf
+++ b/conf/machine/am57xx-hs-evm.conf
@@ -5,3 +5,10 @@
5require conf/machine/am57xx-evm.conf 5require conf/machine/am57xx-evm.conf
6 6
7UBOOT_MACHINE = "am57xx_hs_evm_config" 7UBOOT_MACHINE = "am57xx_hs_evm_config"
8
9UBOOT_ENTRYPOINT = "0x82000000"
10UBOOT_LOADADDRESS = "0x82000000"
11UBOOT_RD_LOADADDRESS = "0x84000000"
12UBOOT_RD_ENTRYPOINT = "0x84000000"
13
14TI_SECURE_DEV_PKG = "${TI_SECURE_DEV_PKG_DRA7}"
diff --git a/conf/machine/dra7xx-hs-evm.conf b/conf/machine/dra7xx-hs-evm.conf
index a8987165..537152b2 100644
--- a/conf/machine/dra7xx-hs-evm.conf
+++ b/conf/machine/dra7xx-hs-evm.conf
@@ -5,3 +5,10 @@
5require conf/machine/dra7xx-evm.conf 5require conf/machine/dra7xx-evm.conf
6 6
7UBOOT_MACHINE = "dra7xx_hs_evm_config" 7UBOOT_MACHINE = "dra7xx_hs_evm_config"
8
9UBOOT_ENTRYPOINT = "0x82000000"
10UBOOT_LOADADDRESS = "0x82000000"
11UBOOT_RD_LOADADDRESS = "0x84000000"
12UBOOT_RD_ENTRYPOINT = "0x84000000"
13
14TI_SECURE_DEV_PKG = "${TI_SECURE_DEV_PKG_DRA7}"
diff --git a/recipes-bsp/u-boot/u-boot-ti-staging_2016.05.bb b/recipes-bsp/u-boot/u-boot-ti-staging_2016.05.bb
index 699c221e..c5a374a8 100644
--- a/recipes-bsp/u-boot/u-boot-ti-staging_2016.05.bb
+++ b/recipes-bsp/u-boot/u-boot-ti-staging_2016.05.bb
@@ -18,9 +18,6 @@ SRCREV = "052f3bfd39e212e43fd141a49331107409e4f993"
18 18
19# Support for secure devices - detailed info is in doc/README.ti-secure 19# Support for secure devices - detailed info is in doc/README.ti-secure
20TI_SECURE_DEV_PKG ?= "" 20TI_SECURE_DEV_PKG ?= ""
21TI_SECURE_DEV_PKG_dra7xx-hs-evm = "${TI_SECURE_DEV_PKG_DRA7}"
22TI_SECURE_DEV_PKG_am57xx-hs-evm = "${TI_SECURE_DEV_PKG_DRA7}"
23TI_SECURE_DEV_PKG_am437x-hs-evm = "${TI_SECURE_DEV_PKG_AM4}"
24export TI_SECURE_DEV_PKG 21export TI_SECURE_DEV_PKG
25 22
26SPL_BINARY = "MLO" 23SPL_BINARY = "MLO"