summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGowtham Tammana <g-tammana@ti.com>2016-08-23 00:14:58 +0000
committerDenys Dmytriyenko <denys@ti.com>2016-08-23 14:40:03 -0400
commitec487fccaa028c31583b6c51f5fdc317707b0225 (patch)
tree7516768625ee390689b591096ff2ea574f3f16d2
parentf844646b01b97a47308b2c72db788b8d23c16bb2 (diff)
downloadmeta-ti-ec487fccaa028c31583b6c51f5fdc317707b0225.tar.gz
ti-gc320-driver: recipe for gc320 kernel mode driver
Kernel drivers for the Vivante GC320 chipset found in TI SoCs Signed-off-by: Gowtham Tammana <g-tammana@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r--recipes-bsp/gc320-drivers/ti-gc320-driver_5.0.11.p7.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes-bsp/gc320-drivers/ti-gc320-driver_5.0.11.p7.bb b/recipes-bsp/gc320-drivers/ti-gc320-driver_5.0.11.p7.bb
new file mode 100644
index 00000000..9344e30b
--- /dev/null
+++ b/recipes-bsp/gc320-drivers/ti-gc320-driver_5.0.11.p7.bb
@@ -0,0 +1,24 @@
1DESCRIPTION = "Kernel drivers for the Vivante GC320 chipset found in TI SoCs"
2HOMEPAGE = "https://git.ti.com/graphics/ti-gc320-driver"
3LICENSE = "MIT | GPLv2"
4LIC_FILES_CHKSUM = "file://../LICENSE;md5=78d9818a51b9a8e9bb89dea418bac297"
5
6inherit module
7
8MACHINE_KERNEL_PR_append = "a"
9PR = "${MACHINE_KERNEL_PR}"
10
11# Need to branch out with ${PV} var
12BRANCH = "ti-${PV}-k4.4"
13
14SRCREV = "7a2b06ad1df46a274336f7ae0e24a9d67e72cd66"
15
16SRC_URI = "git://git.ti.com/graphics/ti-gc320-driver.git;protocol=git;branch=${BRANCH}"
17S = "${WORKDIR}/git/src"
18
19EXTRA_OEMAKE += "-f Kbuild AQROOT=${S} KERNEL_DIR=${STAGING_KERNEL_DIR} TOOLCHAIN_PATH=${TOOLCHAIN_PATH} CROSS_COMPILE=${TARGET_PREFIX} ARCH_TYPE=${TARGET_ARCH}"
20
21do_install() {
22 install -d ${D}/${base_libdir}/modules/${KERNEL_VERSION}/extra
23 install -m 644 ${S}/galcore.ko ${D}/${base_libdir}/modules/${KERNEL_VERSION}/extra
24}