summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2016-04-28 20:14:09 +0000
committerDenys Dmytriyenko <denys@ti.com>2016-04-28 15:00:18 -0400
commit398fb120076ab5b3afc9978f80f18dfc2f459331 (patch)
tree6fa656c3dec12c8d91c2a56bb2d91fb9123c1ebc
parenta7e4b9560aaa9476e86e507132cc8705a4026db6 (diff)
downloadmeta-ti-398fb120076ab5b3afc9978f80f18dfc2f459331.tar.gz
u-boot: remove outdated versions
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r--recipes-bsp/u-boot/u-boot-am33x_2013.01.01.bb20
-rw-r--r--recipes-bsp/u-boot/u-boot-glsdk_2013.01.01.bb17
-rw-r--r--recipes-bsp/u-boot/u-boot-keystone_2013.01.bb71
-rw-r--r--recipes-bsp/u-boot/u-boot-ti-staging_2013.01.01.bb16
-rw-r--r--recipes-bsp/u-boot/u-boot-ti-staging_2013.10.bb18
-rw-r--r--recipes-bsp/u-boot/u-boot_2014.07.bb25
6 files changed, 0 insertions, 167 deletions
diff --git a/recipes-bsp/u-boot/u-boot-am33x_2013.01.01.bb b/recipes-bsp/u-boot/u-boot-am33x_2013.01.01.bb
deleted file mode 100644
index 8f805bc8..00000000
--- a/recipes-bsp/u-boot/u-boot-am33x_2013.01.01.bb
+++ /dev/null
@@ -1,20 +0,0 @@
1require u-boot-ti.inc
2
3DESCRIPTION = "u-boot bootloader for ARM MPU devices"
4
5COMPATIBLE_MACHINE = "ti33x"
6
7DEFAULT_PREFERENCE = "-1"
8
9PR = "r6"
10PV_append = "+git${SRCPV}"
11
12SRC_URI = "git://git.ti.com/ti-u-boot/ti-u-boot.git;protocol=git;branch=${BRANCH}"
13
14# This version of u-boot is meant for 3.2 kernel which doesn't support device tree.
15BRANCH = "ti-u-boot-2013.01.01-amsdk-06.00.00.00"
16
17SRCREV = "540aa6fbb0c9274bda598f7e8819ed28259cad6b"
18
19# Set the name of the SPL that will built so that it is also packaged with u-boot.
20SPL_BINARY = "MLO"
diff --git a/recipes-bsp/u-boot/u-boot-glsdk_2013.01.01.bb b/recipes-bsp/u-boot/u-boot-glsdk_2013.01.01.bb
deleted file mode 100644
index 3a22864a..00000000
--- a/recipes-bsp/u-boot/u-boot-glsdk_2013.01.01.bb
+++ /dev/null
@@ -1,17 +0,0 @@
1require u-boot-ti.inc
2
3DESCRIPTION = "u-boot bootloader for TI devices supported by the GLSDK product"
4
5PR = "r1"
6PV_append = "+git${SRCPV}"
7
8DEFAULT_PREFERENCE = "-1"
9
10SRC_URI = "git://git.omapzoom.org/repo/u-boot.git;protocol=git;branch=${BRANCH}"
11
12BRANCH ?= "p-ti-u-boot-2013.04"
13
14SRCREV = "76447484441a4b8e00840a2bde74e66dbac9e631"
15
16SPL_BINARY = "MLO"
17SPL_UART_BINARY = "u-boot-spl.bin"
diff --git a/recipes-bsp/u-boot/u-boot-keystone_2013.01.bb b/recipes-bsp/u-boot/u-boot-keystone_2013.01.bb
deleted file mode 100644
index e4387fc8..00000000
--- a/recipes-bsp/u-boot/u-boot-keystone_2013.01.bb
+++ /dev/null
@@ -1,71 +0,0 @@
1require u-boot-ti.inc
2
3DESCRIPTION = "u-boot bootloader for Multi-Core BU devices"
4
5COMPATIBLE_MACHINE = "keystone"
6
7PR = "r6"
8PV_append = "+git${SRCPV}"
9
10# Tag "K2_UBOOT_2013_01_15.07_01"
11SRCREV = "5eaedcc4c2bca0ed971ee46694df7edc0cfa36cf"
12BRANCH = "master"
13
14SRC_URI = "git://git.ti.com/keystone-linux/u-boot.git;protocol=git;branch=${BRANCH}"
15
16S = "${WORKDIR}/git"
17
18UBOOT_SUFFIX = "bin"
19UBOOT_MAKE_TARGET = "u-boot-spi.gph u-boot-nand.gph"
20
21# SPI NOR Flash binaries
22UBOOT_SPI_SPL_BINARY = "u-boot-spl.bin"
23UBOOT_SPI_BINARY = "u-boot.img"
24UBOOT_SPI_GPH_BINARY = "u-boot-spi.gph"
25UBOOT_NAND_GPH_BINARY = "u-boot-nand.gph"
26
27# SPI NOR Flash deployed images
28UBOOT_SPI_SPL_IMAGE = "u-boot-spl-${MACHINE}-${PV}-${PR}.bin"
29UBOOT_SPI_SPL_SYMLINK = "u-boot-spl-${MACHINE}.bin"
30UBOOT_SPI_IMAGE = "u-boot-${MACHINE}-${PV}-${PR}.img"
31UBOOT_SPI_SYMLINK = "u-boot-${MACHINE}.img"
32UBOOT_SPI_GPH_IMAGE = "u-boot-spi-${MACHINE}-${PV}-${PR}.gph"
33UBOOT_SPI_GPH_SYMLINK = "u-boot-spi-${MACHINE}.gph"
34UBOOT_NAND_GPH_IMAGE = "u-boot-nand-${MACHINE}-${PV}-${PR}.gph"
35UBOOT_NAND_GPH_SYMLINK = "u-boot-nand-${MACHINE}.gph"
36
37do_install_append () {
38 install ${S}/spl/${UBOOT_SPI_SPL_BINARY} ${D}/boot/${UBOOT_SPI_SPL_IMAGE}
39 ln -sf ${UBOOT_SPI_SPL_IMAGE} ${D}/boot/${UBOOT_SPI_SPL_BINARY}
40
41 install ${S}/${UBOOT_SPI_BINARY} ${D}/boot/${UBOOT_SPI_IMAGE}
42 ln -sf ${UBOOT_SPI_IMAGE} ${D}/boot/${UBOOT_SPI_BINARY}
43
44 install ${S}/${UBOOT_SPI_GPH_BINARY} ${D}/boot/${UBOOT_SPI_GPH_IMAGE}
45 ln -sf ${UBOOT_SPI_GPH_IMAGE} ${D}/boot/${UBOOT_SPI_GPH_BINARY}
46
47 install ${S}/${UBOOT_NAND_GPH_BINARY} ${D}/boot/${UBOOT_NAND_GPH_IMAGE}
48 ln -sf ${UBOOT_NAND_GPH_IMAGE} ${D}/boot/${UBOOT_NAND_GPH_BINARY}
49}
50
51do_deploy_append () {
52 install ${S}/spl/${UBOOT_SPI_SPL_BINARY} ${DEPLOYDIR}/${UBOOT_SPI_SPL_IMAGE}
53 rm -f ${UBOOT_SPI_SPL_BINARY} ${UBOOT_SPI_SPL_SYMLINK}
54 ln -sf ${UBOOT_SPI_SPL_IMAGE} ${UBOOT_SPI_SPL_SYMLINK}
55 ln -sf ${UBOOT_SPI_SPL_IMAGE} ${UBOOT_SPI_SPL_BINARY}
56
57 install ${S}/${UBOOT_SPI_BINARY} ${DEPLOYDIR}/${UBOOT_SPI_IMAGE}
58 rm -f ${UBOOT_SPI_BINARY} ${UBOOT_SPI_SYMLINK}
59 ln -sf ${UBOOT_SPI_IMAGE} ${UBOOT_SPI_SYMLINK}
60 ln -sf ${UBOOT_SPI_IMAGE} ${UBOOT_SPI_BINARY}
61
62 install ${S}/${UBOOT_SPI_GPH_BINARY} ${DEPLOYDIR}/${UBOOT_SPI_GPH_IMAGE}
63 rm -f ${UBOOT_SPI_GPH_BINARY} ${UBOOT_SPI_GPH_SYMLINK}
64 ln -sf ${UBOOT_SPI_GPH_IMAGE} ${UBOOT_SPI_GPH_SYMLINK}
65 ln -sf ${UBOOT_SPI_GPH_IMAGE} ${UBOOT_SPI_GPH_BINARY}
66
67 install ${S}/${UBOOT_NAND_GPH_BINARY} ${DEPLOYDIR}/${UBOOT_NAND_GPH_IMAGE}
68 rm -f ${UBOOT_NAND_GPH_BINARY} ${UBOOT_NAND_GPH_SYMLINK}
69 ln -sf ${UBOOT_NAND_GPH_IMAGE} ${UBOOT_NAND_GPH_SYMLINK}
70 ln -sf ${UBOOT_NAND_GPH_IMAGE} ${UBOOT_NAND_GPH_BINARY}
71}
diff --git a/recipes-bsp/u-boot/u-boot-ti-staging_2013.01.01.bb b/recipes-bsp/u-boot/u-boot-ti-staging_2013.01.01.bb
deleted file mode 100644
index 821e9ed7..00000000
--- a/recipes-bsp/u-boot/u-boot-ti-staging_2013.01.01.bb
+++ /dev/null
@@ -1,16 +0,0 @@
1require u-boot-ti.inc
2
3DESCRIPTION = "u-boot bootloader for TI devices"
4
5PR = "r5"
6PV_append = "+git${SRCPV}"
7
8SRC_URI = "git://git.ti.com/ti-u-boot/ti-u-boot.git;protocol=git;branch=${BRANCH}"
9
10BRANCH ?= "ti-u-boot-2013.01.01"
11
12# This commit corresponds to ti2013.04.00 release tag
13SRCREV = "7552b4c906b0a50fbc5225dc43ed0192618e9d5d"
14
15SPL_BINARY = "MLO"
16SPL_UART_BINARY = "u-boot-spl.bin"
diff --git a/recipes-bsp/u-boot/u-boot-ti-staging_2013.10.bb b/recipes-bsp/u-boot/u-boot-ti-staging_2013.10.bb
deleted file mode 100644
index de44faa5..00000000
--- a/recipes-bsp/u-boot/u-boot-ti-staging_2013.10.bb
+++ /dev/null
@@ -1,18 +0,0 @@
1require u-boot-ti.inc
2
3DESCRIPTION = "u-boot bootloader for TI devices"
4
5LIC_FILES_CHKSUM = "file://Licenses/README;md5=025bf9f768cbcb1a165dbe1a110babfb"
6
7PR = "r8"
8PV_append = "+git${SRCPV}"
9
10SRC_URI = "git://git.ti.com/ti-u-boot/ti-u-boot.git;protocol=git;branch=${BRANCH}"
11
12BRANCH ?= "ti-u-boot-2013.10"
13
14# Corresponds to tag ti2013.12.01_amsdk-07.01
15SRCREV = "259ff9a577cc66cb40e3cdff3e41628e466f0fef"
16
17SPL_BINARY = "MLO"
18SPL_UART_BINARY = "u-boot-spl.bin"
diff --git a/recipes-bsp/u-boot/u-boot_2014.07.bb b/recipes-bsp/u-boot/u-boot_2014.07.bb
deleted file mode 100644
index 6cd8acd4..00000000
--- a/recipes-bsp/u-boot/u-boot_2014.07.bb
+++ /dev/null
@@ -1,25 +0,0 @@
1require u-boot-ti.inc
2
3# DEPEND on dtc-native for mainline u-boot because the mainline u-boot depends
4# on some of the latest syntax constructs for an appended in dtb used for
5# items like secure boot/image signing.
6DEPENDS += "dtc-native"
7
8DESCRIPTION = "Mainline u-boot bootloader"
9
10DEFAULT_PREFERENCE = "-1"
11
12LIC_FILES_CHKSUM = "file://Licenses/README;md5=025bf9f768cbcb1a165dbe1a110babfb"
13
14SRC_URI = "git://git.denx.de/u-boot.git;protocol=git;branch=${BRANCH}"
15
16BRANCH ?= "master"
17
18# Corresponds to tag v2014.07
19SRCREV = "524123a70761110c5cf3ccc5f52f6d4da071b959"
20
21SPL_BINARY = "MLO"
22SPL_UART_BINARY = "u-boot-spl.bin"
23
24SPL_BINARY_omapl138 = ""
25SPL_UART_BINARY_omapl138 = ""