summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2012-02-09 20:21:20 +0100
committerDenys Dmytriyenko <denys@ti.com>2012-02-10 21:32:46 -0500
commita924b24328daa3104d5d8538d417763a9e8b459c (patch)
treeed4f2cb764984c90b229ee13b8ac96a6fc1dc837
parente58c65aca39d3688f3455c31309a54bd3e2ddc56 (diff)
downloadmeta-ti-a924b24328daa3104d5d8538d417763a9e8b459c.tar.gz
bonescript: major rework
* switch to tarball to get a working .git * post-process out x86 binaries * remove allarch Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r--recipes-misc/payload/bonescript.bb23
1 files changed, 11 insertions, 12 deletions
diff --git a/recipes-misc/payload/bonescript.bb b/recipes-misc/payload/bonescript.bb
index 4557eaed..3361cb47 100644
--- a/recipes-misc/payload/bonescript.bb
+++ b/recipes-misc/payload/bonescript.bb
@@ -1,32 +1,31 @@
1DESCRIPTION = "Scripting tools for the BeagleBoard and BeagleBone" 1DESCRIPTION = "Scripting tools for the BeagleBoard and BeagleBone"
2 2
3PR = "r12" 3PR = "r13"
4 4
5inherit allarch systemd 5inherit systemd
6 6
7# Ask Jason
8LICENSE = "MIT" 7LICENSE = "MIT"
9LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58" 8LIC_FILES_CHKSUM = "file://LICENSE;md5=659ee0c98db2664403c769d6b9ab50eb"
10 9
11SRCREV = "8118a541e8927f48de2cf9ec203aa1caf88ec1f3" 10SRC_URI = "http://dominion.thruhere.net/koen/angstrom/beaglebone/bonescript-8898f4ee4ae2548642679626a03e332a4cd43331.tar.bz2 \
12SRC_URI = "git://github.com/jadonk/bonescript.git \
13 file://bonescript-git \ 11 file://bonescript-git \
14 file://bone101.service \ 12 file://bone101.service \
15 " 13 "
16S = "${WORKDIR}/git" 14SRC_URI[md5sum] = "306278a2afc10b75f4fc886918fb02b7"
15SRC_URI[sha256sum] = "01c87e59adcc663365c664b0731f0e5a23feeae1965a5cd5edd3e89255f8a30b"
16
17S = "${WORKDIR}/bonescript"
17 18
18do_install() { 19do_install() {
19 install -m 0644 ${WORKDIR}/bonescript-git ${S}/.git/config
20 cp $(cat .git/objects/info/alternates)/pack/* .git/objects/pack
21 rm -f ${S}/.git/objects/info/alternates
22 echo ${SRCREV} > .git/refs/heads/master
23 git checkout master || true
24 install -d ${D}${localstatedir}/lib/cloud9/ 20 install -d ${D}${localstatedir}/lib/cloud9/
25 cp -a ${S}/* ${D}${localstatedir}/lib/cloud9/ 21 cp -a ${S}/* ${D}${localstatedir}/lib/cloud9/
26 cp -a ${S}/.git ${D}${localstatedir}/lib/cloud9/ 22 cp -a ${S}/.git ${D}${localstatedir}/lib/cloud9/
27 23
28 install -d ${D}${base_libdir}/systemd/system 24 install -d ${D}${base_libdir}/systemd/system
29 install -m 0644 ${WORKDIR}/bone101.service ${D}${base_libdir}/systemd/system 25 install -m 0644 ${WORKDIR}/bone101.service ${D}${base_libdir}/systemd/system
26
27 rm -f ${D}${localstatedir}/lib/cloud9/node_modules/binary/node_modules/put/test/c/itof
28 rm -f ${D}${localstatedir}/lib/cloud9/node_modules/binary/node_modules/put/test/c/ftoi
30} 29}
31 30
32SYSTEMD_PACKAGES = "${PN}" 31SYSTEMD_PACKAGES = "${PN}"