summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2015-09-09 00:40:45 +0000
committerDenys Dmytriyenko <denys@ti.com>2015-09-08 14:45:11 -0400
commit8f3e07ca27cd2ef5c7fbe4ffd9e64886ee58ad08 (patch)
treebbfc55b6228a8804679a9f2b099e0ade3b9d857e
parentde2bdfdc93d82e7f41ee3cba33c8dbc61ad91048 (diff)
downloadmeta-ti-8f3e07ca27cd2ef5c7fbe4ffd9e64886ee58ad08.tar.gz
boot-monitor: also package resulting skern file into /boot
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r--recipes-bsp/boot-monitor/boot-monitor_git.bb17
1 files changed, 12 insertions, 5 deletions
diff --git a/recipes-bsp/boot-monitor/boot-monitor_git.bb b/recipes-bsp/boot-monitor/boot-monitor_git.bb
index c353488d..d64cba71 100644
--- a/recipes-bsp/boot-monitor/boot-monitor_git.bb
+++ b/recipes-bsp/boot-monitor/boot-monitor_git.bb
@@ -8,7 +8,7 @@ PACKAGE_ARCH = "${MACHINE_ARCH}"
8SRC_URI = "git://git.ti.com/keystone-linux/boot-monitor.git;protocol=git;branch=${BRANCH}" 8SRC_URI = "git://git.ti.com/keystone-linux/boot-monitor.git;protocol=git;branch=${BRANCH}"
9 9
10PV = "2.0+git${SRCPV}" 10PV = "2.0+git${SRCPV}"
11PR = "r4" 11PR = "r5"
12 12
13BRANCH = "master" 13BRANCH = "master"
14 14
@@ -24,6 +24,10 @@ FLOATABI = "${@base_contains("TUNE_FEATURES", "vfp", base_contains("TUNE_FEATURE
24 24
25EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX} CC="${TARGET_PREFIX}gcc ${TOOLCHAIN_OPTIONS} ${FLOATABI}" LD="${TARGET_PREFIX}gcc ${TOOLCHAIN_OPTIONS} ${FLOATABI}"" 25EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX} CC="${TARGET_PREFIX}gcc ${TOOLCHAIN_OPTIONS} ${FLOATABI}" LD="${TARGET_PREFIX}gcc ${TOOLCHAIN_OPTIONS} ${FLOATABI}""
26 26
27FILES_${PN} = "/boot"
28
29inherit deploy
30
27do_compile () { 31do_compile () {
28 unset LDFLAGS 32 unset LDFLAGS
29 unset CFLAGS 33 unset CFLAGS
@@ -31,11 +35,14 @@ do_compile () {
31 oe_runmake ${BOOT_MONITOR_MAKE_TARGET} 35 oe_runmake ${BOOT_MONITOR_MAKE_TARGET}
32} 36}
33 37
34inherit deploy 38do_install () {
35 39 install -d ${D}/boot
36addtask deploy before do_build after do_compile 40 install -m 0644 ${S}/${BOOT_MONITOR_BINARY} ${D}/boot/${BOOT_MONITOR_IMAGE}
41}
37 42
38do_deploy () { 43do_deploy () {
39 install -d ${DEPLOYDIR} 44 install -d ${DEPLOYDIR}
40 install ${S}/${BOOT_MONITOR_BINARY} ${DEPLOYDIR}/${BOOT_MONITOR_IMAGE} 45 install -m 0644 ${S}/${BOOT_MONITOR_BINARY} ${DEPLOYDIR}/${BOOT_MONITOR_IMAGE}
41} 46}
47
48addtask deploy before do_build after do_compile