summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2015-09-10 01:53:51 +0000
committerDenys Dmytriyenko <denys@ti.com>2015-09-09 16:08:19 -0400
commit411adbe48c6d567395ce8f824af1b5a9246e5d42 (patch)
tree62e78e0b7a58f55c5f5aa01b150db690f26cb3d6
parent94a36401bc5aea6293bce8f242867b50a6c0e1df (diff)
downloadmeta-ti-411adbe48c6d567395ce8f824af1b5a9246e5d42.tar.gz
boot-monitor: adjust resulting skern name to be SOC specific, not machine specific
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r--recipes-bsp/boot-monitor/boot-monitor_git.bb9
1 files changed, 4 insertions, 5 deletions
diff --git a/recipes-bsp/boot-monitor/boot-monitor_git.bb b/recipes-bsp/boot-monitor/boot-monitor_git.bb
index d64cba71..57801954 100644
--- a/recipes-bsp/boot-monitor/boot-monitor_git.bb
+++ b/recipes-bsp/boot-monitor/boot-monitor_git.bb
@@ -8,7 +8,7 @@ PACKAGE_ARCH = "${MACHINE_ARCH}"
8SRC_URI = "git://git.ti.com/keystone-linux/boot-monitor.git;protocol=git;branch=${BRANCH}" 8SRC_URI = "git://git.ti.com/keystone-linux/boot-monitor.git;protocol=git;branch=${BRANCH}"
9 9
10PV = "2.0+git${SRCPV}" 10PV = "2.0+git${SRCPV}"
11PR = "r5" 11PR = "r6"
12 12
13BRANCH = "master" 13BRANCH = "master"
14 14
@@ -17,8 +17,7 @@ S = "${WORKDIR}/git"
17#Tag "K2_BM_15.07" 17#Tag "K2_BM_15.07"
18SRCREV = "62d198687a34a9df375c1686d75ad4f85515dcf9" 18SRCREV = "62d198687a34a9df375c1686d75ad4f85515dcf9"
19 19
20BOOT_MONITOR_BINARY ?= "skern.bin" 20BOOT_MONITOR_IMAGE ?= "skern-${BOOT_MONITOR_MAKE_TARGET}.bin"
21BOOT_MONITOR_IMAGE ?= "skern-${MACHINE}.bin"
22 21
23FLOATABI = "${@base_contains("TUNE_FEATURES", "vfp", base_contains("TUNE_FEATURES", "callconvention-hard", " -mfloat-abi=hard", " -mfloat-abi=softfp", d), "" ,d)}" 22FLOATABI = "${@base_contains("TUNE_FEATURES", "vfp", base_contains("TUNE_FEATURES", "callconvention-hard", " -mfloat-abi=hard", " -mfloat-abi=softfp", d), "" ,d)}"
24 23
@@ -37,12 +36,12 @@ do_compile () {
37 36
38do_install () { 37do_install () {
39 install -d ${D}/boot 38 install -d ${D}/boot
40 install -m 0644 ${S}/${BOOT_MONITOR_BINARY} ${D}/boot/${BOOT_MONITOR_IMAGE} 39 install -m 0644 ${S}/${BOOT_MONITOR_IMAGE} ${D}/boot/
41} 40}
42 41
43do_deploy () { 42do_deploy () {
44 install -d ${DEPLOYDIR} 43 install -d ${DEPLOYDIR}
45 install -m 0644 ${S}/${BOOT_MONITOR_BINARY} ${DEPLOYDIR}/${BOOT_MONITOR_IMAGE} 44 install -m 0644 ${S}/${BOOT_MONITOR_IMAGE} ${DEPLOYDIR}/
46} 45}
47 46
48addtask deploy before do_build after do_compile 47addtask deploy before do_build after do_compile