summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2015-03-20 08:24:05 +0000
committerDenys Dmytriyenko <denys@ti.com>2015-03-19 23:51:46 -0400
commit600f9fad73a0f6e03281cd1d38af80f8f1e338d1 (patch)
tree838957188c580fdd0d1f5fb4074fe0fcc5c40caf
parentbe8d1c1de175c22dc8e066d17dc54649975b4687 (diff)
downloadmeta-ti-600f9fad73a0f6e03281cd1d38af80f8f1e338d1.tar.gz
ipumm-fw: split omap5-evm and dra7xx-evm recipes due to different versions
The last version update left omap5-evm behind, which breaks the recipe. Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r--recipes-bsp/ipumm-fw/ipumm-fw_3.00.04.02.bb33
-rw-r--r--recipes-bsp/ipumm-fw/ipumm-fw_3.00.07.02.bb26
2 files changed, 41 insertions, 18 deletions
diff --git a/recipes-bsp/ipumm-fw/ipumm-fw_3.00.04.02.bb b/recipes-bsp/ipumm-fw/ipumm-fw_3.00.04.02.bb
new file mode 100644
index 00000000..f5ebd14e
--- /dev/null
+++ b/recipes-bsp/ipumm-fw/ipumm-fw_3.00.04.02.bb
@@ -0,0 +1,33 @@
1python __anonymous() {
2 features = bb.data.getVar("MACHINE_FEATURES", d, 1)
3 if not features:
4 return
5 if "mmip" not in features:
6 raise bb.parse.SkipPackage('ipumm-fw does not apply to systems without the "mmip" flag in MACHINE_FEATURES')
7}
8
9DESCRIPTION = "Firmware for IPU for supporting Accelerated MM decode and encode"
10LICENSE = "TI-TSPA"
11
12LIC_FILES_CHKSUM = "file://MMIP-${PV}-Manifest.doc;md5=39a593dd8fc2a9654c74f679ed329c45"
13
14COMPATIBLE_MACHINE = "omap5-evm"
15PACKAGE_ARCH = "${MACHINE_ARCH}"
16
17SRC_URI = "http://downloads.ti.com/dsps/dsps_public_sw/glsdk/ipumm/3_00_04_02/exports/ipumm-${MACHINE}-${PV}.tar.gz;protocol=http"
18
19SRC_URI[md5sum] = "1572073ebd4f6d127c4e8cf47d270b6a"
20SRC_URI[sha256sum] = "2fdb469f19e3c9984854f5bc82444fca4d7da869f5e645da22ec0d5beaa5cc65"
21
22S = "${WORKDIR}/ipumm-${MACHINE}-${PV}"
23
24TARGET = "ducati-m3-core0.xem3"
25
26do_install() {
27 mkdir -p ${D}${base_libdir}/firmware
28 cp ${S}/firmware/${TARGET} ${D}${base_libdir}/firmware/${TARGET}
29}
30
31FILES_${PN} += "${base_libdir}/firmware/${TARGET}"
32
33PR = "r3"
diff --git a/recipes-bsp/ipumm-fw/ipumm-fw_3.00.07.02.bb b/recipes-bsp/ipumm-fw/ipumm-fw_3.00.07.02.bb
index 5b85f83b..036ea335 100644
--- a/recipes-bsp/ipumm-fw/ipumm-fw_3.00.07.02.bb
+++ b/recipes-bsp/ipumm-fw/ipumm-fw_3.00.07.02.bb
@@ -9,29 +9,19 @@ python __anonymous() {
9DESCRIPTION = "Firmware for IPU for supporting Accelerated MM decode and encode" 9DESCRIPTION = "Firmware for IPU for supporting Accelerated MM decode and encode"
10LICENSE = "TI-TSPA" 10LICENSE = "TI-TSPA"
11 11
12LIC_FILES_CHKSUM_dra7xx = "file://MMIP-${PV}-Manifest.doc;md5=caa45d993ac010abe2fd319f6613bc26" 12LIC_FILES_CHKSUM = "file://MMIP-${PV}-Manifest.doc;md5=caa45d993ac010abe2fd319f6613bc26"
13LIC_FILES_CHKSUM_omap5-evm = "file://MMIP-${PV}-Manifest.doc;md5=39a593dd8fc2a9654c74f679ed329c45"
14 13
15COMPATIBLE_MACHINE = "dra7xx|omap5-evm" 14COMPATIBLE_MACHINE = "dra7xx"
16PACKAGE_ARCH = "${MACHINE_ARCH}" 15PACKAGE_ARCH = "${MACHINE_ARCH}"
17 16
18SRC_URI_dra7xx = "http://downloads.ti.com/dsps/dsps_public_sw/glsdk/ipumm/3_00_07_02/exports/ipumm-dra7xx-evm-3.00.07.02.tar.gz;protocol=ftp;name=dra7xx-evm" 17SRC_URI = "http://downloads.ti.com/dsps/dsps_public_sw/glsdk/ipumm/3_00_07_02/exports/ipumm-${MACHINE}-${PV}.tar.gz;protocol=http"
19 18
20SRC_URI_omap5-evm = "http://downloads.ti.com/dsps/dsps_public_sw/glsdk/ipumm/3_00_04_02/exports/ipumm-${MACHINE}-3.00.04.02.tar.gz;protocol=http;name=${MACHINE}" 19SRC_URI[md5sum] = "06aaf4f144d48ca16054e67e40cc7bc3"
20SRC_URI[sha256sum] = "0f07176e313a692a05fa6bfe9f7920b677b0924287121945c6e22b3f4408670c"
21 21
22# DRA7xx checksums 22S = "${WORKDIR}/ipumm-${MACHINE}-${PV}"
23SRC_URI[dra7xx-evm.md5sum] = "06aaf4f144d48ca16054e67e40cc7bc3"
24SRC_URI[dra7xx-evm.sha256sum] = "0f07176e313a692a05fa6bfe9f7920b677b0924287121945c6e22b3f4408670c"
25 23
26# OMAP5 checksums 24TARGET = "dra7-ipu2-fw.xem4"
27SRC_URI[omap5-evm.md5sum] = "1572073ebd4f6d127c4e8cf47d270b6a"
28SRC_URI[omap5-evm.sha256sum] = "2fdb469f19e3c9984854f5bc82444fca4d7da869f5e645da22ec0d5beaa5cc65"
29
30S_dra7xx = "${WORKDIR}/ipumm-dra7xx-evm-${PV}"
31S_omap5-evm = "${WORKDIR}/ipumm-${MACHINE}-${PV}"
32
33TARGET_dra7xx = "dra7-ipu2-fw.xem4"
34TARGET_omap5-evm = "ducati-m3-core0.xem3"
35 25
36do_install() { 26do_install() {
37 mkdir -p ${D}${base_libdir}/firmware 27 mkdir -p ${D}${base_libdir}/firmware
@@ -40,4 +30,4 @@ do_install() {
40 30
41FILES_${PN} += "${base_libdir}/firmware/${TARGET}" 31FILES_${PN} += "${base_libdir}/firmware/${TARGET}"
42 32
43PR = "r2" 33PR = "r3"