summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSam Nelson <sam.nelson@ti.com>2014-02-12 05:41:49 +0000
committerDenys Dmytriyenko <denys@ti.com>2014-03-04 23:39:59 -0500
commit625b43736f6476701e41de0eb3209f01ab801ae0 (patch)
tree5d66a728f572622495b11cf32deebc81322ac3ba
parente4b90a654c352e0161760d263f589a2c041533bf (diff)
downloadmeta-ti-625b43736f6476701e41de0eb3209f01ab801ae0.tar.gz
ti-ipc: Add recipe for ti-ipc version 3.0.x
- Supports communication between processors in TI keystone architecture Signed-off-by: Sam Nelson <sam.nelson@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rwxr-xr-xrecipes-ti/ipc/files/tiipclad-daemon.sh24
-rw-r--r--recipes-ti/ipc/ti-ipc_3.00.00.bb52
2 files changed, 76 insertions, 0 deletions
diff --git a/recipes-ti/ipc/files/tiipclad-daemon.sh b/recipes-ti/ipc/files/tiipclad-daemon.sh
new file mode 100755
index 00000000..54b38882
--- /dev/null
+++ b/recipes-ti/ipc/files/tiipclad-daemon.sh
@@ -0,0 +1,24 @@
1#! /bin/sh
2
3tiipclad_daemon=/usr/bin/lad_tci6638
4tiipclad_params=lad.txt
5
6test -x "$tiipclad_daemon" || exit 0
7
8case "$1" in
9 start)
10 echo -n "Starting tiipclad daemon"
11 start-stop-daemon --start --quiet --exec $tiipclad_daemon $tiipclad_params
12 echo "."
13 ;;
14 stop)
15 echo -n "Stopping tiipclad daemon"
16 start-stop-daemon --stop --quiet --pidfile /var/run/tiipclad.pid
17 echo "."
18 ;;
19 *)
20 echo "Usage: /etc/init.d/tiipclad-daemon.sh {start|stop}"
21 exit 1
22esac
23
24exit 0
diff --git a/recipes-ti/ipc/ti-ipc_3.00.00.bb b/recipes-ti/ipc/ti-ipc_3.00.00.bb
new file mode 100644
index 00000000..c07b7f9b
--- /dev/null
+++ b/recipes-ti/ipc/ti-ipc_3.00.00.bb
@@ -0,0 +1,52 @@
1DESCRIPTION="This support the communication between processors \
2in a multi-processor environment and communication to peripherals. \
3This communication includes message passing, streams, and linked lists. \
4These modules work transparently in both uni-processor and multi-processor \
5configurations."
6
7HOMEPAGE="http://processors.wiki.ti.com/index.php/Category:IPC"
8
9LICENSE = "BSD"
10LIC_FILES_CHKSUM = "file://products.mak;beginline=2;endline=30;md5=195feadf798bb4165bcb1a23ffd50dbb"
11SECTION = "console"
12COMPATIBLE_MACHINE = "keystone"
13TARGET_PLATFORM = "tci6638"
14
15PR = "r0"
16
17BRANCH ?= "master"
18# The following commit corresponds to 3.00.04.29
19SRCREV = "12794ea33870b782bffe1fe4398e86e93fb64396"
20
21SRC_URI = " \
22 git://git.ti.com/ipc/ipcdev.git;protocol=git;branch=${BRANCH} \
23 file://tiipclad-daemon.sh"
24
25S = "${WORKDIR}/git"
26
27export PLATFORM = "${TARGET_PLATFORM}"
28
29export PARALLEL_MAKE = ""
30
31PACKAGES =+ "${PN}-test"
32
33FILES_${PN}-test = " \
34 ${bindir}/NameServerApp \
35 ${bindir}/MessageQApp \
36 ${bindir}/MessageQMulti \
37 ${bindir}/ping_rpmsg"
38
39DEPENDS += "virtual/kernel"
40
41EXTRA_OECONF += "KERNEL_INSTALL_DIR=${STAGING_KERNEL_DIR}"
42inherit autotools
43
44INITSCRIPT_NAME = "tiipclad-daemon.sh"
45INITSCRIPT_PARAMS = "defaults 10"
46
47inherit update-rc.d
48
49do_install_append() {
50 install -d ${D}${sysconfdir}/init.d/
51 install -c -m 755 ${WORKDIR}/tiipclad-daemon.sh ${D}${sysconfdir}/init.d/${INITSCRIPT_NAME}
52}