summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2019-12-19 12:36:02 +0000
committerDenys Dmytriyenko <denys@ti.com>2019-12-19 17:15:36 +0000
commitf4630f59bb4e0be86f288ba3f65006de27c37ece (patch)
treec3ae4dd96ec42b9d7241ec9ac478f8006d9b220f
parentdd85eab84af0214771aadd41712c2de35f8b61b4 (diff)
downloadmeta-ti-f4630f59bb4e0be86f288ba3f65006de27c37ece.tar.gz
libion: Fix build for multilibbed environment
Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r--recipes-devtools/ion/libion/0001-cmake-Use-GNUInstallDirs-module-to-detect-install-pa.patch48
-rw-r--r--recipes-devtools/ion/libion_git.bb4
2 files changed, 51 insertions, 1 deletions
diff --git a/recipes-devtools/ion/libion/0001-cmake-Use-GNUInstallDirs-module-to-detect-install-pa.patch b/recipes-devtools/ion/libion/0001-cmake-Use-GNUInstallDirs-module-to-detect-install-pa.patch
new file mode 100644
index 00000000..bf63ed32
--- /dev/null
+++ b/recipes-devtools/ion/libion/0001-cmake-Use-GNUInstallDirs-module-to-detect-install-pa.patch
@@ -0,0 +1,48 @@
1From 51eece2c291e121f9ae67c9b812617b885e76a64 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Wed, 18 Dec 2019 20:31:52 -0800
4Subject: [PATCH] cmake: Use GNUInstallDirs module to detect install paths
5
6This helps it to calculate directories as per platform instead of
7hardcoding them, helps compile it for arches which use /lib64 and
8/usr/lib64 for libpaths
9
10Upstream-Status: Submitted [https://github.com/glneo/libion/pull/2]
11Signed-off-by: Khem Raj <raj.khem@gmail.com>
12---
13 CMakeLists.txt | 10 ++++++----
14 1 file changed, 6 insertions(+), 4 deletions(-)
15
16diff --git a/CMakeLists.txt b/CMakeLists.txt
17index 6e5928c..5b7c0de 100644
18--- a/CMakeLists.txt
19+++ b/CMakeLists.txt
20@@ -3,6 +3,8 @@ PROJECT(ion)
21 set(PROJECT_DESCRIPTION "ION Userspace Memory Allocator Library")
22 set(PROJECT_VERSION 1.0.0)
23
24+INCLUDE(GNUInstallDirs)
25+
26 add_library(ion
27 SHARED
28 src/libion.c
29@@ -23,12 +25,12 @@ target_include_directories(ion
30 configure_file(libion.pc.in libion.pc @ONLY)
31
32 install(TARGETS ion
33- LIBRARY DESTINATION lib
34- PUBLIC_HEADER DESTINATION include/ion)
35+ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
36+ PUBLIC_HEADER DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/ion)
37
38 install(DIRECTORY include/kernel-headers/4.19/
39- DESTINATION include
40+ DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}
41 FILES_MATCHING PATTERN "*.h")
42
43 install(FILES ${CMAKE_BINARY_DIR}/libion.pc
44- DESTINATION lib/pkgconfig)
45+ DESTINATION ${CMAKE_INSTALL_LIBDIR}/pkgconfig)
46--
472.24.1
48
diff --git a/recipes-devtools/ion/libion_git.bb b/recipes-devtools/ion/libion_git.bb
index 8bfe19eb..4cf03afa 100644
--- a/recipes-devtools/ion/libion_git.bb
+++ b/recipes-devtools/ion/libion_git.bb
@@ -6,7 +6,9 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
6PV = "1.0.0" 6PV = "1.0.0"
7 7
8BRANCH = "master" 8BRANCH = "master"
9SRC_URI = "git://github.com/glneo/libion.git;protocol=git;branch=${BRANCH}" 9SRC_URI = "git://github.com/glneo/libion.git;protocol=git;branch=${BRANCH} \
10 file://0001-cmake-Use-GNUInstallDirs-module-to-detect-install-pa.patch \
11 "
10SRCREV = "813bd63e2f2118e17cb1c5d38505a1e572a2381c" 12SRCREV = "813bd63e2f2118e17cb1c5d38505a1e572a2381c"
11 13
12S = "${WORKDIR}/git" 14S = "${WORKDIR}/git"