summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2012-05-01 21:06:51 +0200
committerDenys Dmytriyenko <denys@ti.com>2012-05-03 19:09:21 -0400
commitf0e2305c7e1395066b4303b4a891bfb2a066602b (patch)
tree1eede5c9eea3e57d0f89e765a269017e90da0470
parent368d7772dcde0a42e9952ca6b2762495d0f49602 (diff)
downloadmeta-ti-f0e2305c7e1395066b4303b4a891bfb2a066602b.tar.gz
u-boot 2011.12: don't poke at uLCD7 settings from u-boot, it's handled in the kernel now
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> Acked-by: Tom Rini <trini@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r--recipes-bsp/u-boot/u-boot/2011.12/0003-beagleboard-add-support-for-scanning-loop-through-ex.patch2
-rw-r--r--recipes-bsp/u-boot/u-boot_2011.12.bb2
2 files changed, 2 insertions, 2 deletions
diff --git a/recipes-bsp/u-boot/u-boot/2011.12/0003-beagleboard-add-support-for-scanning-loop-through-ex.patch b/recipes-bsp/u-boot/u-boot/2011.12/0003-beagleboard-add-support-for-scanning-loop-through-ex.patch
index 71dd2bb2..1bbe14e7 100644
--- a/recipes-bsp/u-boot/u-boot/2011.12/0003-beagleboard-add-support-for-scanning-loop-through-ex.patch
+++ b/recipes-bsp/u-boot/u-boot/2011.12/0003-beagleboard-add-support-for-scanning-loop-through-ex.patch
@@ -62,7 +62,7 @@ index 9c2e6d0..5ea50d1 100644
62+ printf("Recognized BeagleBoardToys uLCD-lite board\n"); 62+ printf("Recognized BeagleBoardToys uLCD-lite board\n");
63+ setenv("buddy2", "bbtoys-ulcd"); 63+ setenv("buddy2", "bbtoys-ulcd");
64+ setenv("defaultdisplay", "lcd"); 64+ setenv("defaultdisplay", "lcd");
65+ setenv("uenvcmd", "i2c dev 1 ; i2c mw 40 00 00; i2c mw 40 04 80; i2c mw 40 0d 05; i2c mw 40 0d 15"); 65+ //setenv("uenvcmd", "i2c dev 1 ; i2c mw 40 00 00; i2c mw 40 04 80; i2c mw 40 0d 05; i2c mw 40 0d 15");
66+ break; 66+ break;
67+ case BEAGLE_NO_EEPROM: 67+ case BEAGLE_NO_EEPROM:
68+ printf("No EEPROM on expansion board\n"); 68+ printf("No EEPROM on expansion board\n");
diff --git a/recipes-bsp/u-boot/u-boot_2011.12.bb b/recipes-bsp/u-boot/u-boot_2011.12.bb
index 9bbd31e2..9616a053 100644
--- a/recipes-bsp/u-boot/u-boot_2011.12.bb
+++ b/recipes-bsp/u-boot/u-boot_2011.12.bb
@@ -6,7 +6,7 @@ UBOOT_IMAGE = "u-boot-${MACHINE}-${PV}-${PR}.img"
6UBOOT_SYMLINK = "u-boot-${MACHINE}.img" 6UBOOT_SYMLINK = "u-boot-${MACHINE}.img"
7 7
8PV = "2011.12" 8PV = "2011.12"
9PR = "r6" 9PR = "r7"
10 10
11# No patches for other machines yet 11# No patches for other machines yet
12COMPATIBLE_MACHINE = "(beagleboard|pandaboard|hawkboard|am3517-evm|am37x-evm|omap3evm)" 12COMPATIBLE_MACHINE = "(beagleboard|pandaboard|hawkboard|am3517-evm|am37x-evm|omap3evm)"