summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2012-05-23 18:05:58 +0200
committerDenys Dmytriyenko <denys@ti.com>2012-05-30 13:49:27 -0400
commitda7c9449fa3272f63e0ba1f8a42fd3aba66e1ceb (patch)
tree302f212f136d20d7b2013fd3e86b229adb64e697
parent1d44de8f58cdfd71c90ce078070be1b6c6574832 (diff)
downloadmeta-ti-da7c9449fa3272f63e0ba1f8a42fd3aba66e1ceb.tar.gz
linux-ti33x-psp 3.2: fix pin free check once and for all
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r--recipes-kernel/linux/linux-ti33x-psp-3.2/beaglebone/0064-beaglebone-always-execute-the-pin-free-checks.patch68
-rw-r--r--recipes-kernel/linux/linux-ti33x-psp_3.2.bb3
2 files changed, 70 insertions, 1 deletions
diff --git a/recipes-kernel/linux/linux-ti33x-psp-3.2/beaglebone/0064-beaglebone-always-execute-the-pin-free-checks.patch b/recipes-kernel/linux/linux-ti33x-psp-3.2/beaglebone/0064-beaglebone-always-execute-the-pin-free-checks.patch
new file mode 100644
index 00000000..e6f696ed
--- /dev/null
+++ b/recipes-kernel/linux/linux-ti33x-psp-3.2/beaglebone/0064-beaglebone-always-execute-the-pin-free-checks.patch
@@ -0,0 +1,68 @@
1From 2b000164f7bd77838ec5c9ad5d392282a4e27b3f Mon Sep 17 00:00:00 2001
2From: Koen Kooi <koen@dominion.thruhere.net>
3Date: Wed, 23 May 2012 17:39:12 +0200
4Subject: [PATCH 64/64] beaglebone: always execute the pin free checks
5
6This code needs to run when there are no capes and when there are capes present.
7
8Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
9---
10 arch/arm/mach-omap2/board-am335xevm.c | 26 +++++++++++++-------------
11 1 files changed, 13 insertions(+), 13 deletions(-)
12
13diff --git a/arch/arm/mach-omap2/board-am335xevm.c b/arch/arm/mach-omap2/board-am335xevm.c
14index 1f2d1fd..da6020b 100644
15--- a/arch/arm/mach-omap2/board-am335xevm.c
16+++ b/arch/arm/mach-omap2/board-am335xevm.c
17@@ -2589,7 +2589,7 @@ static void beaglebone_cape_setup(struct memory_accessor *mem_acc, void *context
18 ret = mem_acc->read(mem_acc, (char *)&cape_config, 0, sizeof(cape_config));
19 if (ret != sizeof(cape_config)) {
20 pr_warning("BeagleBone cape EEPROM: could not read eeprom at address 0x%x\n", capecount + 0x53);
21- return;
22+ goto out2;
23 }
24
25 if (cape_config.header != AM335X_EEPROM_HEADER) {
26@@ -2724,6 +2724,16 @@ static void beaglebone_cape_setup(struct memory_accessor *mem_acc, void *context
27 beaglebone_w1gpio_free = 0;
28 }
29
30+ goto out2;
31+out:
32+ /*
33+ * If the EEPROM hasn't been programed or an incorrect header
34+ * or board name are read, assume this is an old beaglebone board
35+ * (< Rev A3)
36+ */
37+ pr_err("Could not detect BeagleBone cape properly\n");
38+ beaglebone_cape_detected = false;
39+out2:
40 if (capecount > 3) {
41 if (beaglebone_tsadcpins_free == 1) {
42 pr_info("BeagleBone cape: exporting ADC pins to sysfs\n");
43@@ -2741,20 +2751,10 @@ static void beaglebone_cape_setup(struct memory_accessor *mem_acc, void *context
44 spi_register_board_info(bone_spidev2_info, ARRAY_SIZE(bone_spidev2_info));
45 }
46 if(beaglebone_w1gpio_free == 1) {
47+ pr_info("BeagleBone cape: initializing w1-gpio\n");
48 bonew1_gpio_init(0,0);
49 }
50- }
51-
52- return;
53-out:
54- /*
55- * If the EEPROM hasn't been programed or an incorrect header
56- * or board name are read, assume this is an old beaglebone board
57- * (< Rev A3)
58- */
59- pr_err("Could not detect BeagleBone cape properly\n");
60- beaglebone_cape_detected = false;
61-
62+ }
63 }
64
65 static struct at24_platform_data cape_eeprom_info = {
66--
671.7.7.6
68
diff --git a/recipes-kernel/linux/linux-ti33x-psp_3.2.bb b/recipes-kernel/linux/linux-ti33x-psp_3.2.bb
index 4c144e51..38202fa1 100644
--- a/recipes-kernel/linux/linux-ti33x-psp_3.2.bb
+++ b/recipes-kernel/linux/linux-ti33x-psp_3.2.bb
@@ -12,7 +12,7 @@ MULTI_CONFIG_BASE_SUFFIX = ""
12 12
13BRANCH = "v3.2-staging" 13BRANCH = "v3.2-staging"
14SRCREV = "720e07b4c1f687b61b147b31c698cb6816d72f01" 14SRCREV = "720e07b4c1f687b61b147b31c698cb6816d72f01"
15MACHINE_KERNEL_PR_append = "b+gitr${SRCREV}" 15MACHINE_KERNEL_PR_append = "c+gitr${SRCREV}"
16 16
17COMPATIBLE_MACHINE = "(ti33x)" 17COMPATIBLE_MACHINE = "(ti33x)"
18 18
@@ -1220,4 +1220,5 @@ PATCHES_OVER_PSP = " \
1220 file://beaglebone/0061-beaglebone-make-uart2-pinmux-match-the-uart0-pinmux.patch \ 1220 file://beaglebone/0061-beaglebone-make-uart2-pinmux-match-the-uart0-pinmux.patch \
1221 file://beaglebone/0062-da8xx-fb-Rounding-FB-size-to-satisfy-SGX-buffer-requ.patch \ 1221 file://beaglebone/0062-da8xx-fb-Rounding-FB-size-to-satisfy-SGX-buffer-requ.patch \
1222 file://beaglebone/0063-beaglebone-dvi-cape-audio-hacks.patch \ 1222 file://beaglebone/0063-beaglebone-dvi-cape-audio-hacks.patch \
1223 file://beaglebone/0064-beaglebone-always-execute-the-pin-free-checks.patch \
1223" 1224"