summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2012-05-17 12:07:06 +0200
committerDenys Dmytriyenko <denys@ti.com>2012-05-21 17:12:27 -0400
commitd33058225df1156174db1131d964de1ef0ab3b48 (patch)
tree4b34d9297ea1ba392d45eafa39eaf388325111ad
parent185d6216110354cca80f27b76d78a46336dadfc1 (diff)
downloadmeta-ti-d33058225df1156174db1131d964de1ef0ab3b48.tar.gz
linux-ti33x-psp 3.2: demote cpsw PHY message to INFO
This keeps them from appearing on the screen during quiet boots. They are still being reported, so no info is lost. Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r--recipes-kernel/linux/linux-ti33x-psp-3.2/beaglebone/0045-cpws-phy_device-demote-PHY-message-to-INFO.patch51
-rw-r--r--recipes-kernel/linux/linux-ti33x-psp_3.2.bb3
2 files changed, 53 insertions, 1 deletions
diff --git a/recipes-kernel/linux/linux-ti33x-psp-3.2/beaglebone/0045-cpws-phy_device-demote-PHY-message-to-INFO.patch b/recipes-kernel/linux/linux-ti33x-psp-3.2/beaglebone/0045-cpws-phy_device-demote-PHY-message-to-INFO.patch
new file mode 100644
index 00000000..2aed6469
--- /dev/null
+++ b/recipes-kernel/linux/linux-ti33x-psp-3.2/beaglebone/0045-cpws-phy_device-demote-PHY-message-to-INFO.patch
@@ -0,0 +1,51 @@
1From 04924dfd0335b8adca0e7783112827df30e70a5f Mon Sep 17 00:00:00 2001
2From: Koen Kooi <koen@dominion.thruhere.net>
3Date: Thu, 17 May 2012 10:59:18 +0200
4Subject: [PATCH] cpsw,phy_device: demote PHY message to INFO
5
6This keeps them from appearing on the screen when booting with 'quiet'
7
8Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
9---
10 drivers/net/ethernet/ti/cpsw.c | 2 +-
11 drivers/net/phy/phy_device.c | 4 ++--
12 2 files changed, 3 insertions(+), 3 deletions(-)
13
14diff --git a/drivers/net/ethernet/ti/cpsw.c b/drivers/net/ethernet/ti/cpsw.c
15index 86fe57d..d10996d 100644
16--- a/drivers/net/ethernet/ti/cpsw.c
17+++ b/drivers/net/ethernet/ti/cpsw.c
18@@ -638,7 +638,7 @@ static void cpsw_slave_open(struct cpsw_slave *slave, struct cpsw_priv *priv)
19 slave->data->phy_id, slave->slave_num);
20 slave->phy = NULL;
21 } else {
22- printk(KERN_ERR"\nCPSW phy found : id is : 0x%x\n",
23+ printk(KERN_INFO"\nCPSW phy found : id is : 0x%x\n",
24 slave->phy->phy_id);
25 cpsw_set_phy_config(priv, slave->phy);
26 phy_start(slave->phy);
27diff --git a/drivers/net/phy/phy_device.c b/drivers/net/phy/phy_device.c
28index 83a5a5a..8b84789 100644
29--- a/drivers/net/phy/phy_device.c
30+++ b/drivers/net/phy/phy_device.c
31@@ -380,7 +380,7 @@ struct phy_device * phy_connect(struct net_device *dev, const char *bus_id,
32 * PHY with the requested name */
33 d = bus_find_device_by_name(&mdio_bus_type, NULL, bus_id);
34 if (!d) {
35- pr_err("PHY %s not found\n", bus_id);
36+ pr_info("PHY %s not found\n", bus_id);
37 return ERR_PTR(-ENODEV);
38 }
39 phydev = to_phy_device(d);
40@@ -503,7 +503,7 @@ struct phy_device *phy_attach(struct net_device *dev,
41 * PHY with the requested name */
42 d = bus_find_device_by_name(bus, NULL, bus_id);
43 if (!d) {
44- pr_err("PHY %s not found\n", bus_id);
45+ pr_info("PHY %s not found\n", bus_id);
46 return ERR_PTR(-ENODEV);
47 }
48 phydev = to_phy_device(d);
49--
501.7.7.6
51
diff --git a/recipes-kernel/linux/linux-ti33x-psp_3.2.bb b/recipes-kernel/linux/linux-ti33x-psp_3.2.bb
index bb26c70f..97c1cd03 100644
--- a/recipes-kernel/linux/linux-ti33x-psp_3.2.bb
+++ b/recipes-kernel/linux/linux-ti33x-psp_3.2.bb
@@ -12,7 +12,7 @@ MULTI_CONFIG_BASE_SUFFIX = ""
12 12
13BRANCH = "v3.2-staging" 13BRANCH = "v3.2-staging"
14SRCREV = "720e07b4c1f687b61b147b31c698cb6816d72f01" 14SRCREV = "720e07b4c1f687b61b147b31c698cb6816d72f01"
15MACHINE_KERNEL_PR_append = "j+gitr${SRCREV}" 15MACHINE_KERNEL_PR_append = "l+gitr${SRCREV}"
16 16
17COMPATIBLE_MACHINE = "(ti33x)" 17COMPATIBLE_MACHINE = "(ti33x)"
18 18
@@ -969,4 +969,5 @@ PATCHES_OVER_PSP = " \
969 file://beaglebone/0040-beaglebone-export-SPI2-as-spidev-when-no-capes-are-u.patch \ 969 file://beaglebone/0040-beaglebone-export-SPI2-as-spidev-when-no-capes-are-u.patch \
970 file://beaglebone/0043-st7735fb-Working-WIP-changes-to-make-DMA-safe-and-ad.patch \ 970 file://beaglebone/0043-st7735fb-Working-WIP-changes-to-make-DMA-safe-and-ad.patch \
971 file://beaglebone/0001-arm-boot-compressed-default-asm-arch-to-armv7-a.patch \ 971 file://beaglebone/0001-arm-boot-compressed-default-asm-arch-to-armv7-a.patch \
972 file://beaglebone/0045-cpws-phy_device-demote-PHY-message-to-INFO.patch \
972" 973"