summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2012-05-10 21:55:15 -0400
committerDenys Dmytriyenko <denys@ti.com>2012-05-11 13:21:28 -0400
commita623c766f2ea8e022d216d281301919ee0cdd3fb (patch)
tree735eba4c9bf3e89df15c1bec0bc8ccedbcbd9f47
parentfa87ca0b1a1890d262a591aee50f082194f45317 (diff)
downloadmeta-ti-a623c766f2ea8e022d216d281301919ee0cdd3fb.tar.gz
linux-ti33x-psp 3.2: avoid gold linker for Thumb2 kernel
BeagleBone kernel is required to be built in Thumb2 mode for fast boot. Gold linker is not yet perfect for this, giving an internal error: | arm-linux-gnueabi-ld: internal error in thumb_branch_common, at .../binutils-cross-2.22-r6/binutils-2.22/gold/arm.cc:4149 While this fix can be put in generic linux.inc for all the kernels, it's better to test the Gold linker out as much as possible and only disable it for known issues, like this one (until it gets fixed, of course). Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r--recipes-kernel/linux/linux-ti33x-psp_3.2.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-ti33x-psp_3.2.bb b/recipes-kernel/linux/linux-ti33x-psp_3.2.bb
index d1dfaaf1..0f44a950 100644
--- a/recipes-kernel/linux/linux-ti33x-psp_3.2.bb
+++ b/recipes-kernel/linux/linux-ti33x-psp_3.2.bb
@@ -22,6 +22,8 @@ SRC_URI += "git://arago-project.org/git/projects/linux-am33x.git;protocol=http;b
22 22
23SRC_URI_append_beaglebone = " file://logo_linux_clut224.ppm" 23SRC_URI_append_beaglebone = " file://logo_linux_clut224.ppm"
24 24
25KERNEL_LDSUFFIX_beaglebone = "${@base_contains('DISTRO_FEATURES', 'ld-is-gold', '.bfd', '', d)}"
26
25do_compile_prepend() { 27do_compile_prepend() {
26 cp ${WORKDIR}/am335x-pm-firmware.bin ${S}/firmware/ 28 cp ${WORKDIR}/am335x-pm-firmware.bin ${S}/firmware/
27} 29}