summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2012-05-04 11:02:11 +0200
committerDenys Dmytriyenko <denys@ti.com>2012-05-10 15:31:34 -0400
commit649c697bf885f0abc4c7fcc16a05a556e0a02f29 (patch)
treec717a098833cc3083e27d34243ae841e7309c3bc
parent0be62d6c0d20618706707a3a0e8827b782ca2bef (diff)
downloadmeta-ti-649c697bf885f0abc4c7fcc16a05a556e0a02f29.tar.gz
linux-ti335x-psp 3.2: bump SRCREV to head of v3.2-staging and add 2 irq patches
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r--recipes-kernel/linux/linux-ti33x-psp-3.2/beaglebone/0031-omap2-irq-process-all-4-irq-banks-for-am335x.patch26
-rw-r--r--recipes-kernel/linux/linux-ti33x-psp-3.2/beaglebone/0032-omap2-irqs.h-increase-number-or-irq-banks.patch28
-rw-r--r--recipes-kernel/linux/linux-ti33x-psp_3.2.bb7
3 files changed, 59 insertions, 2 deletions
diff --git a/recipes-kernel/linux/linux-ti33x-psp-3.2/beaglebone/0031-omap2-irq-process-all-4-irq-banks-for-am335x.patch b/recipes-kernel/linux/linux-ti33x-psp-3.2/beaglebone/0031-omap2-irq-process-all-4-irq-banks-for-am335x.patch
new file mode 100644
index 00000000..2007b5b1
--- /dev/null
+++ b/recipes-kernel/linux/linux-ti33x-psp-3.2/beaglebone/0031-omap2-irq-process-all-4-irq-banks-for-am335x.patch
@@ -0,0 +1,26 @@
1From d5f1df216fb51e1edc3e18b6b4c6d382141cf8dd Mon Sep 17 00:00:00 2001
2From: Koen Kooi <koen@dominion.thruhere.net>
3Date: Wed, 2 May 2012 13:51:57 +0200
4Subject: [PATCH 31/32] omap2+ irq: process all 4 irq banks for am335x
5
6Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
7---
8 arch/arm/mach-omap2/irq.c | 2 +-
9 1 file changed, 1 insertion(+), 1 deletion(-)
10
11diff --git a/arch/arm/mach-omap2/irq.c b/arch/arm/mach-omap2/irq.c
12index 1fef061..419b1a1 100644
13--- a/arch/arm/mach-omap2/irq.c
14+++ b/arch/arm/mach-omap2/irq.c
15@@ -212,7 +212,7 @@ static inline void omap_intc_handle_irq(void __iomem *base_addr, struct pt_regs
16 goto out;
17
18 irqnr = readl_relaxed(base_addr + 0xd8);
19-#ifdef CONFIG_SOC_OMAPTI816X
20+#if defined(CONFIG_SOC_OMAPTI816X) || defined(CONFIG_SOC_OMAPAM33XX)
21 if (irqnr)
22 goto out;
23 irqnr = readl_relaxed(base_addr + 0xf8);
24--
251.7.9.5
26
diff --git a/recipes-kernel/linux/linux-ti33x-psp-3.2/beaglebone/0032-omap2-irqs.h-increase-number-or-irq-banks.patch b/recipes-kernel/linux/linux-ti33x-psp-3.2/beaglebone/0032-omap2-irqs.h-increase-number-or-irq-banks.patch
new file mode 100644
index 00000000..beb63f3e
--- /dev/null
+++ b/recipes-kernel/linux/linux-ti33x-psp-3.2/beaglebone/0032-omap2-irqs.h-increase-number-or-irq-banks.patch
@@ -0,0 +1,28 @@
1From c551ce3e274195934304b16cc109204a987c4295 Mon Sep 17 00:00:00 2001
2From: Koen Kooi <koen@dominion.thruhere.net>
3Date: Wed, 2 May 2012 13:56:12 +0200
4Subject: [PATCH 32/32] omap2+ irqs.h: increase number or irq banks
5
6Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
7---
8 arch/arm/plat-omap/include/plat/irqs.h | 4 ++--
9 1 file changed, 2 insertions(+), 2 deletions(-)
10
11diff --git a/arch/arm/plat-omap/include/plat/irqs.h b/arch/arm/plat-omap/include/plat/irqs.h
12index ce6a73c..cc15272 100644
13--- a/arch/arm/plat-omap/include/plat/irqs.h
14+++ b/arch/arm/plat-omap/include/plat/irqs.h
15@@ -434,8 +434,8 @@
16
17 #define OMAP_IRQ_BIT(irq) (1 << ((irq) % 32))
18
19-#define INTCPS_NR_MIR_REGS 3
20-#define INTCPS_NR_IRQS 96
21+#define INTCPS_NR_MIR_REGS 4
22+#define INTCPS_NR_IRQS 128
23
24 #include <mach/hardware.h>
25
26--
271.7.9.5
28
diff --git a/recipes-kernel/linux/linux-ti33x-psp_3.2.bb b/recipes-kernel/linux/linux-ti33x-psp_3.2.bb
index f560a1d1..35d1b268 100644
--- a/recipes-kernel/linux/linux-ti33x-psp_3.2.bb
+++ b/recipes-kernel/linux/linux-ti33x-psp_3.2.bb
@@ -11,8 +11,8 @@ S = "${WORKDIR}/git"
11MULTI_CONFIG_BASE_SUFFIX = "" 11MULTI_CONFIG_BASE_SUFFIX = ""
12 12
13BRANCH = "v3.2-staging" 13BRANCH = "v3.2-staging"
14SRCREV = "e8004dad869568692ca2a45c04e8464ce48cc4d7" 14SRCREV = "0d0567b6c1a61a374120b985559768077c511a6d"
15MACHINE_KERNEL_PR_append = "d+gitr${SRCREV}" 15MACHINE_KERNEL_PR_append = "e+gitr${SRCREV}"
16 16
17COMPATIBLE_MACHINE = "(ti33x)" 17COMPATIBLE_MACHINE = "(ti33x)"
18 18
@@ -826,4 +826,7 @@ PATCHES_OVER_PSP = " \
826 file://beaglebone/0028-beaglebone-fix-ehrpwm-backlight.patch \ 826 file://beaglebone/0028-beaglebone-fix-ehrpwm-backlight.patch \
827 file://beaglebone/0029-beaglebone-also-report-cape-revision.patch \ 827 file://beaglebone/0029-beaglebone-also-report-cape-revision.patch \
828 file://beaglebone/0030-beaglebone-don-t-compare-undefined-characters-it-mak.patch \ 828 file://beaglebone/0030-beaglebone-don-t-compare-undefined-characters-it-mak.patch \
829 file://beaglebone/0031-omap2-irq-process-all-4-irq-banks-for-am335x.patch \
830 file://beaglebone/0032-omap2-irqs.h-increase-number-or-irq-banks.patch \
829" 831"
832