summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2012-05-22 08:06:24 +0200
committerDenys Dmytriyenko <denys@ti.com>2012-05-29 15:49:14 -0400
commit1078965795412744e1fc39ff8e0876665a79afed (patch)
tree2e937b690bbbab517f110ea5224165f42fb37441
parentd33058225df1156174db1131d964de1ef0ab3b48 (diff)
downloadmeta-ti-1078965795412744e1fc39ff8e0876665a79afed.tar.gz
linux-ti33x-psp 3.2: silence useless omap4 hwmod warning
This fixes the last remaining debug print shown when booting with 'quiet' Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r--recipes-kernel/linux/linux-ti33x-psp-3.2/beaglebone/0044-omap-hwmod-silence-st_shift-error.patch33
-rw-r--r--recipes-kernel/linux/linux-ti33x-psp_3.2.bb1
2 files changed, 34 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-ti33x-psp-3.2/beaglebone/0044-omap-hwmod-silence-st_shift-error.patch b/recipes-kernel/linux/linux-ti33x-psp-3.2/beaglebone/0044-omap-hwmod-silence-st_shift-error.patch
new file mode 100644
index 00000000..7991f0af
--- /dev/null
+++ b/recipes-kernel/linux/linux-ti33x-psp-3.2/beaglebone/0044-omap-hwmod-silence-st_shift-error.patch
@@ -0,0 +1,33 @@
1From 4119ec2ea20b7ae4095049e9f192c751559fbb87 Mon Sep 17 00:00:00 2001
2From: Koen Kooi <koen@dominion.thruhere.net>
3Date: Wed, 16 May 2012 17:57:31 +0200
4Subject: [PATCH] omap hwmod: silence st_shift error
5
6During boot the following error is shown:
7
8 [ 0.545227] omap_hwmod: wkup_m3: wkup_m3: hwmod data error: OMAP4 does not support st_shift
9
10Since this PSP tree will never run on omap4 remove the print so people will stop getting scared by it.
11
12Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
13---
14 arch/arm/mach-omap2/omap_hwmod.c | 3 ---
15 1 files changed, 0 insertions(+), 3 deletions(-)
16
17diff --git a/arch/arm/mach-omap2/omap_hwmod.c b/arch/arm/mach-omap2/omap_hwmod.c
18index bc14f9f..a050699 100644
19--- a/arch/arm/mach-omap2/omap_hwmod.c
20+++ b/arch/arm/mach-omap2/omap_hwmod.c
21@@ -1343,9 +1343,6 @@ static int _deassert_hardreset(struct omap_hwmod *oh, const char *name)
22 * Note: cpu_is_omap34xx is true for am33xx device as well.
23 */
24 if (cpu_is_omap44xx() || cpu_is_am33xx()) {
25- if (ohri.st_shift)
26- pr_err("omap_hwmod: %s: %s: hwmod data error: OMAP4 does not support st_shift\n",
27- oh->name, name);
28 ret = omap4_prminst_deassert_hardreset(ohri.rst_shift,
29 oh->clkdm->pwrdm.ptr->prcm_partition,
30 oh->clkdm->pwrdm.ptr->prcm_offs,
31--
321.7.7.6
33
diff --git a/recipes-kernel/linux/linux-ti33x-psp_3.2.bb b/recipes-kernel/linux/linux-ti33x-psp_3.2.bb
index 97c1cd03..0fe3d4f0 100644
--- a/recipes-kernel/linux/linux-ti33x-psp_3.2.bb
+++ b/recipes-kernel/linux/linux-ti33x-psp_3.2.bb
@@ -968,6 +968,7 @@ PATCHES_OVER_PSP = " \
968 file://beaglebone/0039-ARM-OMAP-Mux-Fixed-debugfs-mux-output-always-reporti.patch \ 968 file://beaglebone/0039-ARM-OMAP-Mux-Fixed-debugfs-mux-output-always-reporti.patch \
969 file://beaglebone/0040-beaglebone-export-SPI2-as-spidev-when-no-capes-are-u.patch \ 969 file://beaglebone/0040-beaglebone-export-SPI2-as-spidev-when-no-capes-are-u.patch \
970 file://beaglebone/0043-st7735fb-Working-WIP-changes-to-make-DMA-safe-and-ad.patch \ 970 file://beaglebone/0043-st7735fb-Working-WIP-changes-to-make-DMA-safe-and-ad.patch \
971 file://beaglebone/0044-omap-hwmod-silence-st_shift-error.patch \
971 file://beaglebone/0001-arm-boot-compressed-default-asm-arch-to-armv7-a.patch \ 972 file://beaglebone/0001-arm-boot-compressed-default-asm-arch-to-armv7-a.patch \
972 file://beaglebone/0045-cpws-phy_device-demote-PHY-message-to-INFO.patch \ 973 file://beaglebone/0045-cpws-phy_device-demote-PHY-message-to-INFO.patch \
973" 974"