summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2012-05-03 17:20:32 -0400
committerDenys Dmytriyenko <denys@ti.com>2012-05-10 21:00:29 -0400
commit051482e3b03ba7e2d6cecc0d8f85cc3be22dc8b2 (patch)
tree5aa30b89d8ef1229124a88383761e3474041e370
parent285aeaee513969ca7a79a344c75d0f590b722cb9 (diff)
downloadmeta-ti-051482e3b03ba7e2d6cecc0d8f85cc3be22dc8b2.tar.gz
linux-ti33x-psp 3.2: for beaglebone set default Asm architecture to armv7-a
Beaglebone kernel needs to be built in Thumb2 mode to achieve fast boot times. Unfortunately, that build is broken under newer binutils-2.22 with the below Assembler error. The fix is to pass the specific -march=armv7-a flag to the Assembler to make it work. | arch/arm/boot/compressed/head.S: Assembler messages: | arch/arm/boot/compressed/head.S:127: Error: selected processor does not support requested special purpose register -- `mrs r2,cpsr' | arch/arm/boot/compressed/head.S:134: Error: selected processor does not support requested special purpose register -- `mrs r2,cpsr' | arch/arm/boot/compressed/head.S:136: Error: selected processor does not support requested special purpose register -- `msr cpsr_c,r2' | make[2]: *** [arch/arm/boot/compressed/head.o] Error 1 | make[1]: *** [arch/arm/boot/compressed/vmlinux] Error 2 Signed-off-by: Denys Dmytriyenko <denys@ti.com> Acked-by: Koen Kooi <koen@circuitco.com>
-rw-r--r--recipes-kernel/linux/linux-ti33x-psp-3.2/beaglebone/0001-arm-boot-compressed-default-asm-arch-to-armv7-a.patch36
-rw-r--r--recipes-kernel/linux/linux-ti33x-psp_3.2.bb1
2 files changed, 37 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-ti33x-psp-3.2/beaglebone/0001-arm-boot-compressed-default-asm-arch-to-armv7-a.patch b/recipes-kernel/linux/linux-ti33x-psp-3.2/beaglebone/0001-arm-boot-compressed-default-asm-arch-to-armv7-a.patch
new file mode 100644
index 00000000..5037880f
--- /dev/null
+++ b/recipes-kernel/linux/linux-ti33x-psp-3.2/beaglebone/0001-arm-boot-compressed-default-asm-arch-to-armv7-a.patch
@@ -0,0 +1,36 @@
1From 6b87752bd00d12ac7c8db994480c077857e23bf0 Mon Sep 17 00:00:00 2001
2From: Denys Dmytriyenko <denys@ti.com>
3Date: Thu, 3 May 2012 16:04:16 -0400
4Subject: [PATCH] arch/arm/boot/compressed: set default Asm architecture to armv7-a
5
6This enables building compressed kernel with newer binutils-2.22 when kernel is
7built in Thumb2 mode. Otherwise it fails with the following Assembler error:
8
9| arch/arm/boot/compressed/head.S: Assembler messages:
10| arch/arm/boot/compressed/head.S:127: Error: selected processor does not support requested special purpose register -- `mrs r2,cpsr'
11| arch/arm/boot/compressed/head.S:134: Error: selected processor does not support requested special purpose register -- `mrs r2,cpsr'
12| arch/arm/boot/compressed/head.S:136: Error: selected processor does not support requested special purpose register -- `msr cpsr_c,r2'
13| make[2]: *** [arch/arm/boot/compressed/head.o] Error 1
14| make[1]: *** [arch/arm/boot/compressed/vmlinux] Error 2
15
16Signed-off-by: Denys Dmytriyenko <denys@ti.com>
17---
18 arch/arm/boot/compressed/Makefile | 2 +-
19 1 files changed, 1 insertions(+), 1 deletions(-)
20
21diff --git a/arch/arm/boot/compressed/Makefile b/arch/arm/boot/compressed/Makefile
22index 21f56ff..e01d370 100644
23--- a/arch/arm/boot/compressed/Makefile
24+++ b/arch/arm/boot/compressed/Makefile
25@@ -123,7 +123,7 @@ KBUILD_CFLAGS = $(subst -pg, , $(ORIG_CFLAGS))
26 endif
27
28 ccflags-y := -fpic -fno-builtin -I$(obj)
29-asflags-y := -Wa,-march=all
30+asflags-y := -Wa,-march=armv7-a
31
32 # Supply kernel BSS size to the decompressor via a linker symbol.
33 KBSS_SZ = $(shell size $(obj)/../../../../vmlinux | awk 'END{print $$3}')
34--
351.7.8.5
36
diff --git a/recipes-kernel/linux/linux-ti33x-psp_3.2.bb b/recipes-kernel/linux/linux-ti33x-psp_3.2.bb
index 63c0532d..d1dfaaf1 100644
--- a/recipes-kernel/linux/linux-ti33x-psp_3.2.bb
+++ b/recipes-kernel/linux/linux-ti33x-psp_3.2.bb
@@ -958,4 +958,5 @@ PATCHES_OVER_PSP = " \
958 file://beaglebone/0031-beaglebone-fix-3.5-cape-support.patch \ 958 file://beaglebone/0031-beaglebone-fix-3.5-cape-support.patch \
959 file://beaglebone/0032-beaglebone-connect-batterycape-GPIO-to-gpio-charger.patch \ 959 file://beaglebone/0032-beaglebone-connect-batterycape-GPIO-to-gpio-charger.patch \
960 file://beaglebone/0033-beaglebone-add-support-for-CAN-and-RS232-cape.patch \ 960 file://beaglebone/0033-beaglebone-add-support-for-CAN-and-RS232-cape.patch \
961 file://beaglebone/0001-arm-boot-compressed-default-asm-arch-to-armv7-a.patch \
961" 962"