summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2012-06-07 17:40:44 +0200
committerDenys Dmytriyenko <denys@ti.com>2012-06-11 16:59:08 -0400
commit03092005396f548c401ebbea5bf670c31614992a (patch)
tree9c9b13f80066238ff802b4f0333c92dc60cd3bc8
parentc5e5c304b86a398d65330f430330ce5f730b56c5 (diff)
downloadmeta-ti-03092005396f548c401ebbea5bf670c31614992a.tar.gz
beaglebone-capes: add support for weatherstation cape
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r--recipes-ti/beagleboard/beaglebone-capes.bb2
-rwxr-xr-xrecipes-ti/beagleboard/beaglebone-capes/cape.sh6
2 files changed, 7 insertions, 1 deletions
diff --git a/recipes-ti/beagleboard/beaglebone-capes.bb b/recipes-ti/beagleboard/beaglebone-capes.bb
index 2a9f1fb2..b463a893 100644
--- a/recipes-ti/beagleboard/beaglebone-capes.bb
+++ b/recipes-ti/beagleboard/beaglebone-capes.bb
@@ -3,7 +3,7 @@ DESCRIPTION = "Userspace setup for beaglebone capes"
3LICENSE = "MIT" 3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58" 4LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58"
5 5
6PR = "r2" 6PR = "r3"
7 7
8inherit allarch 8inherit allarch
9 9
diff --git a/recipes-ti/beagleboard/beaglebone-capes/cape.sh b/recipes-ti/beagleboard/beaglebone-capes/cape.sh
index 61240a5f..566cdf5f 100755
--- a/recipes-ti/beagleboard/beaglebone-capes/cape.sh
+++ b/recipes-ti/beagleboard/beaglebone-capes/cape.sh
@@ -10,6 +10,12 @@ for eeprom in /sys/bus/i2c/devices/3-005*/eeprom ; do
10 echo "Turning on backlight for LCD4 cape" 10 echo "Turning on backlight for LCD4 cape"
11 i2cset -f -y 1 0x24 0x07 0x09 11 i2cset -f -y 1 0x24 0x07 0x09
12 i2cset -f -y 1 0x24 0x08 0x60;; 12 i2cset -f -y 1 0x24 0x08 0x60;;
13 "BB-BONE-WTHR-01.")
14 echo "Initializing I2C devices"
15 echo sht21 0x40 > /sys/class/i2c-adapter/i2c-3/new_device
16 echo bmp085 0x77 > /sys/class/i2c-adapter/i2c-3/new_device
17 echo tsl2550 0x39 > /sys/class/i2c-adapter/i2c-3/new_device
18 echo 1 > /sys/bus/i2c/devices/3-0039/operating_mode;;
13 *) 19 *)
14 echo "unknown cape: $PARTNUMBER";; 20 echo "unknown cape: $PARTNUMBER";;
15 esac 21 esac