summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMahesh Radhakrishnan <m-radhakrishnan2@ti.com>2019-03-14 09:18:09 +0000
committerDenys Dmytriyenko <denys@ti.com>2019-03-18 18:16:45 +0000
commit2901824acb7962e84f2c0d8fe99a96e4063cd6db (patch)
tree67c2724aba28a9a728d261fb127362e7ca3caf51
parentb691fb99ee3267405fbb1df6fa5a7e188909204d (diff)
downloadmeta-ti-2901824acb7962e84f2c0d8fe99a96e4063cd6db.tar.gz
ti-cgt-arm: Update to version 18.1.5 LTS
The license checksum change is due to version number. License has not been changed. However Patrick powell license which was missing earlier has been added now. Signed-off-by: Mahesh Radhakrishnan <m-radhakrishnan2@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r--recipes-ti/devtools/ti-cgt-arm-native_16.9.9.bb6
-rw-r--r--recipes-ti/devtools/ti-cgt-arm-native_18.1.5.bb6
-rw-r--r--recipes-ti/devtools/ti-cgt-arm.inc16
3 files changed, 8 insertions, 20 deletions
diff --git a/recipes-ti/devtools/ti-cgt-arm-native_16.9.9.bb b/recipes-ti/devtools/ti-cgt-arm-native_16.9.9.bb
deleted file mode 100644
index f642a5b5..00000000
--- a/recipes-ti/devtools/ti-cgt-arm-native_16.9.9.bb
+++ /dev/null
@@ -1,6 +0,0 @@
1include ti-cgt-arm.inc
2
3LIC_FILES_CHKSUM = "file://ti-cgt-arm_${PV}.LTS/README.txt;md5=1c0dc8c15d8c4768e399b9ce7651c25e"
4
5BINFILE_MD5 = "ccae16e9c6fc3749e7da49d3a2b6fb44"
6BINFILE_SHA256 = "13b66686cc012af6f2e7f021099b5bc735a461d8eb254a2b0edef0fd8b26e81e"
diff --git a/recipes-ti/devtools/ti-cgt-arm-native_18.1.5.bb b/recipes-ti/devtools/ti-cgt-arm-native_18.1.5.bb
new file mode 100644
index 00000000..0ed19391
--- /dev/null
+++ b/recipes-ti/devtools/ti-cgt-arm-native_18.1.5.bb
@@ -0,0 +1,6 @@
1include ti-cgt-arm.inc
2
3LIC_FILES_CHKSUM = "file://ti-cgt-arm_${PV}.LTS/README.txt;md5=3faed35326711d6596f0377279323df1"
4
5BINFILE_MD5 = "d0559bccc323002a9256dd68e1d223ab"
6BINFILE_SHA256 = "8462eb7ce837274582721ed75c73928865d7678aca23b30fde962cdd36c21414"
diff --git a/recipes-ti/devtools/ti-cgt-arm.inc b/recipes-ti/devtools/ti-cgt-arm.inc
index d55b55b4..d2d768ce 100644
--- a/recipes-ti/devtools/ti-cgt-arm.inc
+++ b/recipes-ti/devtools/ti-cgt-arm.inc
@@ -1,6 +1,6 @@
1SUMMARY = "TI ARM Code Generation Tools" 1SUMMARY = "TI ARM Code Generation Tools"
2HOMEPAGE = "https://www-a.ti.com/downloads/sds_support/TICodegenerationTools/download.htm" 2HOMEPAGE = "https://www-a.ti.com/downloads/sds_support/TICodegenerationTools/download.htm"
3LICENSE = "(TI-TSPA & Thai-Open-Source-Software-Center) & BSD-3-Clause & BSL-1.0 & Hewlett-Packard & AFL-3.0 & MIT & BSD-2-Clause & PD & BSD-4-Clause" 3LICENSE = "(TI-TSPA & Thai-Open-Source-Software-Center) & BSD-3-Clause & BSL-1.0 & Hewlett-Packard & Patrick-Powell & AFL-3.0 & MIT & BSD-2-Clause & PD & BSD-4-Clause"
4 4
5inherit native 5inherit native
6require recipes-ti/includes/ti-unpack.inc 6require recipes-ti/includes/ti-unpack.inc
@@ -9,7 +9,7 @@ require recipes-ti/includes/ti-paths.inc
9 9
10S = "${WORKDIR}/ti-cgt-arm-${PV}" 10S = "${WORKDIR}/ti-cgt-arm-${PV}"
11 11
12PR = "r2" 12PR = "r0"
13 13
14SRC_URI = "http://software-dl.ti.com/codegen/esd/cgt_public_sw/TMS470/${PV}.LTS/${BINFILE};name=${BINFILE_NAME}" 14SRC_URI = "http://software-dl.ti.com/codegen/esd/cgt_public_sw/TMS470/${PV}.LTS/${BINFILE};name=${BINFILE_NAME}"
15 15
@@ -17,18 +17,6 @@ BINFILE = "ti_cgt_tms470_${PV}.LTS_linux_installer_x86.bin"
17TI_BIN_UNPK_ARGS = "--prefix ${S}" 17TI_BIN_UNPK_ARGS = "--prefix ${S}"
18TI_BIN_UNPK_CMDS = "" 18TI_BIN_UNPK_CMDS = ""
19 19
20do_configure_append() {
21 # Remove the library if it exists to prevent an error when building the
22 # library in do_compile().
23 rm -f ./ti-cgt-arm_${PV}.LTS/lib/rtsv7R4_A_le_v3D16_eabi.lib
24}
25
26do_compile_append() {
27 cd ${S}/ti-cgt-arm_${PV}.LTS
28 export PATH=${PATH}:${S}/ti-cgt-arm_${PV}.LTS/bin
29 lib/mklib --pattern=rtsv7R4_A_le_v3D16_eabi.lib
30}
31
32do_install() { 20do_install() {
33 install -d ${D}${M4_TOOLCHAIN_INSTALL_DIR_RECIPE} 21 install -d ${D}${M4_TOOLCHAIN_INSTALL_DIR_RECIPE}
34 cp -r ${S}/ti-cgt-arm*/. ${D}${M4_TOOLCHAIN_INSTALL_DIR_RECIPE} 22 cp -r ${S}/ti-cgt-arm*/. ${D}${M4_TOOLCHAIN_INSTALL_DIR_RECIPE}