summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJacob Stiffler <j-stiffler@ti.com>2018-02-14 00:18:47 +0000
committerDenys Dmytriyenko <denys@ti.com>2018-02-14 15:28:46 -0500
commit7d52a5bde038f2646b3dd4cf806d4a34c31095c6 (patch)
tree2287b8a3dc1504156ddcf339a9cc8b26a6980c62
parentd2568081f862908e46ecd5c35cb1aa740afda9ee (diff)
downloadmeta-ti-7d52a5bde038f2646b3dd4cf806d4a34c31095c6.tar.gz
ti-xdctools: do not create target package
* ti-xdctools is a host development package, but the target recipe is needed to create the sourceipk used in SDKs. * And move class extension to common include. Signed-off-by: Jacob Stiffler <j-stiffler@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r--recipes-ti/devtools/ti-xdctools-common.inc6
-rw-r--r--recipes-ti/devtools/ti-xdctools_3.50.03.33.bb4
2 files changed, 5 insertions, 5 deletions
diff --git a/recipes-ti/devtools/ti-xdctools-common.inc b/recipes-ti/devtools/ti-xdctools-common.inc
index 17166caf..d2d0df45 100644
--- a/recipes-ti/devtools/ti-xdctools-common.inc
+++ b/recipes-ti/devtools/ti-xdctools-common.inc
@@ -7,10 +7,14 @@ require recipes-ti/includes/ti-paths.inc
7require recipes-ti/includes/ti-staging.inc 7require recipes-ti/includes/ti-staging.inc
8 8
9do_install() { 9do_install() {
10 CP_ARGS="-Prf --preserve=mode,timestamps --no-preserve=ownership"
11
10 install -d ${D}${XDC_INSTALL_DIR_RECIPE} 12 install -d ${D}${XDC_INSTALL_DIR_RECIPE}
11 cp -pPrf ${S}/* ${D}${XDC_INSTALL_DIR_RECIPE} 13 cp ${CP_ARGS} ${S}/* ${D}${XDC_INSTALL_DIR_RECIPE}
12} 14}
13 15
16BBCLASSEXTEND = "native nativesdk"
17
14INHIBIT_PACKAGE_STRIP = "1" 18INHIBIT_PACKAGE_STRIP = "1"
15INHIBIT_SYSROOT_STRIP = "1" 19INHIBIT_SYSROOT_STRIP = "1"
16INHIBIT_PACKAGE_DEBUG_SPLIT = "1" 20INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
diff --git a/recipes-ti/devtools/ti-xdctools_3.50.03.33.bb b/recipes-ti/devtools/ti-xdctools_3.50.03.33.bb
index 6ab2b94a..73ab3bdf 100644
--- a/recipes-ti/devtools/ti-xdctools_3.50.03.33.bb
+++ b/recipes-ti/devtools/ti-xdctools_3.50.03.33.bb
@@ -7,7 +7,3 @@ LIC_FILES_CHKSUM = "file://docs/license/xdc/shelf/package.html;beginline=1;endli
7 7
8SRC_URI[xdczip.md5sum] = "21310b647275a7c7dd5b37dcb96c0b1b" 8SRC_URI[xdczip.md5sum] = "21310b647275a7c7dd5b37dcb96c0b1b"
9SRC_URI[xdczip.sha256sum] = "afe8616773e63b01e79e8cfacaf4d2c8d3b92c798c7f8cf5d1c7b5fe2060bbe4" 9SRC_URI[xdczip.sha256sum] = "afe8616773e63b01e79e8cfacaf4d2c8d3b92c798c7f8cf5d1c7b5fe2060bbe4"
10
11FILES_${PN} += "${XDC_INSTALL_DIR_RECIPE}"
12
13BBCLASSEXTEND = "native nativesdk"