summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSam Nelson <sam.nelson@ti.com>2017-10-17 09:19:49 +0000
committerDenys Dmytriyenko <denys@ti.com>2017-10-19 02:52:47 -0400
commit02008598e0d5f503a532d1f768e42aba161ede59 (patch)
tree85cd29c46b5c45542a046b37672715bcc0507d3e
parentb0531c2266f8138f91d5fd69f8c86fbf7d0770f1 (diff)
downloadmeta-ti-02008598e0d5f503a532d1f768e42aba161ede59.tar.gz
gcc-arm-none-eabi-native: Add recipe for new version 6-2017-q1-update
The source location changed to developer.arm.com compared to previous version Signed-off-by: Sam Nelson <sam.nelson@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r--recipes-ti/devtools/gcc-arm-none-eabi-native_6-2017-q1-update.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes-ti/devtools/gcc-arm-none-eabi-native_6-2017-q1-update.bb b/recipes-ti/devtools/gcc-arm-none-eabi-native_6-2017-q1-update.bb
new file mode 100644
index 00000000..1140f27a
--- /dev/null
+++ b/recipes-ti/devtools/gcc-arm-none-eabi-native_6-2017-q1-update.bb
@@ -0,0 +1,23 @@
1DESCRIPTION = "Baremetal GCC for ARM"
2LICENSE = "GPL-3.0-with-GCC-exception & GPLv3"
3
4LIC_FILES_CHKSUM = "file://share/doc/gcc-arm-none-eabi/license.txt;md5=c224e429f53a1a6ce70bf8986ea2990b"
5
6inherit native
7require recipes-ti/includes/ti-paths.inc
8
9SRC_URI = "https://developer.arm.com/-/media/Files/downloads/gnu-rm/6_1-2017q1/gcc-arm-none-eabi-6-2017-q1-update-linux.tar.bz2;name=gcc-arm-none"
10
11SRC_URI[gcc-arm-none.md5sum] = "30004c24f4632bc594952462bb0cd1c9"
12SRC_URI[gcc-arm-none.sha256sum] = "e7aad2579f02e3b095c6d7899ca5e6a70cfa9b8a8cbd6abd868da849d416c2eb"
13
14S = "${WORKDIR}/gcc-arm-none-eabi-6-2017-q1-update"
15
16do_install() {
17 install -d ${D}${GCC_ARM_NONE_TOOLCHAIN_RECIPE}
18 cp -r ${S}/. ${D}${GCC_ARM_NONE_TOOLCHAIN_RECIPE}
19}
20
21FILES_${PN} = "${GCC_ARM_NONE_TOOLCHAIN_RECIPE}/*"
22
23INSANE_SKIP_${PN} = "already-stripped"