summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@konsulko.com>2022-02-22 04:12:57 +0000
committerRyan Eatmon <reatmon@ti.com>2022-02-22 12:01:30 -0600
commitcd64b0e06490cdc5de63178fb6145d561c85186f (patch)
treea7f1f7ed2033a7244732d9a6d894284d870d6e41
parent209da2791f911235faaf4104ebf289b0e11d975b (diff)
downloadmeta-ti-cd64b0e06490cdc5de63178fb6145d561c85186f.tar.gz
x-load: remove deprecated first stage X-Loader bootloader
X-Loader was originally used on OMAP3/4 platforms, but eventually got replaced by U-boot SPL. Signed-off-by: Denys Dmytriyenko <denys@konsulko.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
-rw-r--r--recipes-bsp/x-load/signgp.bb20
-rw-r--r--recipes-bsp/x-load/signgp/signGP.c108
-rw-r--r--recipes-bsp/x-load/x-load.inc58
-rw-r--r--recipes-bsp/x-load/x-load/0001-Beagle-Rev-C5-support.patch60
-rw-r--r--recipes-bsp/x-load/x-load/panda-frefclk.patch193
-rw-r--r--recipes-bsp/x-load/x-load_1.46-psp.bb38
-rw-r--r--recipes-bsp/x-load/x-load_git.bb22
7 files changed, 0 insertions, 499 deletions
diff --git a/recipes-bsp/x-load/signgp.bb b/recipes-bsp/x-load/signgp.bb
deleted file mode 100644
index 479e6f81..00000000
--- a/recipes-bsp/x-load/signgp.bb
+++ /dev/null
@@ -1,20 +0,0 @@
1LICENSE = "BSD-3-Clause"
2DESCRIPTION = "Tool to sign omap3 x-loader images"
3LIC_FILES_CHKSUM = "file://signGP.c;md5=960f484fea13941ca88821366f9dade0"
4
5SRC_URI = "file://signGP.c"
6
7do_compile() {
8 ${CC} ${CFLAGS} ${LDFLAGS} ${WORKDIR}/signGP.c -o signGP
9}
10
11do_install() {
12 install -d ${D}${bindir}
13 install -m 0755 signGP ${D}${bindir}
14}
15
16S = "${WORKDIR}"
17
18NATIVE_INSTALL_WORKS = "1"
19
20BBCLASSEXTEND = "native nativesdk"
diff --git a/recipes-bsp/x-load/signgp/signGP.c b/recipes-bsp/x-load/signgp/signGP.c
deleted file mode 100644
index 93250640..00000000
--- a/recipes-bsp/x-load/signgp/signGP.c
+++ /dev/null
@@ -1,108 +0,0 @@
1/*
2 * Copyright (C) 2010 Texas Instruments Incorporated - http://www.ti.com/
3 *
4 *
5 * Redistribution and use in source and binary forms, with or without
6 * modification, are permitted provided that the following conditions
7 * are met:
8 *
9 * Redistributions of source code must retain the above copyright
10 * notice, this list of conditions and the following disclaimer.
11 *
12 * Redistributions in binary form must reproduce the above copyright
13 * notice, this list of conditions and the following disclaimer in the
14 * documentation and/or other materials provided with the
15 * distribution.
16 *
17 * Neither the name of Texas Instruments Incorporated nor the names of
18 * its contributors may be used to endorse or promote products derived
19 * from this software without specific prior written permission.
20 *
21 * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
22 * "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
23 * LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
24 * A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
25 * OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
26 * SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
27 * LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
28 * DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
29 * THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
30 * (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
31 * OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
32 *
33*/
34
35
36//
37// signGP.c
38// Read the x-load.bin file and write out the x-load.bin.ift file.
39// The signed image is the original pre-pended with the size of the image
40// and the load address. If not entered on command line, file name is
41// assumed to be x-load.bin in current directory and load address is
42// 0x40200800.
43
44#include <stdio.h>
45#include <stdlib.h>
46#include <fcntl.h>
47#include <sys/stat.h>
48#include <string.h>
49#include <malloc.h>
50
51
52main(int argc, char *argv[])
53{
54 int i;
55 char ifname[FILENAME_MAX], ofname[FILENAME_MAX], ch;
56 FILE *ifile, *ofile;
57 unsigned long loadaddr, len;
58 struct stat sinfo;
59
60
61 // Default to x-load.bin and 0x40200800.
62 strcpy(ifname, "x-load.bin");
63 loadaddr = 0x40200800;
64
65 if ((argc == 2) || (argc == 3))
66 strcpy(ifname, argv[1]);
67
68 if (argc == 3)
69 loadaddr = strtol(argv[2], NULL, 16);
70
71 // Form the output file name.
72 strcpy(ofname, ifname);
73 strcat(ofname, ".ift");
74
75 // Open the input file.
76 ifile = fopen(ifname, "rb");
77 if (ifile == NULL) {
78 printf("Cannot open %s\n", ifname);
79 exit(0);
80 }
81
82 // Get file length.
83 stat(ifname, &sinfo);
84 len = sinfo.st_size;
85
86 // Open the output file and write it.
87 ofile = fopen(ofname, "wb");
88 if (ofile == NULL) {
89 printf("Cannot open %s\n", ofname);
90 fclose(ifile);
91 exit(0);
92 }
93
94 // Pad 1 sector of zeroes.
95 //ch = 0x00;
96 //for (i=0; i<0x200; i++)
97 // fwrite(&ch, 1, 1, ofile);
98
99 fwrite(&len, 1, 4, ofile);
100 fwrite(&loadaddr, 1, 4, ofile);
101 for (i=0; i<len; i++) {
102 fread(&ch, 1, 1, ifile);
103 fwrite(&ch, 1, 1, ofile);
104 }
105
106 fclose(ifile);
107 fclose(ofile);
108}
diff --git a/recipes-bsp/x-load/x-load.inc b/recipes-bsp/x-load/x-load.inc
deleted file mode 100644
index bb700e46..00000000
--- a/recipes-bsp/x-load/x-load.inc
+++ /dev/null
@@ -1,58 +0,0 @@
1DESCRIPTION = "x-load bootloader loader"
2SECTION = "bootloaders"
3LICENSE = "GPLv2+"
4
5LIC_FILES_CHKSUM = "file://common/cmd_load.c;beginline=4;endline=22;md5=14420d7cc8dfb427d17ad407ddf8dc89"
6
7PARALLEL_MAKE = ""
8
9EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX} CONFIG_HEADER=${CONFIG_HEADER}"
10
11XLOAD_MACHINE ?= "${MACHINE}_config"
12
13XLOAD_IMAGE ?= "x-load-${MACHINE}-${PV}-${PR}.bin.ift"
14XLOAD_SYMLINK ?= "x-load-${MACHINE}.bin.ift"
15XLOAD_USB_IMAGE ?= "x-load-usb-${MACHINE}-${PV}-${PR}.bin"
16XLOAD_USB_SYMLINK ?= "x-load-usb-${MACHINE}.bin"
17MLO_IMAGE ?= "MLO-${MACHINE}-${PV}-${PR}"
18MLO_SYMLINK ?= "MLO-${MACHINE}"
19MLO_SYMLINK_NOMACHINE ?= "MLO"
20XLOAD_LOAD_ADDRESS ?= "0x40200800"
21
22do_compile () {
23 unset LDFLAGS
24 unset CFLAGS
25 unset CPPFLAGS
26 oe_runmake distclean
27 oe_runmake ${XLOAD_MACHINE}
28 oe_runmake ift
29}
30
31do_install () {
32 install -d ${D}/boot
33 install ${S}/x-load.bin.ift ${D}/boot/${MLO_IMAGE}
34 ln -sf ${MLO_IMAGE} ${D}/boot/${MLO_SYMLINK_NOMACHINE}
35}
36
37FILES:${PN} = "/boot"
38
39inherit deploy
40
41addtask deploy before do_package after do_install
42
43do_deploy () {
44 install -d ${DEPLOY_DIR_IMAGE}
45 install ${S}/x-load.bin.ift ${DEPLOY_DIR_IMAGE}/${XLOAD_IMAGE}
46 install ${S}/x-load.bin ${DEPLOY_DIR_IMAGE}/${XLOAD_USB_IMAGE}
47 install ${S}/x-load.bin.ift ${DEPLOY_DIR_IMAGE}/${MLO_IMAGE}
48
49 cd ${DEPLOY_DIR_IMAGE}
50 rm -f ${XLOAD_SYMLINK}
51 ln -sf ${XLOAD_IMAGE} ${XLOAD_SYMLINK}
52 rm -f ${XLOAD_USB_SYMLINK}
53 ln -sf ${XLOAD_USB_IMAGE} ${XLOAD_USB_SYMLINK}
54 rm -f ${MLO_SYMLINK}
55 ln -sf ${MLO_IMAGE} ${MLO_SYMLINK}
56 rm -f ${MLO_SYMLINK_NOMACHINE}
57 ln -sf ${MLO_IMAGE} ${MLO_SYMLINK_NOMACHINE}
58}
diff --git a/recipes-bsp/x-load/x-load/0001-Beagle-Rev-C5-support.patch b/recipes-bsp/x-load/x-load/0001-Beagle-Rev-C5-support.patch
deleted file mode 100644
index 1c67bd35..00000000
--- a/recipes-bsp/x-load/x-load/0001-Beagle-Rev-C5-support.patch
+++ /dev/null
@@ -1,60 +0,0 @@
1From 992eb6ff881792f5c753ef6c85be0ceb2d162c78 Mon Sep 17 00:00:00 2001
2From: Joel Fernandes <agnel.joel@gmail.com>
3Date: Tue, 7 Jun 2011 09:50:03 +0200
4Subject: [PATCH] Beagle Rev C5 support
5
6---
7 board/omap3530beagle/omap3530beagle.c | 16 ++++++++++++++++
8 1 files changed, 16 insertions(+), 0 deletions(-)
9
10diff --git a/board/omap3530beagle/omap3530beagle.c b/board/omap3530beagle/omap3530beagle.c
11index 15943f5..2b8c3c0 100644
12--- a/board/omap3530beagle/omap3530beagle.c
13+++ b/board/omap3530beagle/omap3530beagle.c
14@@ -281,6 +281,7 @@ u32 wait_on_value(u32 read_bit_mask, u32 match_value, u32 read_addr, u32 bound)
15
16 #define MICRON_DDR 0
17 #define NUMONYX_MCP 1
18+#define MICRON_MCP 2
19 int identify_xm_ddr()
20 {
21 int mfr, id;
22@@ -303,6 +304,8 @@ int identify_xm_ddr()
23 return MICRON_DDR;
24 if ((mfr == 0x20) && (id == 0xba))
25 return NUMONYX_MCP;
26+ if ((mfr == 0x2c) && (id == 0xbc))
27+ return MICRON_MCP;
28 }
29 /*********************************************************************
30 * config_3430sdram_ddr() - Init DDR on 3430SDP dev board.
31@@ -329,6 +332,17 @@ void config_3430sdram_ddr(void)
32 __raw_writel(NUMONYX_V_ACTIMB_165, SDRC_ACTIM_CTRLB_1);
33 __raw_writel(SDP_3430_SDRC_RFR_CTRL_165MHz, SDRC_RFR_CTRL_0);
34 __raw_writel(SDP_3430_SDRC_RFR_CTRL_165MHz, SDRC_RFR_CTRL_1);
35+ } else if (identify_xm_ddr() == MICRON_MCP) {
36+ /* Beagleboard Rev C5 */
37+ __raw_writel(0x2, SDRC_CS_CFG); /* 256MB/bank */
38+ __raw_writel(SDP_SDRC_MDCFG_0_DDR_MICRON_XM, SDRC_MCFG_0);
39+ __raw_writel(SDP_SDRC_MDCFG_0_DDR_MICRON_XM, SDRC_MCFG_1);
40+ __raw_writel(MICRON_V_ACTIMA_200, SDRC_ACTIM_CTRLA_0);
41+ __raw_writel(MICRON_V_ACTIMB_200, SDRC_ACTIM_CTRLB_0);
42+ __raw_writel(MICRON_V_ACTIMA_200, SDRC_ACTIM_CTRLA_1);
43+ __raw_writel(MICRON_V_ACTIMB_200, SDRC_ACTIM_CTRLB_1);
44+ __raw_writel(SDP_3430_SDRC_RFR_CTRL_200MHz, SDRC_RFR_CTRL_0);
45+ __raw_writel(SDP_3430_SDRC_RFR_CTRL_200MHz, SDRC_RFR_CTRL_1);
46 } else {
47 __raw_writel(0x1, SDRC_CS_CFG); /* 128MB/bank */
48 __raw_writel(SDP_SDRC_MDCFG_0_DDR, SDRC_MCFG_0);
49@@ -699,6 +713,8 @@ int misc_init_r(void)
50 case REVISION_C4:
51 if (identify_xm_ddr() == NUMONYX_MCP)
52 printf("Beagle Rev C4 from Special Computing\n");
53+ else if(identify_xm_ddr() == MICRON_MCP)
54+ printf("Beagle Rev C5\n");
55 else
56 printf("Beagle Rev C4\n");
57 break;
58--
591.6.6.1
60
diff --git a/recipes-bsp/x-load/x-load/panda-frefclk.patch b/recipes-bsp/x-load/x-load/panda-frefclk.patch
deleted file mode 100644
index a893376a..00000000
--- a/recipes-bsp/x-load/x-load/panda-frefclk.patch
+++ /dev/null
@@ -1,193 +0,0 @@
1Delivered-To: koen@dominion.thruhere.net
2Received: by 10.236.61.2 with SMTP id v2cs463572yhc;
3 Mon, 11 Jul 2011 00:39:44 -0700 (PDT)
4Received: by 10.236.79.69 with SMTP id h45mr4010171yhe.342.1310369983896;
5 Mon, 11 Jul 2011 00:39:43 -0700 (PDT)
6Return-Path: <x-loader+bncCKvc3d-lHRC70erwBBoEmZF8Og@googlegroups.com>
7Received: from mail-gx0-f189.google.com (mail-gx0-f189.google.com [209.85.161.189])
8 by mx.google.com with ESMTPS id u61si41782290yhm.15.2011.07.11.00.39.43
9 (version=TLSv1/SSLv3 cipher=OTHER);
10 Mon, 11 Jul 2011 00:39:43 -0700 (PDT)
11Received-SPF: pass (google.com: domain of x-loader+bncCKvc3d-lHRC70erwBBoEmZF8Og@googlegroups.com designates 209.85.161.189 as permitted sender) client-ip=209.85.161.189;
12Authentication-Results: mx.google.com; spf=pass (google.com: domain of x-loader+bncCKvc3d-lHRC70erwBBoEmZF8Og@googlegroups.com designates 209.85.161.189 as permitted sender) smtp.mail=x-loader+bncCKvc3d-lHRC70erwBBoEmZF8Og@googlegroups.com; dkim=pass (test mode) header.i=@googlegroups.com
13Received: by gxk3 with SMTP id 3sf9821900gxk.6
14 for <koen@dominion.thruhere.net>; Mon, 11 Jul 2011 00:39:43 -0700 (PDT)
15DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed;
16 d=googlegroups.com; s=beta;
17 h=mime-version:x-beenthere:received-spf:from:to:cc:subject:date
18 :message-id:x-mailer:in-reply-to:references:x-original-sender
19 :x-original-authentication-results:reply-to:precedence:mailing-list
20 :list-id:x-google-group-id:list-post:list-help:list-archive:sender
21 :list-subscribe:list-unsubscribe:content-type;
22 bh=knz/OIehyS1eNPnUO3PKelxTOdkGPG+fRW2FJ4AriF0=;
23 b=cjz/o/2YFMmEgHKdtY7SmdxjqN+uxnJluh9MGSOmA+kVKkPYzbv4SXQQEcjFMBrXXw
24 pCUO8G8BylJJLTBTeRDAcji73YDd65OKsc6UoAyrSUtxtj4sgKXBVwaLu0eS+1Efsyl3
25 +5g8sPqNFFG3tcvYD30FjtHZwLFyCTAtU2g18=
26Received: by 10.101.142.10 with SMTP id u10mr495069ann.24.1310369979330;
27 Mon, 11 Jul 2011 00:39:39 -0700 (PDT)
28MIME-Version: 1.0
29X-BeenThere: x-loader@googlegroups.com
30Received: by 10.101.164.36 with SMTP id r36ls170737ano.5.gmail; Mon, 11 Jul
31 2011 00:39:38 -0700 (PDT)
32Received: by 10.101.126.20 with SMTP id d20mr158105ann.0.1310369978730;
33 Mon, 11 Jul 2011 00:39:38 -0700 (PDT)
34Received: by 10.101.126.20 with SMTP id d20mr158104ann.0.1310369978718;
35 Mon, 11 Jul 2011 00:39:38 -0700 (PDT)
36Received: from mail-yx0-f181.google.com (mail-yx0-f181.google.com [209.85.213.181])
37 by gmr-mx.google.com with ESMTPS id i19si12624205anq.3.2011.07.11.00.39.37
38 (version=TLSv1/SSLv3 cipher=OTHER);
39 Mon, 11 Jul 2011 00:39:37 -0700 (PDT)
40Received-SPF: neutral (google.com: 209.85.213.181 is neither permitted nor denied by best guess record for domain of ricardo.salveti@linaro.org) client-ip=209.85.213.181;
41Received: by mail-yx0-f181.google.com with SMTP id 13so1644271yxi.12
42 for <x-loader@googlegroups.com>; Mon, 11 Jul 2011 00:39:37 -0700 (PDT)
43Received: by 10.150.53.14 with SMTP id b14mr3957102yba.181.1310369977490;
44 Mon, 11 Jul 2011 00:39:37 -0700 (PDT)
45Received: from localhost.localdomain ([201.82.65.93])
46 by mx.google.com with ESMTPS id s21sm510693ybm.15.2011.07.11.00.39.34
47 (version=TLSv1/SSLv3 cipher=OTHER);
48 Mon, 11 Jul 2011 00:39:35 -0700 (PDT)
49From: Ricardo Salveti de Araujo <ricardo.salveti@linaro.org>
50To: x-loader@googlegroups.com
51Cc: patches@linaro.org,
52 Ricardo Salveti de Araujo <ricardo.salveti@linaro.org>
53Subject: [x-loader] [PATCH v2] omap4: pandaboard: ehci fref_clkout per board revision
54Date: Mon, 11 Jul 2011 04:39:17 -0300
55Message-Id: <1310369957-28444-1-git-send-email-ricardo.salveti@linaro.org>
56X-Mailer: git-send-email 1.7.4.1
57In-Reply-To: <1305973002-28352-1-git-send-email-ricardo.salveti@linaro.org>
58References: <1305973002-28352-1-git-send-email-ricardo.salveti@linaro.org>
59X-Original-Sender: ricardo.salveti@linaro.org
60X-Original-Authentication-Results: gmr-mx.google.com; spf=neutral (google.com:
61 209.85.213.181 is neither permitted nor denied by best guess record for
62 domain of ricardo.salveti@linaro.org) smtp.mail=ricardo.salveti@linaro.org
63Reply-To: x-loader@googlegroups.com
64Precedence: list
65Mailing-list: list x-loader@googlegroups.com; contact x-loader+owners@googlegroups.com
66List-ID: <x-loader.googlegroups.com>
67X-Google-Group-Id: 243713986749
68List-Post: <http://groups.google.com/group/x-loader/post?hl=en_US>, <mailto:x-loader@googlegroups.com>
69List-Help: <http://groups.google.com/support/?hl=en_US>, <mailto:x-loader+help@googlegroups.com>
70List-Archive: <http://groups.google.com/group/x-loader?hl=en_US>
71Sender: x-loader@googlegroups.com
72List-Subscribe: <http://groups.google.com/group/x-loader/subscribe?hl=en_US>, <mailto:x-loader+subscribe@googlegroups.com>
73List-Unsubscribe: <http://groups.google.com/group/x-loader/subscribe?hl=en_US>,
74 <mailto:x-loader+unsubscribe@googlegroups.com>
75Content-Type: text/plain; charset=ISO-8859-1
76
77Add support for correctly configuring the fref_clkout depending on the
78board revision of the pandaboard. This patch is necessary to make u-boot
79work with the smsc usb+ethernet driver.
80
81Tested USB+Eth with TFTP and PXE using linaro u-boot:
82http://git.linaro.org/gitweb?p=boot/u-boot-linaro-stable.git;a=summary
83
84Based on patch from David Anders <x0132446@ti.com> from
85omap4_panda_L24.9 branch at gitorious.org/pandaboard x-loader tree.
86
87Changes since v1:
88 * Moving the code from s_init instead of adding a new block
89
90Signed-off-by: Ricardo Salveti de Araujo <ricardo.salveti@linaro.org>
91---
92 board/omap4430panda/omap4430panda.c | 58 +++++++++++++++-------------------
93 1 files changed, 26 insertions(+), 32 deletions(-)
94
95diff --git a/board/omap4430panda/omap4430panda.c b/board/omap4430panda/omap4430panda.c
96index 9b4e457..bcee6fe 100644
97--- a/board/omap4430panda/omap4430panda.c
98+++ b/board/omap4430panda/omap4430panda.c
99@@ -531,6 +531,7 @@ static void ddr_init(void)
100 *****************************************/
101 int board_init(void)
102 {
103+ unsigned int rev = omap_revision();
104 unsigned int v;
105
106 /*
107@@ -546,10 +547,32 @@ int board_init(void)
108 v = __raw_readl(OMAP44XX_GPIO_BASE2 + __GPIO_DATAOUT);
109 __raw_writel((v & ~(1 << 30)), OMAP44XX_GPIO_BASE2 + __GPIO_DATAOUT);
110
111- /* kill USB PLL */
112+ if (rev == OMAP4430_ES1_0)
113+ return 0;
114
115- v = __raw_readl(CM_CLKMODE_DPLL_USB);
116- __raw_writel((v & ~7) | 1, CM_CLKMODE_DPLL_USB);
117+ if (__raw_readl(OMAP44XX_GPIO_BASE6 + __GPIO_DATAIN) & (1 << 22)) {
118+ /* enable software ioreq */
119+ sr32(OMAP44XX_SCRM_AUXCLK3, 8, 1, 0x1);
120+ /* set for sys_clk (38.4MHz) */
121+ sr32(OMAP44XX_SCRM_AUXCLK3, 1, 2, 0x0);
122+ /* set divisor to 2 */
123+ sr32(OMAP44XX_SCRM_AUXCLK3, 16, 4, 0x1);
124+ /* set the clock source to active */
125+ sr32(OMAP44XX_SCRM_ALTCLKSRC, 0, 1, 0x1);
126+ /* enable clocks */
127+ sr32(OMAP44XX_SCRM_ALTCLKSRC, 2, 2, 0x3);
128+ } else {
129+ /* enable software ioreq */
130+ sr32(OMAP44XX_SCRM_AUXCLK1, 8, 1, 0x1);
131+ /* set for PER_DPLL */
132+ sr32(OMAP44XX_SCRM_AUXCLK1, 1, 2, 0x2);
133+ /* set divisor to 16 */
134+ sr32(OMAP44XX_SCRM_AUXCLK1, 16, 4, 0xf);
135+ /* set the clock source to active */
136+ sr32(OMAP44XX_SCRM_ALTCLKSRC, 0, 1, 0x1);
137+ /* enable clocks */
138+ sr32(OMAP44XX_SCRM_ALTCLKSRC, 2, 2, 0x3);
139+ }
140
141 return 0;
142 }
143@@ -683,8 +706,6 @@ static int scale_vcores(void)
144
145 void s_init(void)
146 {
147- unsigned int rev = omap_revision();
148-
149 /*
150 * this is required to survive the muxconf in the case the ROM
151 * started up USB OTG
152@@ -707,33 +728,6 @@ void s_init(void)
153 /* setup_auxcr(get_device_type(), external_boot); */
154
155 ddr_init();
156-
157- if (rev == OMAP4430_ES1_0)
158- return;
159-
160- if (__raw_readl(OMAP44XX_GPIO_BASE6 + __GPIO_DATAIN) & (1 << 22)) {
161- /* enable software ioreq */
162- sr32(OMAP44XX_SCRM_AUXCLK3, 8, 1, 0x1);
163- /* set for sys_clk (38.4MHz) */
164- sr32(OMAP44XX_SCRM_AUXCLK3, 1, 2, 0x0);
165- /* set divisor to 2 */
166- sr32(OMAP44XX_SCRM_AUXCLK3, 16, 4, 0x1);
167- /* set the clock source to active */
168- sr32(OMAP44XX_SCRM_ALTCLKSRC, 0, 1, 0x1);
169- /* enable clocks */
170- sr32(OMAP44XX_SCRM_ALTCLKSRC, 2, 2, 0x3);
171- } else {
172- /* enable software ioreq */
173- sr32(OMAP44XX_SCRM_AUXCLK1, 8, 1, 0x1);
174- /* set for PER_DPLL */
175- sr32(OMAP44XX_SCRM_AUXCLK1, 1, 2, 0x2);
176- /* set divisor to 16 */
177- sr32(OMAP44XX_SCRM_AUXCLK1, 16, 4, 0xf);
178- /* set the clock source to active */
179- sr32(OMAP44XX_SCRM_ALTCLKSRC, 0, 1, 0x1);
180- /* enable clocks */
181- sr32(OMAP44XX_SCRM_ALTCLKSRC, 2, 2, 0x3);
182- }
183 }
184
185 /*******************************************************
186--
1871.7.4.1
188
189--
190--
191To unsubscribe from this group, email: x-loader+unsubscribe@googlegroups.com
192For more options: http://groups.google.com/group/x-loader?hl=en?hl=en
193Home Page: http://gitorious.org/x-loader
diff --git a/recipes-bsp/x-load/x-load_1.46-psp.bb b/recipes-bsp/x-load/x-load_1.46-psp.bb
deleted file mode 100644
index cc9ad3f7..00000000
--- a/recipes-bsp/x-load/x-load_1.46-psp.bb
+++ /dev/null
@@ -1,38 +0,0 @@
1require x-load.inc
2
3DEPENDS += "signgp-native"
4
5LIC_FILES_CHKSUM = "file://README;md5=fb7a7e60aceaa99c529b6c667dfcf474"
6
7COMPATIBLE_MACHINE = "am3517-evm"
8
9PV = "1.46+${PR}+gitr${SRCREV}"
10PR ="r0"
11PE = "1"
12
13# TI PSP v1.46_OMAPPSP_03.00.01.06 (Tag is one commit different)
14SRCREV:pn-${PN} = "fc6d5be15c703d21aef0ae0b8c02177721f0445f"
15SRC_URI = "git://arago-project.org/git/projects/x-load-omap3.git;protocol=git"
16
17S = "${WORKDIR}/git"
18
19do_compile () {
20 unset LDFLAGS
21 unset CFLAGS
22 unset CPPFLAGS
23 oe_runmake distclean
24 oe_runmake ${XLOAD_MACHINE}
25 oe_runmake
26}
27
28do_install () {
29 signGP x-load.bin ${XLOAD_LOAD_ADDRESS}
30
31 install -d ${D}/boot
32 install x-load.bin.ift ${D}/boot/${MLO_IMAGE}
33 ln -sf ${MLO_IMAGE} ${D}/boot/${MLO_SYMLINK_NOMACHINE}
34}
35
36FILES:${PN} = "/boot"
37
38PACKAGE_ARCH = "${MACHINE_ARCH}"
diff --git a/recipes-bsp/x-load/x-load_git.bb b/recipes-bsp/x-load/x-load_git.bb
deleted file mode 100644
index 0234c574..00000000
--- a/recipes-bsp/x-load/x-load_git.bb
+++ /dev/null
@@ -1,22 +0,0 @@
1require x-load.inc
2
3#FILESPATHPKG_prepend = "x-load-git:x-load-git/${MACHINE}"
4
5PV = "1.5.1"
6PR ="r3"
7PE = "1"
8
9SRCREV:pn-${PN} = "c4289f1bee035dea41536c5ba5e1bc36c7d493c4"
10SRC_URI = "git://gitorious.org/x-loader/x-loader.git;branch=master;protocol=git \
11"
12
13S = "${WORKDIR}/git"
14
15XLOAD_MACHINE:beagleboard = "omap3530beagle_config"
16CONFIG_HEADER:beagleboard = "1"
17XLOAD_MACHINE:omap3-touchbook = "omap3530beagle_config"
18
19PACKAGE_ARCH = "${MACHINE_ARCH}"
20
21COMPATIBLE_HOST ?= "null"
22COMPATIBLE_HOST:ti-soc = "(.*)"